summaryrefslogtreecommitdiff
path: root/games-rpg/gwiz/gwiz-0.8-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-rpg/gwiz/gwiz-0.8-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'games-rpg/gwiz/gwiz-0.8-r1.ebuild')
-rw-r--r--games-rpg/gwiz/gwiz-0.8-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/games-rpg/gwiz/gwiz-0.8-r1.ebuild b/games-rpg/gwiz/gwiz-0.8-r1.ebuild
new file mode 100644
index 000000000000..f7a462a9a302
--- /dev/null
+++ b/games-rpg/gwiz/gwiz-0.8-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils flag-o-matic
+
+DESCRIPTION="clone of old-school Wizardry(tm) games by SirTech"
+HOMEPAGE="http://icculus.org/gwiz/"
+SRC_URI="http://icculus.org/gwiz/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND=">=media-libs/libsdl-1.2.3[joystick,video]
+ >=media-libs/sdl-image-1.2.1-r1[png]
+ >=media-libs/sdl-ttf-2.0.4"
+RDEPEND=${DEPEND}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-buffer.patch
+)
+
+src_prepare() {
+ default
+
+ append-cflags -std=gnu89 # build with gcc5 (bug #572532)
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog README doc/HOWTO-PLAY" \
+ default
+ newicon pixmaps/gwiz_icon.xpm ${PN}.xpm
+ make_desktop_entry gwiz Gwiz
+}