summaryrefslogtreecommitdiff
path: root/games-rpg/kqlives/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /games-rpg/kqlives/files
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'games-rpg/kqlives/files')
-rw-r--r--games-rpg/kqlives/files/kqlives-0.99_autoconf.patch93
-rw-r--r--games-rpg/kqlives/files/kqlives-0.99_dumb2.patch13
-rw-r--r--games-rpg/kqlives/files/kqlives-0.99_gcc10.patch13
3 files changed, 119 insertions, 0 deletions
diff --git a/games-rpg/kqlives/files/kqlives-0.99_autoconf.patch b/games-rpg/kqlives/files/kqlives-0.99_autoconf.patch
new file mode 100644
index 000000000000..dc4a5f9d4534
--- /dev/null
+++ b/games-rpg/kqlives/files/kqlives-0.99_autoconf.patch
@@ -0,0 +1,93 @@
+diff --git a/Makefile.am b/Makefile.am
+index 799b2c0..ff49ce2 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,8 +1,8 @@
+ SUBDIRS = intl po scripts
+-bin_PROGRAMS = kq mapdraw mapdiff mapdump $(MAPDRAW2)
+-EXTRA_PROGRAMS = mapdraw2
++bin_PROGRAMS = kqlives kqlives-mapdraw kqlives-mapdiff kqlives-mapdump $(MAPDRAW2)
++EXTRA_PROGRAMS = kqlives-mapdraw2
+
+-kq_SOURCES = src/enemyc.c src/intrface.c src/sgame.c src/bounds.c \
++kqlives_SOURCES = src/enemyc.c src/intrface.c src/sgame.c src/bounds.c \
+ src/combat.c src/entity.c src/movement.c src/shopmenu.c \
+ src/credits.c src/eqpmenu.c src/itemmenu.c src/music.c src/timing.c \
+ src/disk.c src/eskill.c src/kq.c src/res.c \
+@@ -20,29 +20,29 @@ kq_SOURCES = src/enemyc.c src/intrface.c src/sgame.c src/bounds.c \
+ include/eskill.h include/magic.h include/selector.h \
+ include/bounds.h include/gettext.h include/console.h
+
+-EXTRA_kq_SOURCES = src/unix.c src/osx.m src/beos.c src/win.c src/dos.c src/winres.rc
+-kq_LDADD = $(kq_extra_files) $(ALLEGRO_LIBS) $(LIBINTL)
+-kq_DEPENDENCIES = $(kq_extra_files)
++EXTRA_kqlives_SOURCES = src/unix.c src/osx.m src/beos.c src/win.c src/dos.c src/winres.rc
++kqlives_LDADD = $(kq_extra_files) $(ALLEGRO_LIBS) $(LIBINTL)
++kqlives_DEPENDENCIES = $(kq_extra_files)
+
+-mapdraw_SOURCES = maps/mapdata.c maps/mapdraw.h maps/mapedit.c \
++kqlives_mapdraw_SOURCES = maps/mapdata.c maps/mapdraw.h maps/mapedit.c \
+ maps/mapfile.c maps/mapent.c maps/mapshared.c src/disk.c \
+ maps/mapstructs.c src/bounds.c include/disk.h include/structs.h
+-mapdraw_LDADD = $(ALLEGRO_LIBS) $(LIBINTL)
++kqlives_mapdraw_LDADD = $(ALLEGRO_LIBS) $(LIBINTL)
+
+-mapdraw2_SOURCES = maps/mapdraw2.c maps/mapdraw2.h \
++kqlives_mapdraw2_SOURCES = maps/mapdraw2.c maps/mapdraw2.h \
+ maps/mainwindow.c maps/mapedit2.c maps/mapedit2.h \
+ maps/mapshared.c maps/mapdraw.h src/disk.c \
+ src/bounds.c include/disk.h include/structs.h
+-mapdraw2_LDADD = $(GTK_LIBS) $(ALLEGRO_LIBS) $(LIBINTL)
+-mapdraw2_CPPFLAGS = $(AM_CPPFLAGS) $(GTK_CFLAGS)
++kqlives_mapdraw2_LDADD = $(GTK_LIBS) $(ALLEGRO_LIBS) $(LIBINTL)
++kqlives_mapdraw2_CPPFLAGS = $(AM_CPPFLAGS) $(GTK_CFLAGS)
+
+-mapdiff_SOURCES = maps/mapdraw.h maps/mapdiff.c src/disk.c \
++kqlives_mapdiff_SOURCES = maps/mapdraw.h maps/mapdiff.c src/disk.c \
+ include/disk.h include/structs.h
+-mapdiff_LDADD = $(ALLEGRO_LIBS) $(LIBINTL)
++kqlives_mapdiff_LDADD = $(ALLEGRO_LIBS) $(LIBINTL)
+
+-mapdump_SOURCES = maps/mapdump.c maps/mapshared.c maps/mapdata.c \
++kqlives_mapdump_SOURCES = maps/mapdump.c maps/mapshared.c maps/mapdata.c \
+ src/disk.c src/bounds.c include/disk.h include/structs.h
+-mapdump_LDADD = $(ALLEGRO_LIBS) $(LIBINTL)
++kqlives_mapdump_LDADD = $(ALLEGRO_LIBS) $(LIBINTL)
+
+ APPR=KQ.app/Contents/Resources
+ KQ.app: kq
+@@ -88,10 +88,10 @@ dist_music_DATA = music/aa_arofl.xm music/exp.s3m music/oxford.s3m \
+
+ musicdir = $(pkgdatadir)/music
+
+-dist_man_MANS = debian/kq.6
++dist_man_MANS = debian/kqlives.6
+
+ AM_CPPFLAGS = $(WARNING_CFLAGS) -I$(top_srcdir)/include \
+- -DKQ_BIN=\"$(bindir)/kq$(EXEEXT)\" \
++ -DKQ_BIN=\"$(bindir)/kqlives$(EXEEXT)\" \
+ -DKQ_DATA=\"$(pkgdatadir)\" \
+ -DKQ_LIB=\"$(pkglibdir)\" \
+ -DKQ_LOCALE=\"$(localedir)\" \
+diff --git a/configure.ac b/configure.ac
+index 679d74f..48db735 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -2,7 +2,7 @@
+ # Process this file with autoconf to produce a configure script.
+
+ AC_PREREQ(2.61)
+-AC_INIT([KQ],[0.99],[peterhull90@users.sourceforge.net])
++AC_INIT([KQLIVES],[0.99],[peterhull90@users.sourceforge.net])
+ AC_CONFIG_SRCDIR([src/kq.c])
+ AC_CONFIG_HEADER([config.h])
+ AC_CANONICAL_BUILD
+@@ -88,7 +88,7 @@ AC_SEARCH_LIBS(lua_gettop, lua50 lua5.1 lua, [], [AC_MSG_ERROR([Lua not found])]
+ PKG_CHECK_MODULES(GTK, [gtk+-2.0 >= 2.8.0 libglade-2.0 >= 2.4.0],
+ [AC_SUBST(GTK_LIBS)
+ AC_SUBST(GTK_CFLAGS)
+- MAPDRAW2="mapdraw2${EXEEXT}"],
++ MAPDRAW2="kqlives-mapdraw2${EXEEXT}"],
+ [MAPDRAW2=""])
+ AC_SUBST(MAPDRAW2)
+
diff --git a/games-rpg/kqlives/files/kqlives-0.99_dumb2.patch b/games-rpg/kqlives/files/kqlives-0.99_dumb2.patch
new file mode 100644
index 000000000000..943145b44763
--- /dev/null
+++ b/games-rpg/kqlives/files/kqlives-0.99_dumb2.patch
@@ -0,0 +1,13 @@
+diff --git a/src/music.c b/src/music.c
+index 94c2786..1912d4d 100644
+--- a/src/music.c
++++ b/src/music.c
+@@ -125,7 +125,7 @@ void play_music (const char *music_name, long position)
+ stop_music ();
+ strcpy (filename, kqres (MUSIC_DIR, music_name));
+ if (strstr (filename, ".mod"))
+- mod_song[current_music_player] = dumb_load_mod (filename);
++ mod_song[current_music_player] = dumb_load_mod (filename, 0);
+
+ else if (strstr (filename, ".xm"))
+ mod_song[current_music_player] = dumb_load_xm (filename);
diff --git a/games-rpg/kqlives/files/kqlives-0.99_gcc10.patch b/games-rpg/kqlives/files/kqlives-0.99_gcc10.patch
new file mode 100644
index 000000000000..693b993cdbdf
--- /dev/null
+++ b/games-rpg/kqlives/files/kqlives-0.99_gcc10.patch
@@ -0,0 +1,13 @@
+diff --git a/maps/mapshared.c b/maps/mapshared.c
+index 47fa7af..0c05d81 100644
+--- a/maps/mapshared.c
++++ b/maps/mapshared.c
+@@ -129,7 +129,7 @@ unsigned short *map, *b_map, *f_map, *c_map, *cf_map, *cb_map;
+ unsigned char *z_map, *sh_map, *o_map, *cz_map, *csh_map, *co_map;
+ unsigned char *search_map;
+
+-s_bound bound_box[MAX_BOUNDS]; // WK - not redundant. Used on line 266
++extern s_bound bound_box[MAX_BOUNDS]; // WK - not redundant. Used on line 266
+
+ /*! \brief Blit to screen
+ *