summaryrefslogtreecommitdiff
path: root/games-rpg/the-royal-trap
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
commit51af5f0eb4cddbe6aa7953717873691d77aae9ff (patch)
tree1541525274162b033ebbc3ed38abaf335fbbd49a /games-rpg/the-royal-trap
parent7014a5a3ea0feffab9701fdd6b64cc7667a985af (diff)
gentoo resync : 11.07.2019
Diffstat (limited to 'games-rpg/the-royal-trap')
-rw-r--r--games-rpg/the-royal-trap/Manifest3
-rw-r--r--games-rpg/the-royal-trap/metadata.xml18
-rw-r--r--games-rpg/the-royal-trap/the-royal-trap-1.2.ebuild41
3 files changed, 62 insertions, 0 deletions
diff --git a/games-rpg/the-royal-trap/Manifest b/games-rpg/the-royal-trap/Manifest
new file mode 100644
index 000000000000..22968b0ba2af
--- /dev/null
+++ b/games-rpg/the-royal-trap/Manifest
@@ -0,0 +1,3 @@
+DIST The_Royal_Trap_HD_1.2-linux-x86.tar 193616345 BLAKE2B f43eb162abd077b1b2dde85012652704049c18830d0e8eb5ee4aa60b05d4b123b0fe9388aec70154b0d6e8d6a89e12fba06aacf50d5026d2391e6ad90af3d5ba SHA512 d6c0172a35e36fc6e42f1c9827e99f814cd9084a2d94042b9fd2b9a0ffd4ac1adb7c898a6579b856cfde548073b1d34a49fb6ba80d4a6c6bce682673094eff0d
+EBUILD the-royal-trap-1.2.ebuild 1065 BLAKE2B 8fa6bab526cd296f628fe98567225687a208fb131a6ae2bdeb9165138ae3af1cfd8bcc61b4a6bc0fd66857dcaf5566edc2b16fd4448dd26c34f0a705697ad188 SHA512 00bb5d9d02c93040a4eece2fb9b3ef998dacb47797efe34d96ad94895fc7dc6d50a5db0e5a8b7b87f5e1c7f08ca9c916784505131d4164ad70b381105bf151d2
+MISC metadata.xml 720 BLAKE2B a9b4464da7a46fa7e074d18a0e610b11df7fea0e79ad203cd1dc21e35d34be1d6a3dcc232eb88f2ab35a7aed0bd8007c060f82cc5f9cf7b0ed1f86673c77c78c SHA512 48a73c80d55bc4c2617e6f71288747ffb702efc9b3b071c046d502e6272fb9d48fc567bcce03d13de37d60fbff67517007c33f1f038c375969be343b02f6f52b
diff --git a/games-rpg/the-royal-trap/metadata.xml b/games-rpg/the-royal-trap/metadata.xml
new file mode 100644
index 000000000000..59e01fb5b2fa
--- /dev/null
+++ b/games-rpg/the-royal-trap/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <longdescription>
+ Madeleine Valois is a prince's companion. Her job is to guide
+ and advise him, to make him look good so that he can land a
+ royal bride. It is her responsibility to keep him out of
+ trouble - not to let him walk blindly into a political
+ minefield, not to let him get arrested for a crime he didn't
+ commit, and definitely not to let him fall in love with her.
+
+ Unfortunately, events are not going according to plan...
+ </longdescription>
+</pkgmetadata>
diff --git a/games-rpg/the-royal-trap/the-royal-trap-1.2.ebuild b/games-rpg/the-royal-trap/the-royal-trap-1.2.ebuild
new file mode 100644
index 000000000000..dccd9ca8f22a
--- /dev/null
+++ b/games-rpg/the-royal-trap/the-royal-trap-1.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop eutils xdg-utils
+
+RENPY_SLOT="6.99"
+MY_PN="The Royal Trap"
+
+DESCRIPTION="Visual novel where you help a prince choose his royal bride"
+HOMEPAGE="https://www.hanakogames.com/royaltrap.shtml"
+SRC_URI="${MY_PN// /_}_HD_${PV}-linux-x86.tar"
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="bindist fetch"
+
+RDEPEND="games-engines/renpy:${RENPY_SLOT}"
+
+S="${WORKDIR}/${MY_PN} HD ${PV}-linux-x86"
+
+pkg_nofetch() {
+ einfo "If you have ${SRC_URI} as distributed by Humble Bundle then move"
+ einfo "it to your distfiles directory. If you have some other version then"
+ einfo "please contact the Gentoo Games team."
+}
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins -r game/*
+
+ make_wrapper ${PN} "renpy-${RENPY_SLOT} '${EPREFIX}/usr/share/${PN}'"
+ make_desktop_entry ${PN} "${MY_PN}" applications-games
+
+ docinto html
+ dodoc README.html
+}
+
+pkg_postinst() { xdg_icon_cache_update; }
+pkg_postrm() { xdg_icon_cache_update; }