summaryrefslogtreecommitdiff
path: root/games-rpg/wastesedge/wastesedge-0.3.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-rpg/wastesedge/wastesedge-0.3.5-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'games-rpg/wastesedge/wastesedge-0.3.5-r1.ebuild')
-rw-r--r--games-rpg/wastesedge/wastesedge-0.3.5-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/games-rpg/wastesedge/wastesedge-0.3.5-r1.ebuild b/games-rpg/wastesedge/wastesedge-0.3.5-r1.ebuild
new file mode 100644
index 000000000000..2f28fcfac7b9
--- /dev/null
+++ b/games-rpg/wastesedge/wastesedge-0.3.5-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+inherit eutils python-single-r1
+
+DESCRIPTION="role playing game to showcase the adonthell engine"
+HOMEPAGE="http://adonthell.linuxgames.com/"
+SRC_URI="https://savannah.nongnu.org/download/adonthell/${PN}-src-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="userpriv"
+
+RDEPEND="${PYTHON_DEPS}
+ >=games-rpg/adonthell-0.3.5-r2[${PYTHON_USEDEP}]
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_configure(){
+ econf \
+ $(use_enable nls) \
+ --with-adonthell-binary="/usr/bin/adonthell"
+}
+
+src_install(){
+ emake DESTDIR="${D}" pixmapdir=/usr/share/pixmaps install
+ dodoc AUTHORS ChangeLog NEWS PLAYING README
+ make_desktop_entry adonthell-wastesedge "Waste's Edge" wastesedge_32x32
+}