summaryrefslogtreecommitdiff
path: root/games-rpg/wastesedge/wastesedge-0.3.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /games-rpg/wastesedge/wastesedge-0.3.8.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'games-rpg/wastesedge/wastesedge-0.3.8.ebuild')
-rw-r--r--games-rpg/wastesedge/wastesedge-0.3.8.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/games-rpg/wastesedge/wastesedge-0.3.8.ebuild b/games-rpg/wastesedge/wastesedge-0.3.8.ebuild
new file mode 100644
index 000000000000..1138036c0acd
--- /dev/null
+++ b/games-rpg/wastesedge/wastesedge-0.3.8.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit autotools python-single-r1 xdg
+
+DESCRIPTION="Role playing game to showcase the adonthell engine"
+HOMEPAGE="http://adonthell.nongnu.org/download/"
+SRC_URI="https://savannah.nongnu.org/download/adonthell/${PN}-src-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="nls"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=games-rpg/adonthell-0.3.8[${PYTHON_SINGLE_USEDEP}]
+ nls? ( virtual/libintl )"
+BDEPEND="nls? ( sys-devel/gettext )"
+
+PATCHES=( "${FILESDIR}/${P}_version-handling.patch" )
+DOCS=( AUTHORS ChangeLog NEWS PLAYING README )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ --with-adonthell-binary="/usr/bin/adonthell"
+}