summaryrefslogtreecommitdiff
path: root/games-server/crossfire-server/crossfire-server-1.75.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-15 00:13:03 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-15 00:13:03 +0000
commit770d63f36dbe1722e0ff9ab55eeca49986f01527 (patch)
treebe9aae0ef5001e4669f914ac9ad9b4eaa4db8500 /games-server/crossfire-server/crossfire-server-1.75.0-r1.ebuild
parent4fda045f90a4e301329bddb766e2e12a0b4401de (diff)
gentoo auto-resync : 15:02:2025 - 00:13:02HEADnextmaster
Diffstat (limited to 'games-server/crossfire-server/crossfire-server-1.75.0-r1.ebuild')
-rw-r--r--games-server/crossfire-server/crossfire-server-1.75.0-r1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/games-server/crossfire-server/crossfire-server-1.75.0-r1.ebuild b/games-server/crossfire-server/crossfire-server-1.75.0-r1.ebuild
new file mode 100644
index 000000000000..57b8bdecb757
--- /dev/null
+++ b/games-server/crossfire-server/crossfire-server-1.75.0-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P="${P/-server/}"
+DESCRIPTION="Server for the crossfire clients"
+HOMEPAGE="https://crossfire.real-time.com/"
+SRC_URI="https://downloads.sourceforge.net/crossfire/crossfire-server/${PV}/crossfire-${PV}.tar.gz
+ https://downloads.sourceforge.net/crossfire/crossfire-maps/${PV}/crossfire-maps-${PV}.tar.gz"
+DEPEND="${RDEPEND}"
+S="${WORKDIR}/${MY_P}"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X"
+RESTRICT="test"
+
+RDEPEND="
+ net-misc/curl
+ sys-libs/zlib
+ virtual/libcrypt:=
+ X? (
+ x11-libs/libXaw
+ media-libs/libpng:0=
+ )
+"
+
+PATCHES=( "${FILESDIR}/${P}-incompatible-func-pointers.patch" )
+
+src_prepare() {
+ default
+
+ # bug #236205
+ rm -f "${WORKDIR}"/maps/Info/combine.pl || die
+# ln -s "${WORKDIR}"/arch "${S}"/lib || die
+
+ eapply "${FILESDIR}"/${P}-format.patch
+}
+
+src_compile() {
+ # work around the collect.pl locking
+ emake -j1 -C lib
+ emake
+}
+
+src_install() {
+ default
+
+ keepdir /var/lib/crossfire/{account,datafiles,maps,players,template-maps,unique-items}
+
+ insinto /usr/share/crossfire
+ doins -r "${WORKDIR}"/maps
+
+ find "${ED}" -name '*.la' -delete || die
+}