summaryrefslogtreecommitdiff
path: root/games-server/monopd/monopd-0.10.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-server/monopd/monopd-0.10.2-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'games-server/monopd/monopd-0.10.2-r1.ebuild')
-rw-r--r--games-server/monopd/monopd-0.10.2-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/games-server/monopd/monopd-0.10.2-r1.ebuild b/games-server/monopd/monopd-0.10.2-r1.ebuild
new file mode 100644
index 000000000000..c0776e83d646
--- /dev/null
+++ b/games-server/monopd/monopd-0.10.2-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils systemd
+
+DESCRIPTION="server for atlantik games"
+HOMEPAGE="http://gtkatlantic.gradator.net/"
+SRC_URI="http://download.tuxfamily.org/gtkatlantic/monopd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="systemd"
+
+RDEPEND="systemd? ( sys-apps/systemd )"
+DEPEND="${RDEPEND}
+ >=dev-cpp/muParser-2
+ dev-libs/utfcpp"
+
+src_prepare() {
+ default
+
+ sed "s:GENTOO_DIR:\"/usr/bin\":" \
+ "${FILESDIR}"/monopd.in > "${T}"/monopd || die
+ sed -i \
+ -e "s:/usr/sbin:/usr/bin:" \
+ doc/systemd/monopd.service || die
+ sed -i \
+ -e '/C_SUBST(CXXFLAGS/s/CFLAGS/CXXFLAGS/' \
+ configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with systemd systemd-daemon)
+}
+
+src_install() {
+ default
+ doinitd "${T}"/monopd
+ systemd_dounit doc/systemd/monopd.s*
+}