summaryrefslogtreecommitdiff
path: root/games-simulation
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-03-11 01:49:36 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-03-11 01:49:36 +0000
commitcf7807d7aea23a99a144afceaba961cfed652b5f (patch)
treeffd2c781c27e0b7e72152a685a04938a2b7966f0 /games-simulation
parent7c5ebaf83da4c538dd11b56fdd5dfdf39dcbc096 (diff)
gentoo auto-resync : 11:03:2025 - 01:49:36HEADmaster
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/EmptyEpsilon/EmptyEpsilon-2022.10.28.ebuild16
-rw-r--r--games-simulation/EmptyEpsilon/Manifest2
-rw-r--r--games-simulation/Manifest.gzbin3771 -> 3769 bytes
3 files changed, 3 insertions, 15 deletions
diff --git a/games-simulation/EmptyEpsilon/EmptyEpsilon-2022.10.28.ebuild b/games-simulation/EmptyEpsilon/EmptyEpsilon-2022.10.28.ebuild
index 2e760b51db7f..1f1c5dd24e42 100644
--- a/games-simulation/EmptyEpsilon/EmptyEpsilon-2022.10.28.ebuild
+++ b/games-simulation/EmptyEpsilon/EmptyEpsilon-2022.10.28.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit cmake toolchain-funcs
+inherit cmake
# basis_universal version
MY_BU_VER="1_15_update2"
@@ -46,18 +46,6 @@ PATCHES=(
"${FILESDIR}/${PN}-cmake-meshoptimizer.patch"
)
-pkg_pretend() {
- [[ ${MERGE_TYPE} == "binary" ]] && return
-
- if tc-is-gcc; then
- if [[ $(gcc-major-version) -lt 11 ]]; then
- # ld: /usr/lib64/libsfml-audio.so: undefined reference to `std::__throw_bad_array_new_length()@GLIBCXX_3.a4.29'
- eerror "${PN} requires GCC >= 11. Run gcc-config to switch your default compiler."
- die "Need at least GCC >= 11"
- fi
- fi
-}
-
src_prepare() {
cmake_src_prepare
diff --git a/games-simulation/EmptyEpsilon/Manifest b/games-simulation/EmptyEpsilon/Manifest
index 5f3b2acce63c..919912c002bd 100644
--- a/games-simulation/EmptyEpsilon/Manifest
+++ b/games-simulation/EmptyEpsilon/Manifest
@@ -6,5 +6,5 @@ DIST SeriousProton-2022.10.28-add-missing-cstdint-include.patch 850 BLAKE2B f193
DIST SeriousProton-2022.10.28.tar.gz 2668713 BLAKE2B 9f200881bfa812904cd37428eb2bb2f8e04c46a134e8b3fceb0e02e87fe4bd7e529e1fbaf18cb4e284ec7ee4d1c6e8606f35e7ec3e61efa66816a7b354d446b9 SHA512 7955ed78529c0f69d6fd3ef6fac5537009548cdfe1cf8e47dc1fac8919fc3532e03453869968369f027c40dd4da513cfd84e58ffedaddd4b9d9fe67d28406be7
DIST basis_universal_1_15_update2.tar.gz 13283133 BLAKE2B 5400d23f86dd581da1bc96c1b95eae58f3c97b5412ad1d09d7f4ffd2ae7cae6cb14330795380e253579cc17f1ee16c91555229268219c300905da1420c0d8717 SHA512 a898a057b57ac64f6c0bf5fce0b599e23421ccdd015ea7bb668bce8b9292ef55b098f3d05854a2fb5363959932b75cd0a842664ae7d4f71f3537dc11301c1b32
DIST meshoptimizer-0.16.tar.gz 342571 BLAKE2B 2b4e244ea3676f109c904261d47bd0e7b2ad440f23d65325d34281ed13ac09657116c96b5a56860a0107479773b58c21018c8825b314f87a05bce38341fd75c1 SHA512 cc6d28359fb99a615e1046a4af1b247cbc6ea0266d9e7f41ea0516c1fc09fa1e67376071daf138a126c77bca3baf9d565636ed0e3adf045f1a08498c38b7a7e7
-EBUILD EmptyEpsilon-2022.10.28.ebuild 3313 BLAKE2B 6ca242823d873f5ff1253b5839aed380b7b7a2070a792240b366fdde19cd762b030a936e05d34b9f36e524199ceaa6cf027a7f8883248b031e677095002db68a SHA512 fa466763638a47d68eedf3d45b74c0f256bedc176b7c5cb9e5eae48e3e97370c0a904579bb015544b89b5c4bf009575d47d111690b37dffb2df4cd613df80655
+EBUILD EmptyEpsilon-2022.10.28.ebuild 2926 BLAKE2B f8ade984c7c9c1da4444244793feb951060c225d59b55e62238ecdbce73ac5331faca0040b30bcf0570a9fb5cdbd82ce4c1c54084721dcf4e541592b07d7190e SHA512 165d47465852727779928f13425255e62b3b63d0371fa78f78a103f3ff8f011a0121fe40bb2580b37e10b620a141829b843a7774ec8d385e5adacb544c90db90
MISC metadata.xml 329 BLAKE2B 8473231ca386ac0a49c270619d7dbe528f578e6dafda3aff92309e947fdae58e6a09b8895e9f051dcf4f70854351756188463e2a987b03939eb41d3cc9346893 SHA512 75c1304961cb113e7957b9f40e091f343af41f7ab74ce59ad20840a883179e8123cc571f6cf45f77ca15bebadecee5e0ed945dc7eae614770b1f943fc195e7b2
diff --git a/games-simulation/Manifest.gz b/games-simulation/Manifest.gz
index b6cf5fd2a3ad..e08b96c4ba37 100644
--- a/games-simulation/Manifest.gz
+++ b/games-simulation/Manifest.gz
Binary files differ