summaryrefslogtreecommitdiff
path: root/games-simulation/corsix-th/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /games-simulation/corsix-th/files
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'games-simulation/corsix-th/files')
-rw-r--r--games-simulation/corsix-th/files/corsix-th-0.66-cmake_lua_detection.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/games-simulation/corsix-th/files/corsix-th-0.66-cmake_lua_detection.patch b/games-simulation/corsix-th/files/corsix-th-0.66-cmake_lua_detection.patch
new file mode 100644
index 000000000000..f85d1bfb0b89
--- /dev/null
+++ b/games-simulation/corsix-th/files/corsix-th-0.66-cmake_lua_detection.patch
@@ -0,0 +1,13 @@
+diff --git a/CorsixTH/CMakeLists.txt b/CorsixTH/CMakeLists.txt
+index 1544810..05ed3b0 100644
+--- a/CorsixTH/CMakeLists.txt
++++ b/CorsixTH/CMakeLists.txt
+@@ -133,7 +133,7 @@ if(MSVC AND USE_VCPKG_DEPS)
+ target_link_libraries(CorsixTH_lib lua)
+ target_link_libraries(CorsixTH lua)
+ else()
+- find_package(Lua REQUIRED)
++ find_package(Lua ${LUA_VERSION} EXACT REQUIRED)
+ if(Lua_FOUND OR LUA_FOUND)
+ target_link_libraries(CorsixTH ${LUA_LIBRARY})
+ include_directories(${LUA_INCLUDE_DIR})