summaryrefslogtreecommitdiff
path: root/games-simulation/crrcsim/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-simulation/crrcsim/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-simulation/crrcsim/files')
-rw-r--r--games-simulation/crrcsim/files/crrcsim-0.9.13-buildsystem.patch62
-rw-r--r--games-simulation/crrcsim/files/crrcsim-0.9.13-gcc6.patch14
-rw-r--r--games-simulation/crrcsim/files/crrcsim-cgal_gmp.patch11
3 files changed, 87 insertions, 0 deletions
diff --git a/games-simulation/crrcsim/files/crrcsim-0.9.13-buildsystem.patch b/games-simulation/crrcsim/files/crrcsim-0.9.13-buildsystem.patch
new file mode 100644
index 000000000000..396fd573ec90
--- /dev/null
+++ b/games-simulation/crrcsim/files/crrcsim-0.9.13-buildsystem.patch
@@ -0,0 +1,62 @@
+--- crrcsim-0.9.11/configure.ac
++++ crrcsim-0.9.11/configure.ac
+@@ -79,8 +79,12 @@
+ dnl Default is: no portaudio present
+ portaudio=0
+
++AC_ARG_WITH([portaudio], AS_HELP_STRING([--without-portaudio], [Build without portaudio library (default: test)]))
++
++AS_IF([test "x$with_portaudio" != "xno"], [
+ dnl Check for the Portaudio header file
+ AC_CHECK_HEADER([portaudio.h])
++])
+
+ if (test "x$ac_cv_header_portaudio_h" = "xyes"); then
+ dnl Check for Portaudio 18
+--- crrcsim-0.9.13/src/mod_misc/filesystools.cpp
++++ crrcsim-0.9.13/src/mod_misc/filesystools.cpp
+@@ -113,8 +113,8 @@
+ // $USERPROFILE/.crrcsim (WIN32)
+ // $HOME/.crrcsim (LINUX)
+ // CRRC_DATA_PATH (LINUX)
+- // /usr/local/share/games/crrcsim (LINUX)
+- // /usr/share/games/crrcsim (LINUX)
++ // /usr/local/share/crrcsim (LINUX)
++ // /usr/share/crrcsim (LINUX)
+
+ // cwd
+ if (dirname != "")
+@@ -154,13 +154,13 @@
+ s.append(dirname);
+ pathlist.push_back(s);
+ #endif
+- s = "/usr/local/share/games/" + appname + "/";
++ s = "/usr/local/share/" + appname + "/";
+ if (s != data_path) // avoid adding this path twice
+ {
+ s.append(dirname);
+ pathlist.push_back(s);
+ }
+- s = "/usr/share/games/" + appname + "/";
++ s = "/usr/share/" + appname + "/";
+ if (s != data_path) // avoid adding this path twice
+ {
+ s.append(dirname);
+@@ -172,13 +172,13 @@
+ #ifdef CRRC_DATA_PATH
+ pathlist.push_back(data_path);
+ #endif
+- if (data_path != "/usr/local/share/games/" + appname) // avoid adding this path twice
++ if (data_path != "/usr/local/share/" + appname) // avoid adding this path twice
+ {
+- pathlist.push_back("/usr/local/share/games/" + appname);
++ pathlist.push_back("/usr/local/share/" + appname);
+ }
+- if (data_path != "/usr/share/games/" + appname) // avoid adding this path twice
++ if (data_path != "/usr/share/" + appname) // avoid adding this path twice
+ {
+- pathlist.push_back("/usr/share/games/" + appname);
++ pathlist.push_back("/usr/share/" + appname);
+ }
+ }
+ #endif
diff --git a/games-simulation/crrcsim/files/crrcsim-0.9.13-gcc6.patch b/games-simulation/crrcsim/files/crrcsim-0.9.13-gcc6.patch
new file mode 100644
index 000000000000..b11550f3dff6
--- /dev/null
+++ b/games-simulation/crrcsim/files/crrcsim-0.9.13-gcc6.patch
@@ -0,0 +1,14 @@
+Bug: https://bugs.gentoo.org/610560
+Upstream commit: https://sourceforge.net/p/crrcsim/code/ci/28ed9ba57011371cab8b637550acc716b973c47d
+
+--- a/src/mod_video/crrc_animation.cpp
++++ b/src/mod_video/crrc_animation.cpp
+@@ -84,7 +84,7 @@
+ else
+ {
+ std::cerr << "createAnimation: unknown animation type \'"
+- << type << "\'" << std::cerr;
++ << type << "\'" << std::endl;
+ }
+
+ if (anim != NULL)
diff --git a/games-simulation/crrcsim/files/crrcsim-cgal_gmp.patch b/games-simulation/crrcsim/files/crrcsim-cgal_gmp.patch
new file mode 100644
index 000000000000..10d6bff6b769
--- /dev/null
+++ b/games-simulation/crrcsim/files/crrcsim-cgal_gmp.patch
@@ -0,0 +1,11 @@
+--- crrcsim-0.9.11/configure.ac
++++ crrcsim-0.9.11/configure.ac
+@@ -229,7 +229,7 @@
+ has_CGAL="yes (found CGAL v3)"
+ fi
+ CGAL_CFLAGS=-frounding-math
+- CGAL_LIBS=-lCGAL
++ CGAL_LIBS="-lCGAL -lgmp"
+ AC_DEFINE([WINDDATA3D], [1], [Import code for wind data, needs CGAL, 0 to disable])
+ else
+ has_CGAL="no (CGAL not found)"