summaryrefslogtreecommitdiff
path: root/games-strategy/colobot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-16 17:34:21 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-16 17:34:21 +0000
commit02e2208f46f4e2c00fb9743cbc47350bdd233bfa (patch)
tree132dd60828854db4f65f30f9230f43d9602507ff /games-strategy/colobot
parent8be70107efbb417f839292165ee39d07a062046f (diff)
gentoo resync : 16.01.2018
Diffstat (limited to 'games-strategy/colobot')
-rw-r--r--games-strategy/colobot/Manifest4
-rw-r--r--games-strategy/colobot/colobot-0.1.11.ebuild58
-rw-r--r--games-strategy/colobot/colobot-9999.ebuild58
-rw-r--r--games-strategy/colobot/metadata.xml15
4 files changed, 135 insertions, 0 deletions
diff --git a/games-strategy/colobot/Manifest b/games-strategy/colobot/Manifest
new file mode 100644
index 000000000000..c19e2de20169
--- /dev/null
+++ b/games-strategy/colobot/Manifest
@@ -0,0 +1,4 @@
+DIST colobot-0.1.11.tar.gz 1430595 BLAKE2B 6e4a23f17631031a6f502b045637949d99bfcf8aa723f11c406c8cdb9b201b9a2771de8b8c92829bc890848a19eb182bc30a45a51e6d281ce64370f6c7a0d8a5 SHA512 fe32bc56b6fae9435c74a73b694b7d2b93667e5d15b1c57a7558e492613f0a5d4cab72ff341ab4c921150137282cc71292a1e31eb1ed06c752de33c50120f20e
+EBUILD colobot-0.1.11.ebuild 1372 BLAKE2B b40e81306d7fc183e9d523db5d60cd19a88880e010584bc4ccb762734ad34fe7ffc1ff50660cdd80e38edca4edfb915c047d4da93caafb82d1fec0c5779879e3 SHA512 19012df06321273072c51cd9408c80f487f53e979c0eaf31edf1fab574d3a41d4a37582a05888f4486891ae057e5341905f28dd686a8e94552d9fb38062cd0cd
+EBUILD colobot-9999.ebuild 1372 BLAKE2B b40e81306d7fc183e9d523db5d60cd19a88880e010584bc4ccb762734ad34fe7ffc1ff50660cdd80e38edca4edfb915c047d4da93caafb82d1fec0c5779879e3 SHA512 19012df06321273072c51cd9408c80f487f53e979c0eaf31edf1fab574d3a41d4a37582a05888f4486891ae057e5341905f28dd686a8e94552d9fb38062cd0cd
+MISC metadata.xml 411 BLAKE2B 1fe6b4d93d539ff408830e300bed7f331f3fa6e90771a9577b8583a087ea36ed307122055143f6e5c7433d5ee1f4c4fdc074bac1f9370ef02ac501f33cb7312d SHA512 1b88f6c73c05a01b8184779585d3e5720abfb2dbcf0948a22d1cc7d16faf68579f13262891bf7589b918c67139d8b4d6ff53536d12e4f79fef19aa2029db13e4
diff --git a/games-strategy/colobot/colobot-0.1.11.ebuild b/games-strategy/colobot/colobot-0.1.11.ebuild
new file mode 100644
index 000000000000..02e4757ef02e
--- /dev/null
+++ b/games-strategy/colobot/colobot-0.1.11.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils desktop
+
+DESCRIPTION="Colobot is an educational real-time strategy video game featuring 3D graphics"
+HOMEPAGE="https://colobot.info/"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/colobot/colobot"
+ EGIT_SUBMODULES=()
+ inherit git-r3
+else
+ SRC_URI="https://github.com/colobot/colobot/archive/${PN}-gold-${PV}-alpha.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}-${PN}-gold-${PV}-alpha"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="devbuild test tools doc +openal"
+
+DEPEND="
+ dev-games/physfs
+ dev-libs/boost:=
+ media-libs/glew:0
+ media-libs/libogg
+ media-libs/libpng:0=
+ media-libs/libsdl2:=
+ media-libs/libsndfile:=
+ media-libs/libvorbis:=
+ media-libs/sdl2-image
+ media-libs/sdl2-ttf
+ media-sound/vorbis-tools
+ sys-devel/gettext
+ openal? ( media-libs/openal )"
+RDEPEND="${DEPEND}
+ games-strategy/colobot-data"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDEV_BUILD=$(usex devbuild)
+ -DTESTS=$(usex test)
+ -DTOOLS=$(usex tools)
+ -DINSTALL_DOCS=$(usex doc)
+ -DOPENAL_SOUND=$(usex openal)
+ -DCOLOBOT_INSTALL_BIN_DIR="${EPREFIX}"/usr/bin
+ -DCOLOBOT_INSTALL_LIB_DIR="${EPREFIX}"/usr/$(get_libdir)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ doicon -s 256 desktop/colobot.ico
+}
diff --git a/games-strategy/colobot/colobot-9999.ebuild b/games-strategy/colobot/colobot-9999.ebuild
new file mode 100644
index 000000000000..02e4757ef02e
--- /dev/null
+++ b/games-strategy/colobot/colobot-9999.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils desktop
+
+DESCRIPTION="Colobot is an educational real-time strategy video game featuring 3D graphics"
+HOMEPAGE="https://colobot.info/"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/colobot/colobot"
+ EGIT_SUBMODULES=()
+ inherit git-r3
+else
+ SRC_URI="https://github.com/colobot/colobot/archive/${PN}-gold-${PV}-alpha.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}-${PN}-gold-${PV}-alpha"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="devbuild test tools doc +openal"
+
+DEPEND="
+ dev-games/physfs
+ dev-libs/boost:=
+ media-libs/glew:0
+ media-libs/libogg
+ media-libs/libpng:0=
+ media-libs/libsdl2:=
+ media-libs/libsndfile:=
+ media-libs/libvorbis:=
+ media-libs/sdl2-image
+ media-libs/sdl2-ttf
+ media-sound/vorbis-tools
+ sys-devel/gettext
+ openal? ( media-libs/openal )"
+RDEPEND="${DEPEND}
+ games-strategy/colobot-data"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDEV_BUILD=$(usex devbuild)
+ -DTESTS=$(usex test)
+ -DTOOLS=$(usex tools)
+ -DINSTALL_DOCS=$(usex doc)
+ -DOPENAL_SOUND=$(usex openal)
+ -DCOLOBOT_INSTALL_BIN_DIR="${EPREFIX}"/usr/bin
+ -DCOLOBOT_INSTALL_LIB_DIR="${EPREFIX}"/usr/$(get_libdir)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ doicon -s 256 desktop/colobot.ico
+}
diff --git a/games-strategy/colobot/metadata.xml b/games-strategy/colobot/metadata.xml
new file mode 100644
index 000000000000..16f1e43ba0d5
--- /dev/null
+++ b/games-strategy/colobot/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>fdsfgs@krutt.org</email>
+ <name>soredake</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">colobot/colobot</remote-id>
+ </upstream>
+ <use>
+ <flag name="devbuild">TODO</flag>
+ <flag name="tools">Build tools</flag>
+ </use>
+</pkgmetadata>