summaryrefslogtreecommitdiff
path: root/games-strategy/s25rttr/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-11 14:19:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-11 14:19:56 +0100
commit34d4f34516ab568ad4ea24fc16ee0ad9ec8ad079 (patch)
tree3339f6fc30715c2fbe1d20281f6ddc53eda3f9b4 /games-strategy/s25rttr/files
parent32eff0cac517b699efc32b86520bac482961a57f (diff)
gentoo auto-resync : 11:08:2022 - 14:19:56
Diffstat (limited to 'games-strategy/s25rttr/files')
-rw-r--r--games-strategy/s25rttr/files/s25rttr-0.9.0_pre20200723-boost-1.77-missing-include.patch17
-rw-r--r--games-strategy/s25rttr/files/s25rttr-0.9.1-cxx-std.patch30
-rw-r--r--games-strategy/s25rttr/files/s25rttr-0.9.1-libsamplerate.patch37
3 files changed, 0 insertions, 84 deletions
diff --git a/games-strategy/s25rttr/files/s25rttr-0.9.0_pre20200723-boost-1.77-missing-include.patch b/games-strategy/s25rttr/files/s25rttr-0.9.0_pre20200723-boost-1.77-missing-include.patch
deleted file mode 100644
index 9a69797ea27a..000000000000
--- a/games-strategy/s25rttr/files/s25rttr-0.9.0_pre20200723-boost-1.77-missing-include.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-https://github.com/Return-To-The-Roots/s25client/pull/1431
-
-From: Sam James <sam@gentoo.org>
-Date: Thu, 19 Aug 2021 02:41:42 +0100
-Subject: [PATCH] Fix build with Boost 1.77 (missing <algorithm> include)
-
-Closes: https://bugs.gentoo.org/808767
---- a/libs/s25main/convertSounds.cpp
-+++ b/libs/s25main/convertSounds.cpp
-@@ -20,6 +20,7 @@
- #include <libsiedler2/ArchivItem_Sound_Wave.h>
- #include <libsiedler2/loadMapping.h>
- #include <s25util/StringConversion.h>
-+#include <algorithm>
- #include <cmath>
- #include <samplerate.hpp>
- #include <sstream>
diff --git a/games-strategy/s25rttr/files/s25rttr-0.9.1-cxx-std.patch b/games-strategy/s25rttr/files/s25rttr-0.9.1-cxx-std.patch
deleted file mode 100644
index cb5ecdf28220..000000000000
--- a/games-strategy/s25rttr/files/s25rttr-0.9.1-cxx-std.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 5db419d044149ab3760c1588b44536febab5d657 Mon Sep 17 00:00:00 2001
-From: James Le Cuirot <chewi@gentoo.org>
-Date: Sat, 11 Sep 2021 08:41:57 +0100
-Subject: [PATCH] Set C++ standard (to C++14) using CMake
-
-Not adding the -std flag broke builds with GCC 11 until the code was
-fixed up recently. This should prevent this sort of thing from
-happening in future. It also ensures that the compiler is actually new
-enough.
----
- CMakeLists.txt | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 8ab991c97..b55c545a2 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -22,6 +22,9 @@ if(DEFINED CMAKE_TOOLCHAIN_FILE)
- message(STATUS "Used Toolchain definition file '${CMAKE_TOOLCHAIN_FILE}'")
- endif()
-
-+set(CMAKE_CXX_STANDARD 14)
-+set(CXX_STANDARD_REQUIRED ON)
-+
- list(APPEND CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake/Modules" "${CMAKE_SOURCE_DIR}/external/libutil/cmake")
- if(CMAKE_VERSION VERSION_LESS 3.14)
- list(APPEND CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/external/libutil/cmake/cmake_3.14")
---
-2.32.0
-
diff --git a/games-strategy/s25rttr/files/s25rttr-0.9.1-libsamplerate.patch b/games-strategy/s25rttr/files/s25rttr-0.9.1-libsamplerate.patch
deleted file mode 100644
index 41d6d90e5fd8..000000000000
--- a/games-strategy/s25rttr/files/s25rttr-0.9.1-libsamplerate.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From 16cb06c99f78a21b1be2bc681c1f1d85a6caddca Mon Sep 17 00:00:00 2001
-From: James Le Cuirot <chewi@gentoo.org>
-Date: Fri, 10 Sep 2021 22:59:51 +0100
-Subject: [PATCH] Fix bad channel count handling with libsamplerate 0.2.0
-
-Since libsndfile/libsamplerate@26d92c369394bcd0b0cea488890edce1a0d757d5,
-initialising libsamplerate with 0 channels or less causes a SIGABRT. We
-therefore need to handle this in the C++ wrapper classes.
----
- libs/libsamplerate/include/samplerate.hpp | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/libs/libsamplerate/include/samplerate.hpp b/libs/libsamplerate/include/samplerate.hpp
-index d0af34317..23e243d91 100644
---- a/libs/libsamplerate/include/samplerate.hpp
-+++ b/libs/libsamplerate/include/samplerate.hpp
-@@ -152,6 +152,8 @@ class State : public detail::StateBase
- {
- static SRC_STATE* createOrThrow(Converter converter, int channels)
- {
-+ if (channels <= 0)
-+ throw std::runtime_error("Channel count must be >= 1.");
- int error;
- auto* state = src_new(static_cast<int>(converter), channels, &error);
- if(!state)
-@@ -174,6 +176,8 @@ class StateCallback : public detail::StateBase
- {
- static SRC_STATE* createOrThrow(Converter converter, int channels, src_callback_t func, void* data)
- {
-+ if (channels <= 0)
-+ throw std::runtime_error("Channel count must be >= 1.");
- int error;
- auto* state = src_callback_new(func, static_cast<int>(converter), channels, &error, data);
- if(!state)
---
-2.32.0
-