summaryrefslogtreecommitdiff
path: root/games-strategy/smac
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-strategy/smac
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-strategy/smac')
-rw-r--r--games-strategy/smac/Manifest4
-rw-r--r--games-strategy/smac/metadata.xml8
-rw-r--r--games-strategy/smac/smac-6.0a.ebuild102
3 files changed, 114 insertions, 0 deletions
diff --git a/games-strategy/smac/Manifest b/games-strategy/smac/Manifest
new file mode 100644
index 000000000000..00cea5f3ed46
--- /dev/null
+++ b/games-strategy/smac/Manifest
@@ -0,0 +1,4 @@
+DIST smac-6.0a-x86.run 6801730 BLAKE2B 95d50c79cde06c4abb5473d7a67f4a66205f7147b7796c9f5e62273776083ce592ec748fd4db559b57568075fb53b4d44db05b2cf14e450ed5757898da6c26d7 SHA512 b71dd1ee46d37d66131cf6fc15c6a406719989021c8dbb6e74cded18c5520ee9ba4bbdfc5bdfc0ddfa67fa2e846365636be41d87a6440473e8ae5ebf542b7744
+DIST smac-install-ppc.run 18528928 BLAKE2B f5c9689c192ebd8ae03d5bb5d4db6deb2b19c5924ce87426cb9140163c9b53a1c4b0ba8592d8b823b2b73847cbf4ffa6d400000a3cf458dd5473ab6bd0aef965 SHA512 99fc6edca2c9e64bfc0cab644cbd061c3842359c16e5e6537a2aa2df4cd2a1a6a39169a2b9540199b08f7aee28f4e2cfad814499fdd55b5edf7ab9b19c12d793
+EBUILD smac-6.0a.ebuild 3069 BLAKE2B dd865b2d81bc1bcb69254beed8f8f9066a83e87541bac41bd230a895f72939b8f0780fa6771cda473c3fe43a8277531e026c0da204b921f83d0f87cdec9e070e SHA512 031b661c3fc11be4c3474fc7c752ca15332b982e527f61560763c5a3592369262e5ce76157f61f00a635b22b0d0be489732183ae5ceb42a09fda004ecb5d315b
+MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-strategy/smac/metadata.xml b/games-strategy/smac/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-strategy/smac/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-strategy/smac/smac-6.0a.ebuild b/games-strategy/smac/smac-6.0a.ebuild
new file mode 100644
index 000000000000..e6aff2ef3a12
--- /dev/null
+++ b/games-strategy/smac/smac-6.0a.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils unpacker cdrom games
+
+DESCRIPTION="Linux port of the popular strategy game from Firaxis"
+HOMEPAGE="http://www.lokigames.com/products/smac/"
+SRC_URI="x86? ( mirror://lokigames/${PN}/${P}-x86.run )
+ amd64? ( mirror://lokigames/${PN}/${P}-x86.run )
+ ppc? ( http://mirrors.dotsrc.org/lokigames/installers/${PN}/${PN}-install-ppc.run )"
+
+LICENSE="LOKI-EULA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+videos"
+RESTRICT="strip"
+
+DEPEND="games-util/loki_patch"
+RDEPEND="sys-libs/glibc
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ !ppc? ( sys-libs/lib-compat-loki )
+ media-libs/libsdl[sound,video]
+ media-libs/sdl-ttf
+ media-libs/sdl-mixer
+ media-libs/smpeg
+ media-libs/freetype
+ sys-libs/zlib"
+
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
+
+src_unpack() {
+ cdrom_get_cds Alien_Crossfire_Manual.pdf
+ mkdir -p "${S}"/a
+ cd "${S}"/a
+ use x86 || use amd64 && unpack_makeself ${P}-x86.run
+ use ppc && unpack_makeself ${PN}-install-ppc.run
+}
+
+src_install() {
+ einfo "Copying files... this may take a while..."
+ exeinto "${dir}"
+ doexe "${CDROM_ROOT}"/bin/x86/{smac,smacx,smacpack}
+
+ insinto "${dir}"
+ doins ${CDROM_ROOT}/{{Alien_Crossfire,Alpha_Centauri}_Manual.pdf,QuickStart.txt,README,icon.{bmp,xpm}}
+
+ cd "${Ddir}"
+ tar xzf "${CDROM_ROOT}"/data.tar.gz || die
+ insinto "${dir}"/data
+ doins "${CDROM_ROOT}"/data/*.{pcx,cvr,flc,gif}
+ doins -r "${CDROM_ROOT}"/data/{facs,fx,projs,techs,voices}
+
+ if use videos ; then
+ doins -r "${CDROM_ROOT}"/data/movies
+ fi
+
+ cd "${S}"/a
+ if use ppc ; then
+ cd ${P}-ppc
+ fi
+ loki_patch --verify patch.dat
+ loki_patch patch.dat "${Ddir}" >& /dev/null || die
+
+ # now, since these files are coming off a cd, the times/sizes/md5sums wont
+ # be different ... that means portage will try to unmerge some files (!)
+ # we run touch on ${D} so as to make sure portage doesnt do any such thing
+ find "${Ddir}" -exec touch '{}' +
+
+ newicon "${CDROM_ROOT}"/icon.xpm smac.xpm
+
+ games_make_wrapper ${PN}pack ./${PN}pack "${dir}" "${dir}"
+ games_make_wrapper ${PN} ./${PN} "${dir}" "${dir}"
+ games_make_wrapper ${PN}x ./${PN}x "${dir}" "${dir}"
+ make_desktop_entry smacpack "Sid Meier's SMAC Planetary Pack" smacpack
+ make_desktop_entry smac "Sid Meier's Alpha Centauri" smac
+ make_desktop_entry smacx "Sid Meier's Alpha Centauri - Alien Crossfire" smac
+ prepgamesdirs
+
+ if use x86 || use amd64 ; then
+ einfo "Linking libs provided by 'sys-libs/lib-compat-loki' to '${dir}'."
+ dosym /lib/loki_ld-linux.so.2 "${dir}"/ld-linux.so.2 && \
+ dosym /usr/lib/loki_libc.so.6 "${dir}"/libc.so.6 && \
+ dosym /usr/lib/loki_libnss_files.so.2 "${dir}"/libnss_files.so.2
+ fi
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "To start Sid Meyer's SMAC Planetary Pack run:"
+ elog " smac"
+ elog "To play Sid Meyer's Alpha Centauri run:"
+ elog " smac"
+ elog "To play Alien Crossfire run:"
+ elog " smacx"
+ elog "Be sure to enable CONFIG_UID16 in your kernel config or"
+ elog "the game will error." # bug 340303
+}