summaryrefslogtreecommitdiff
path: root/games-strategy/warmux/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-strategy/warmux/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-strategy/warmux/files')
-rw-r--r--games-strategy/warmux/files/warmux-11.04.1-action.patch12
-rw-r--r--games-strategy/warmux/files/warmux-11.04.1-fix-c++14.patch14
-rw-r--r--games-strategy/warmux/files/warmux-11.04.1-gcc47.patch11
-rw-r--r--games-strategy/warmux/files/warmux-11.04.1-gentoo.patch40
-rw-r--r--games-strategy/warmux/files/warmux-11.04.1-stat.patch61
-rw-r--r--games-strategy/warmux/files/warmux-11.04.1-zlib.patch11
6 files changed, 149 insertions, 0 deletions
diff --git a/games-strategy/warmux/files/warmux-11.04.1-action.patch b/games-strategy/warmux/files/warmux-11.04.1-action.patch
new file mode 100644
index 000000000000..e1530337a259
--- /dev/null
+++ b/games-strategy/warmux/files/warmux-11.04.1-action.patch
@@ -0,0 +1,12 @@
+diff -uNr warmux-11.04.orig/lib/warmux/action/action.cpp warmux-11.04/lib/warmux/action/action.cpp
+--- warmux-11.04.orig/lib/warmux/action/action.cpp 2012-03-27 15:18:08.440709875 +0200
++++ warmux-11.04/lib/warmux/action/action.cpp 2012-03-27 15:17:44.871711354 +0200
+@@ -85,7 +85,7 @@
+ {
+ m_creator = _creator;
+
+- m_header.len = SDLNet_Read32(buffer);
++ m_header.len = SDLNet_Read32((void *)buffer);
+ ASSERT(m_header.len >= sizeof(Header));
+ buffer += 4;
+ // All of the following could be skipped for the actions we now, \ No newline at end of file
diff --git a/games-strategy/warmux/files/warmux-11.04.1-fix-c++14.patch b/games-strategy/warmux/files/warmux-11.04.1-fix-c++14.patch
new file mode 100644
index 000000000000..223ee47ab5a2
--- /dev/null
+++ b/games-strategy/warmux/files/warmux-11.04.1-fix-c++14.patch
@@ -0,0 +1,14 @@
+In C++14, bool -> T* implicit conversions are not allowed anymore.
+See also: https://bugs.gentoo.org/show_bug.cgi?id=598639
+
+--- a/src/interface/weapon_menu.cpp
++++ b/src/interface/weapon_menu.cpp
+@@ -391,7 +391,7 @@
+ Weapon * WeaponsMenu::UpdateCurrentOverflyItem(const Polygon * poly)
+ {
+ if (!show)
+- return false;
++ return NULL;
+ const std::vector<PolygonItem *>& items = poly->GetItem();
+ WeaponMenuItem * tmp;
+ Interface::GetInstance()->SetCurrentOverflyWeapon(NULL);
diff --git a/games-strategy/warmux/files/warmux-11.04.1-gcc47.patch b/games-strategy/warmux/files/warmux-11.04.1-gcc47.patch
new file mode 100644
index 000000000000..8460bcbd0b1c
--- /dev/null
+++ b/games-strategy/warmux/files/warmux-11.04.1-gcc47.patch
@@ -0,0 +1,11 @@
+Description: Fix FTBFS with gcc 4.7.
+Author: Felix Geyer <debfx-pkg@fobos.de>
+
+--- warmux-11.04.1+repack.orig/tools/list_games/main.cpp
++++ warmux-11.04.1+repack/tools/list_games/main.cpp
+@@ -1,4 +1,5 @@
+ #include <stdio.h>
++#include <unistd.h>
+ #include <WARMUX_types.h>
+ #include <WARMUX_network.h>
+ #include <WARMUX_index_server.h>
diff --git a/games-strategy/warmux/files/warmux-11.04.1-gentoo.patch b/games-strategy/warmux/files/warmux-11.04.1-gentoo.patch
new file mode 100644
index 000000000000..62d22f84c82d
--- /dev/null
+++ b/games-strategy/warmux/files/warmux-11.04.1-gentoo.patch
@@ -0,0 +1,40 @@
+diff -ru warmux-11.04.orig/configure.ac warmux-11.04/configure.ac
+--- warmux-11.04.orig/configure.ac 2011-04-18 16:46:12.000000000 -0400
++++ warmux-11.04/configure.ac 2011-04-19 11:17:27.380256500 -0400
+@@ -43,8 +43,6 @@
+ AC_MSG_ERROR([*** No C++ compiler can be found!])
+ fi
+
+-AX_CFLAGS_WARN_ALL([CXXFLAGS])
+-
+ # ==========================================================================
+ # == Set flags for various environments =
+ # ==========================================================================
+@@ -348,14 +346,9 @@
+ exit 1
+ fi
+
+-dnl === Add Werror flag for gcc/g++ if debug mode is enabled, ==============
+-dnl === but allow RTTI (ie dynamic_cast, typeid/typeinfo unavailable) ======
+-if test "x${debug}" = "xyes"; then
++if test "x${debug}" != "xyes"; then
+- CFLAGS="$CFLAGS -Werror"
+- CXXFLAGS="$CXXFLAGS -Werror"
+-else
+ CXXFLAGS="$CXXFLAGS -fno-rtti"
+ fi
+
+ dnl === Forbid exceptions (Android platform requirement) ===================
+ CXXFLAGS="$CXXFLAGS -fno-exceptions"
+diff -ru warmux-11.04.orig/data/Makefile.am warmux-11.04/data/Makefile.am
+--- warmux-11.04.orig/data/Makefile.am 2011-04-18 16:46:11.000000000 -0400
++++ warmux-11.04/data/Makefile.am 2011-04-19 11:17:45.134724536 -0400
+@@ -1,8 +1,2 @@
+-xdg_appsdir = $(prefix)/share/applications
+-xdg_apps_DATA = warmux.desktop warmux_files.desktop
+-pixmapsdir = $(prefix)/share/pixmaps
+-pixmaps_DATA = icon/warmux_128x128.png
+-
+ nobase_dist_pkgdata_DATA = @DATA_FILES@
+ pkgdatadir = @DATADIR@
+-EXTRA_DIST = $(pixmaps_DATA)
diff --git a/games-strategy/warmux/files/warmux-11.04.1-stat.patch b/games-strategy/warmux/files/warmux-11.04.1-stat.patch
new file mode 100644
index 000000000000..487b3805ba6f
--- /dev/null
+++ b/games-strategy/warmux/files/warmux-11.04.1-stat.patch
@@ -0,0 +1,61 @@
+diff -ur warmux-11.04.orig/lib/warmux/tools/file_tools.cpp warmux-11.04/lib/warmux/tools/file_tools.cpp
+--- warmux-11.04.orig/lib/warmux/tools/file_tools.cpp 2011-04-28 21:03:13.000000000 +0200
++++ warmux-11.04/lib/warmux/tools/file_tools.cpp 2013-03-05 16:58:42.040443845 +0100
+@@ -33,6 +33,8 @@
+ # include <direct.h>
+ # undef DeleteFile // windows.h defines it I think
+ #else
++# include <sys/types.h>
++# include <sys/stat.h>
+ # include <stdlib.h> // getenv
+ # include <unistd.h> // not needed by mingw
+ #endif
+@@ -275,18 +277,14 @@
+ {
+ DIR *dir;
+ struct dirent *file;
+-#ifdef __SYMBIAN32__
+ std::string dname;
+-#endif
+ };
+
+ FolderSearch* OpenFolder(const std::string& dirname)
+ {
+ FolderSearch *f = new FolderSearch;
+ f->dir = opendir(dirname.c_str());
+-#ifdef __SYMBIAN32__
+ f->dname = dirname;
+-#endif
+
+ if (!f->dir) {
+ delete f;
+@@ -300,11 +298,11 @@
+ {
+ while ((f->file = readdir(f->dir)) != NULL) {
+
++ if (
+ #ifdef __SYMBIAN32__
+- if (f->file->d_namlen && DoesFolderExist(f->dname+"/"+std::string(f->file->d_name))) {
+-#else
+- if (f->file->d_type == DT_DIR) {
++ f->file->d_namlen &&
+ #endif
++ DoesFolderExist(f->dname+"/"+std::string(f->file->d_name))) {
+ // If we are also looking for files, report it isn't one
+ if (file)
+ file = false;
+@@ -316,11 +314,11 @@
+ continue;
+
+ // This is a file and we do search for file
++ if (
+ #ifdef __SYMBIAN32__
+- if (f->file->d_namlen && DoesFileExist(f->dname+"/"+std::string(f->file->d_name))) {
+-#else
+- if (f->file->d_type == DT_REG) {
++ f->file->d_namlen &&
+ #endif
++ DoesFileExist(f->dname+"/"+std::string(f->file->d_name))) {
+ file = true;
+ return f->file->d_name;
+ }
diff --git a/games-strategy/warmux/files/warmux-11.04.1-zlib.patch b/games-strategy/warmux/files/warmux-11.04.1-zlib.patch
new file mode 100644
index 000000000000..c7e77aba11c8
--- /dev/null
+++ b/games-strategy/warmux/files/warmux-11.04.1-zlib.patch
@@ -0,0 +1,11 @@
+diff -uNr warmux-11.04.orig/src/graphic/surface.cpp warmux-11.04/src/graphic/surface.cpp
+--- warmux-11.04.orig/src/graphic/surface.cpp 2011-09-19 09:26:52.392650465 +0200
++++ warmux-11.04/src/graphic/surface.cpp 2011-09-19 09:26:19.417648189 +0200
+@@ -25,6 +25,7 @@
+ #include <SDL_image.h>
+ #include <SDL_rotozoom.h>
+ #include <png.h>
++#include <zlib.h>
+
+ #include "graphic/surface.h"
+ #include "tool/math_tools.h"