summaryrefslogtreecommitdiff
path: root/games-util/biounzip/biounzip-1.1a.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-util/biounzip/biounzip-1.1a.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-util/biounzip/biounzip-1.1a.ebuild')
-rw-r--r--games-util/biounzip/biounzip-1.1a.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/games-util/biounzip/biounzip-1.1a.ebuild b/games-util/biounzip/biounzip-1.1a.ebuild
new file mode 100644
index 000000000000..8864926d8034
--- /dev/null
+++ b/games-util/biounzip/biounzip-1.1a.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Unpacks BioZip archives"
+HOMEPAGE="http://biounzip.sourceforge.net/"
+SRC_URI="mirror://sourceforge/biounzip/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-libs/zlib"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${P/a/}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-64bit.patch
+}
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o ${PN} *.c -lz || die
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc biozip.txt
+}