summaryrefslogtreecommitdiff
path: root/games-util/cartridges
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-28 15:14:55 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-28 15:14:55 +0100
commite5346f2f512bd7faf413f3de3ef7fbcfbcd974b3 (patch)
tree44147dcd86c1974cea8fa5e6914b2b4428d4ec28 /games-util/cartridges
parentdd543f86f47d3b1796d2190759773c75779ba7ad (diff)
gentoo auto-resync : 28:05:2023 - 15:14:55
Diffstat (limited to 'games-util/cartridges')
-rw-r--r--games-util/cartridges/Manifest4
-rw-r--r--games-util/cartridges/cartridges-1.5.4.ebuild51
-rw-r--r--games-util/cartridges/files/cartridges-1.5.4-dont-validate-appstream.patch10
-rw-r--r--games-util/cartridges/metadata.xml20
4 files changed, 85 insertions, 0 deletions
diff --git a/games-util/cartridges/Manifest b/games-util/cartridges/Manifest
new file mode 100644
index 000000000000..2b27e2408db5
--- /dev/null
+++ b/games-util/cartridges/Manifest
@@ -0,0 +1,4 @@
+AUX cartridges-1.5.4-dont-validate-appstream.patch 304 BLAKE2B bc6f26ccc39f2029a0d09a767843139b219692159e1b3036e40845a14db2bf43f4510ab29b626cc9acfa140123a841b36536b767187b792ce545737914bebd1e SHA512 2a5b2a8a4dbd0614f7fdabb487e2df5c63c0718b11320fefa8894c1dd166438d7238e1d4703c9e9aeac2bf540ecaa4c0cbf6e5a64343d8bce80d5e1033a6dd14
+DIST cartridges-1.5.4.tar.gz 1302013 BLAKE2B f54d867ce769c843ee8114ea2946618a1ee275dff877a5f5b175f2457d5f67ffe412b188d44961aaa351acfd8e89e68d9b30442f79d747ebba7fd8432fa82d45 SHA512 b69b18150ecec2dc39ab126f1708f04af4902babdd999b5d26d71b001e8111f062ef6edc4efed66b551b2a84b7bed1e18a4e3aecf3f60aaa3518c08e144a8a25
+EBUILD cartridges-1.5.4.ebuild 1069 BLAKE2B 385353933a1bbf7a2629d5f494693b59557507f59f34e6f04e4e490be2b1237616b8fb3d921abcac7302d84646834392df2c40e23462a3f68110ee80d3dabb4e SHA512 8d8eebcef5c1e532005c079497044cb1443c4522cc0560065d495ea1813b3abb0ad38d3f33b58b29f36d0671051116fc805c34df20d4712b54dd83d301d5dd0c
+MISC metadata.xml 760 BLAKE2B f57df1306fd66ac7c1275d2c77ced58a333f3e47a7f02ae643d8fe4bceb7f28dfc796e3898fb28eef7f6e4ee250e762ca208c662be94a12e89a098ec45d5b482 SHA512 e70a9f88c0cdb41276783878ccaf24623f8c97fafc55d88ab564604cb534b4ea7426eb50d3c9ba9ee091e7adf5bea6d68e919c0c84a496be3d8c6497394cd2b7
diff --git a/games-util/cartridges/cartridges-1.5.4.ebuild b/games-util/cartridges/cartridges-1.5.4.ebuild
new file mode 100644
index 000000000000..d41dbef3341e
--- /dev/null
+++ b/games-util/cartridges/cartridges-1.5.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit gnome2-utils meson python-single-r1 xdg
+
+DESCRIPTION="Simple game launcher written in Python using GTK4 and Libadwaita"
+HOMEPAGE="https://github.com/kra-mo/cartridges/"
+SRC_URI="https://github.com/kra-mo/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ gui-libs/gtk:4[introspection]
+ gui-libs/libadwaita:1[introspection]
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-util/desktop-file-utils
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.5.4-dont-validate-appstream.patch )
+
+src_install() {
+ meson_src_install
+
+ python_fix_shebang "${ED}"/usr/bin
+ python_optimize "${ED}"/usr/share/cartridges/cartridges
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_pkg_postrm
+}
diff --git a/games-util/cartridges/files/cartridges-1.5.4-dont-validate-appstream.patch b/games-util/cartridges/files/cartridges-1.5.4-dont-validate-appstream.patch
new file mode 100644
index 000000000000..7cfc09376292
--- /dev/null
+++ b/games-util/cartridges/files/cartridges-1.5.4-dont-validate-appstream.patch
@@ -0,0 +1,10 @@
+--- a/data/meson.build
++++ b/data/meson.build
+@@ -54,7 +54,6 @@ appstream_file = i18n.merge_file(
+
+ appstream_util = find_program('appstream-util', required: false)
+ if appstream_util.found()
+- test('Validate appstream file', appstream_util, args: ['validate', appstream_file])
+ endif
+
+ install_data(
diff --git a/games-util/cartridges/metadata.xml b/games-util/cartridges/metadata.xml
new file mode 100644
index 000000000000..703d77d0fd2e
--- /dev/null
+++ b/games-util/cartridges/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription>
+ Cartridges is a simple game launcher for all of your games. It has support
+ for importing games from Steam, Lutris, Heroic and more with no login
+ necessary. You can sort and hide games or download cover art from
+ SteamGridDB.
+ </longdescription>
+ <upstream>
+ <changelog>https://github.com/kra-mo/cartridges/releases/</changelog>
+ <bugs-to>https://github.com/kra-mo/cartridges/issues/</bugs-to>
+ <remote-id type="github">kra-mo/cartridges</remote-id>
+ </upstream>
+</pkgmetadata>