summaryrefslogtreecommitdiff
path: root/games-util/gamemode
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
commit62f67115b5c46134c34f88f4b1cbdacc19384c0a (patch)
tree0a76b14de203a4c23040e5665e39df8de9867745 /games-util/gamemode
parent265dbe5dbc14c199299496c6db8fce3f76647015 (diff)
gentoo resync : 30.09.2018
Diffstat (limited to 'games-util/gamemode')
-rw-r--r--games-util/gamemode/Manifest4
-rw-r--r--games-util/gamemode/gamemode-1.2.ebuild102
-rw-r--r--games-util/gamemode/gamemode-9999.ebuild102
-rw-r--r--games-util/gamemode/metadata.xml16
4 files changed, 224 insertions, 0 deletions
diff --git a/games-util/gamemode/Manifest b/games-util/gamemode/Manifest
new file mode 100644
index 000000000000..3634b04b348f
--- /dev/null
+++ b/games-util/gamemode/Manifest
@@ -0,0 +1,4 @@
+DIST gamemode-1.2.tar.xz 38536 BLAKE2B af39b8c0585c522afa72238b8332a6a5301d36b3c53e50652a78c41788eae9f5cb319cad06eaf6f345c50f934e188df4c78d70efbad919dd6897d3350d14e568 SHA512 233602e5e93b6cfcc742510dafb00dc826000d0c8618a693e9a579dc3b31c546d22c0545084cfb78c6085226e6b0e26c066078bc1871d36d5fb90828cf63cea9
+EBUILD gamemode-1.2.ebuild 3239 BLAKE2B 43f63f18aa08f8206ccf914fabdf19f5e060d7c6da5670cb766b25f8f3338dcd9bbf945105da7e9671e36bbba4094bb71b5f249f1f218e4621680f8dd6d7c375 SHA512 9b0ff9ae1e19779748d88bf1c87431a1484b022d4aab24a5a339ccf848e424aef1cf4fd206616b63f132e4abfe8055c9a51d05a29b3953a5af5b5ae3a08d7aca
+EBUILD gamemode-9999.ebuild 3239 BLAKE2B 43f63f18aa08f8206ccf914fabdf19f5e060d7c6da5670cb766b25f8f3338dcd9bbf945105da7e9671e36bbba4094bb71b5f249f1f218e4621680f8dd6d7c375 SHA512 9b0ff9ae1e19779748d88bf1c87431a1484b022d4aab24a5a339ccf848e424aef1cf4fd206616b63f132e4abfe8055c9a51d05a29b3953a5af5b5ae3a08d7aca
+MISC metadata.xml 530 BLAKE2B 14e10e8800bca7ad7e412916ee250a4c9dbc5ed78feb99fbb9ec1feb6cc60cbf96494676eaf48200781f9e25bd330d97e16e7cbd46120df79a3e7affb8361d7e SHA512 6a080b2ec0af531ef9c5d989927a2bef7dd8870c27a5edccc9e61bc9c35cb8bc11c1b781aa003dbca470a2c8172b10f5317be6cca6c6d3d6bef206e91fe7e75c
diff --git a/games-util/gamemode/gamemode-1.2.ebuild b/games-util/gamemode/gamemode-1.2.ebuild
new file mode 100644
index 000000000000..6ac471006aa0
--- /dev/null
+++ b/games-util/gamemode/gamemode-1.2.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MULTILIB_COMPAT=( abi_x86_{32,64} )
+
+inherit meson multilib-minimal ninja-utils user
+
+DESCRIPTION="Optimise Linux system performance on demand"
+HOMEPAGE="https://github.com/FeralInteractive/gamemode"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/FeralInteractive/gamemode.git"
+ GAMEMODE_GIT_PTR="master"
+ inherit git-r3
+else
+ GAMEMODE_GIT_PTR="${PV}"
+ SRC_URI="https://github.com/FeralInteractive/gamemode/releases/download/${GAMEMODE_GIT_PTR}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=sys-apps/systemd-236[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+pkg_pretend() {
+ elog
+ elog "GameMode needs a kernel capable of SCHED_ISO to use its soft realtime"
+ elog "feature. Examples of kernels providing that are sys-kernel/ck-source"
+ elog "and sys-kernel/pf-sources."
+ elog
+ elog "Support for soft realtime is completely optional. It may provide the"
+ elog "following benefits with systems having at least four CPU cores:"
+ elog
+ elog " * more CPU shares allocated exclusively to the game"
+ elog " * reduced input lag and reduced thread latency"
+ elog " * more consistent frame times resulting in less microstutters"
+ elog
+ elog "You probably won't benefit from soft realtime mode and thus don't need"
+ elog "SCHED_ISO if:"
+ elog
+ elog " * Your CPU has less than four cores because the game may experience"
+ elog " priority inversion with the graphics driver (thus heuristics"
+ elog " automatically disable SCHED_ISO usage then)"
+ elog " * Your game uses busy-loops to interface with the graphics driver"
+ elog " but you may still force SCHED_ISO per configuation file, YMMV,"
+ elog " it depends on the graphics driver implementation, i.e. usage of"
+ elog " __GL_THREADED_OPTIMIZATIONS or similar."
+ elog " * If your game causes more than 70% CPU usage across all cores,"
+ elog " SCHED_ISO automatically turns off and on depending on usage and"
+ elog " is processed with higher-than-normal priority then (renice)."
+ elog " This auto-switching may result in a lesser game experience."
+ elog
+ elog "For more info look at:"
+ elog "https://github.com/FeralInteractive/gamemode/blob/${GAMEMODE_GIT_PTR}/README.md"
+ elog
+}
+
+multilib_src_configure() {
+ local myconf=()
+ if ! multilib_is_native_abi; then
+ myconf+=(
+ -Dwith-examples=false
+ -Dwith-daemon=false
+ )
+ fi
+ meson_src_configure "${myconf[@]}"
+}
+
+multilib_src_compile() {
+ eninja
+}
+
+multilib_src_install() {
+ DESTDIR="${D}" eninja install
+ insinto /etc/security/limits.d
+ newins - 45-gamemode.conf <<-EOF
+ @gamemode - nice -10
+ EOF
+}
+
+pkg_postinst() {
+ enewgroup gamemode
+
+ elog
+ elog "GameMode can renice your games. You need to be in the gamemode group for this to work."
+ elog "Run the following command as root to add your user:"
+ elog "# gpasswd -a USER gamemode # with USER = your user name"
+ elog
+
+ elog "Enable and start the daemon in your systemd user instance, then add"
+ elog "LD_PRELOAD=\$LD_PRELOAD:/usr/\$LIB/libgamemodeauto.so %command%"
+ elog "to the start options of any steam game to enable the performance"
+ elog "governor as you start the game."
+ elog
+}
diff --git a/games-util/gamemode/gamemode-9999.ebuild b/games-util/gamemode/gamemode-9999.ebuild
new file mode 100644
index 000000000000..6ac471006aa0
--- /dev/null
+++ b/games-util/gamemode/gamemode-9999.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MULTILIB_COMPAT=( abi_x86_{32,64} )
+
+inherit meson multilib-minimal ninja-utils user
+
+DESCRIPTION="Optimise Linux system performance on demand"
+HOMEPAGE="https://github.com/FeralInteractive/gamemode"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/FeralInteractive/gamemode.git"
+ GAMEMODE_GIT_PTR="master"
+ inherit git-r3
+else
+ GAMEMODE_GIT_PTR="${PV}"
+ SRC_URI="https://github.com/FeralInteractive/gamemode/releases/download/${GAMEMODE_GIT_PTR}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=sys-apps/systemd-236[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+pkg_pretend() {
+ elog
+ elog "GameMode needs a kernel capable of SCHED_ISO to use its soft realtime"
+ elog "feature. Examples of kernels providing that are sys-kernel/ck-source"
+ elog "and sys-kernel/pf-sources."
+ elog
+ elog "Support for soft realtime is completely optional. It may provide the"
+ elog "following benefits with systems having at least four CPU cores:"
+ elog
+ elog " * more CPU shares allocated exclusively to the game"
+ elog " * reduced input lag and reduced thread latency"
+ elog " * more consistent frame times resulting in less microstutters"
+ elog
+ elog "You probably won't benefit from soft realtime mode and thus don't need"
+ elog "SCHED_ISO if:"
+ elog
+ elog " * Your CPU has less than four cores because the game may experience"
+ elog " priority inversion with the graphics driver (thus heuristics"
+ elog " automatically disable SCHED_ISO usage then)"
+ elog " * Your game uses busy-loops to interface with the graphics driver"
+ elog " but you may still force SCHED_ISO per configuation file, YMMV,"
+ elog " it depends on the graphics driver implementation, i.e. usage of"
+ elog " __GL_THREADED_OPTIMIZATIONS or similar."
+ elog " * If your game causes more than 70% CPU usage across all cores,"
+ elog " SCHED_ISO automatically turns off and on depending on usage and"
+ elog " is processed with higher-than-normal priority then (renice)."
+ elog " This auto-switching may result in a lesser game experience."
+ elog
+ elog "For more info look at:"
+ elog "https://github.com/FeralInteractive/gamemode/blob/${GAMEMODE_GIT_PTR}/README.md"
+ elog
+}
+
+multilib_src_configure() {
+ local myconf=()
+ if ! multilib_is_native_abi; then
+ myconf+=(
+ -Dwith-examples=false
+ -Dwith-daemon=false
+ )
+ fi
+ meson_src_configure "${myconf[@]}"
+}
+
+multilib_src_compile() {
+ eninja
+}
+
+multilib_src_install() {
+ DESTDIR="${D}" eninja install
+ insinto /etc/security/limits.d
+ newins - 45-gamemode.conf <<-EOF
+ @gamemode - nice -10
+ EOF
+}
+
+pkg_postinst() {
+ enewgroup gamemode
+
+ elog
+ elog "GameMode can renice your games. You need to be in the gamemode group for this to work."
+ elog "Run the following command as root to add your user:"
+ elog "# gpasswd -a USER gamemode # with USER = your user name"
+ elog
+
+ elog "Enable and start the daemon in your systemd user instance, then add"
+ elog "LD_PRELOAD=\$LD_PRELOAD:/usr/\$LIB/libgamemodeauto.so %command%"
+ elog "to the start options of any steam game to enable the performance"
+ elog "governor as you start the game."
+ elog
+}
diff --git a/games-util/gamemode/metadata.xml b/games-util/gamemode/metadata.xml
new file mode 100644
index 000000000000..05078a2e7821
--- /dev/null
+++ b/games-util/gamemode/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>hurikhan77+bgo@gmail.com</email>
+ <name>Kai Krakow</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/FeralInteractive/gamemode/issues</bugs-to>
+ <remote-id type="github">FeralInteractive/gamemode</remote-id>
+ </upstream>
+</pkgmetadata>