summaryrefslogtreecommitdiff
path: root/games-util/glbsp/glbsp-2.24.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:58:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:58:29 +0100
commit0cf2f20608308acdf3cb922c3736446bbd8f3388 (patch)
tree07815070629c7c11000a7f51ceb8ccbccb49a809 /games-util/glbsp/glbsp-2.24.ebuild
parent1798c4aeca70ac8d0a243684d6a798fbc65735f8 (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-util/glbsp/glbsp-2.24.ebuild')
-rw-r--r--games-util/glbsp/glbsp-2.24.ebuild64
1 files changed, 0 insertions, 64 deletions
diff --git a/games-util/glbsp/glbsp-2.24.ebuild b/games-util/glbsp/glbsp-2.24.ebuild
deleted file mode 100644
index e6c982167ae0..000000000000
--- a/games-util/glbsp/glbsp-2.24.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils toolchain-funcs versionator
-
-MY_PV=$(delete_version_separator 1)
-DESCRIPTION="A node builder specially designed for OpenGL ports of the DOOM game engine"
-HOMEPAGE="http://glbsp.sourceforge.net/"
-SRC_URI="mirror://sourceforge/glbsp/${PN}_src_${MY_PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="fltk"
-
-DEPEND="fltk? ( x11-libs/fltk:1 )"
-RDEPEND=${DEPEND}
-
-S=${WORKDIR}/${P}-source
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-ldflags.patch
- sed -i \
- -e "/^CC=/s:=.*:=$(tc-getCC):" \
- -e "/^CXX=/s:=.*:=$(tc-getCXX):" \
- -e "/^AR=/s:ar:$(tc-getAR):" \
- -e "/^RANLIB=/s:=.*:=$(tc-getRANLIB):" \
- -e "s:-O2:${CFLAGS}:" \
- -e "s:-O -g3:${CFLAGS}:" \
- Makefile.unx \
- nodeview/Makefile.unx || die
-}
-
-src_compile() {
- emake -f Makefile.unx
- if use fltk ; then
- emake -f Makefile.unx glBSPX \
- FLTK_FLAGS="$(fltk-config --cflags)" \
- FLTK_LIBS="$(fltk-config --use-images --ldflags)"
- emake -f Makefile.unx -C nodeview \
- FLTK_CFLAGS="$(fltk-config --cflags)" \
- FLTK_LIBS="$(fltk-config --use-images --ldflags)"
- fi
-}
-
-src_install() {
- dobin glbsp
- dolib.a libglbsp.a
- doman glbsp.1
- dodoc AUTHORS.txt glbsp.txt
- insinto "/usr/include"
- doins "src/glbsp.h"
-
- if use fltk ; then
- newbin glBSPX glbspx
- newicon gui/icon.xpm glbspx.xpm
- make_desktop_entry glbspx glBSPX glbspx
-
- dobin nodeview/nodeview
- docinto nodeview
- dodoc nodeview/{README,TODO}.txt
- fi
-}