summaryrefslogtreecommitdiff
path: root/games-util/grfcodec
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-util/grfcodec
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-util/grfcodec')
-rw-r--r--games-util/grfcodec/Manifest3
-rw-r--r--games-util/grfcodec/grfcodec-6.0.6.ebuild51
-rw-r--r--games-util/grfcodec/metadata.xml8
3 files changed, 62 insertions, 0 deletions
diff --git a/games-util/grfcodec/Manifest b/games-util/grfcodec/Manifest
new file mode 100644
index 000000000000..76ae1902c91f
--- /dev/null
+++ b/games-util/grfcodec/Manifest
@@ -0,0 +1,3 @@
+DIST grfcodec-6.0.6-source.tar.xz 166820 BLAKE2B ba81e31477fb15bb5273add4d993ee7de88cfd47fd8300743e97c4abd19b0daf736d78b5bafc82569ff110757131501c07d7365a4e7ffde8d3a7fcc2e277bada SHA512 543123c794bfdb5b6556f7a897bcd2f3bdd09be8ad6a4ff07b138e0cac62621a4801c732bb20099c1bb383ad5822fc4ade276d49acf2744c811edd10d7699480
+EBUILD grfcodec-6.0.6.ebuild 1066 BLAKE2B ca41f8822b55fba5dac610e2bb9efcd786b5ee9bda3084407953cbade5c450f383337ef11c354e44a4ebd7c42ef60ab55a614c94f204602c17c7d6bb7dcaaa08 SHA512 6ac4994f25b2cfe551e56d9d9d828797928ae3a205e440a743213a468cd697d15d7442af0313744a296fa6d1a4b37baf295f696b9434a4fa5dc8c9757c847921
+MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-util/grfcodec/grfcodec-6.0.6.ebuild b/games-util/grfcodec/grfcodec-6.0.6.ebuild
new file mode 100644
index 000000000000..ebfb9b894f6b
--- /dev/null
+++ b/games-util/grfcodec/grfcodec-6.0.6.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [ "${PV%9999}" != "${PV}" ] ; then
+ SCM=mercurial
+ EHG_REPO_URI="http://hg.openttdcoop.org/${PN}"
+fi
+
+inherit toolchain-funcs ${SCM}
+
+DESCRIPTION="A suite of programs to modify openttd/Transport Tycoon Deluxe's GRF files"
+HOMEPAGE="https://dev.openttdcoop.org/projects/grfcodec"
+[[ -z ${SCM} ]] && SRC_URI="https://binaries.openttd.org/extra/${PN}/${PV}/${P}-source.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libpng:0"
+DEPEND="
+ ${RDEPEND}
+ !games-util/nforenum
+ dev-lang/perl
+ dev-libs/boost
+"
+
+src_prepare() {
+ default
+
+ # Set up Makefile.local so that we respect CXXFLAGS/LDFLAGS
+ cat > Makefile.local <<-__EOF__
+ CXX=$(tc-getCXX)
+ BOOST_INCLUDE=/usr/include
+ CXXFLAGS=${CXXFLAGS}
+ LDOPT=${LDFLAGS}
+ UPX=
+ V=1
+ FLAGS=
+ EXE=
+ __EOF__
+ sed -i -e 's/-O2//g' Makefile || die
+}
+
+src_install() {
+ dobin grfcodec grfid grfstrip nforenum
+ doman docs/*.1
+ dodoc changelog.txt docs/*.txt
+}
diff --git a/games-util/grfcodec/metadata.xml b/games-util/grfcodec/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-util/grfcodec/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>