summaryrefslogtreecommitdiff
path: root/games-util/lgogdownloader
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
commit677b7ba5c317778df2ad7e70df94b9b7eec4adbc (patch)
tree6c418a1546fff5becab5d8b9ed6803323e7f316e /games-util/lgogdownloader
parentfbda87924e6faa7a1919f1a2b4182490bde5ec5c (diff)
gentoo resync : 10.09.2021
Diffstat (limited to 'games-util/lgogdownloader')
-rw-r--r--games-util/lgogdownloader/Manifest4
-rw-r--r--games-util/lgogdownloader/lgogdownloader-3.8.ebuild39
-rw-r--r--games-util/lgogdownloader/lgogdownloader-9999.ebuild4
3 files changed, 44 insertions, 3 deletions
diff --git a/games-util/lgogdownloader/Manifest b/games-util/lgogdownloader/Manifest
index 8da7375a0a57..5cccc8e418a0 100644
--- a/games-util/lgogdownloader/Manifest
+++ b/games-util/lgogdownloader/Manifest
@@ -1,4 +1,6 @@
DIST lgogdownloader-3.7.tar.gz 85653 BLAKE2B bb6fe56be291ca726b97cfb7ce83e87e855584da911839a9bc6a923c027e7ea67e83e62a5e8bb1a0c62dd053a7d6728c1e82896d19ba48a310574dc8c6a647f5 SHA512 2085b9c64008d790a28dcb9d22009340acac164db316523919dcf797255fd57a36160950fb222e82b9ee6262ef8c0e86193e2d9a4488ea2105f9f4bbe7db727b
+DIST lgogdownloader-3.8.tar.gz 85271 BLAKE2B ff8e9f80dbec849649b4074ab5890f833a5bfaf120246e7ca5eae83f414af469da29302323dc22632eb0a7259e49e9cf3660ea8953adda75fc7a5308204767bd SHA512 ccc6116f22a5c0bff5e4ef650f6386d5bfc507cc667b7154b021ecdbd45e7553ac33ae6b81531e2cea52a5022ee9c810033518a07374d4e9f7c672344e7ccad3
EBUILD lgogdownloader-3.7-r1.ebuild 824 BLAKE2B 4a64d63c3d70032fb06ef7bfbf3afbb87a4351fb6e017fb969d7f217420665ff47251b665191623c8a45dff4651a9720312862d2a03b4b13fdaa213c3436a6cd SHA512 a1a74b922da7a2eec57f5f7f5d653bc297d2798f2009b2651f3bb0b0c6a3e76ab4a1069ba3dbd0a27a5caa7e795cce1430fa356770fbac88fcae539935a7ad80
-EBUILD lgogdownloader-9999.ebuild 802 BLAKE2B 5cdcfe6eb2f4dedd786d2241f699efde930fac4a5e5717696e08a34398354dd57324cb8c0895ad3a8ea4d9b23dfe6bc90ba60f6b4f6db00d5840ade3cc0d584a SHA512 d78a9556d194ec71c1ad5adf09a33a02f18411a2686be6e32bf1fccb111d1d111e715c857393593623859559fb2ce312fe6e701a5d04cda663ad81121d561a28
+EBUILD lgogdownloader-3.8.ebuild 824 BLAKE2B 8f66e5a1761eda13849def434d2bfe95d4c06ef0ca222f8b8b986178a59f7c7ce04e7f8c1b73acdaff6dcd58129d5b0376d74e75045f44393e44d1a68f0c1f66 SHA512 6360c6238d29c2033ec40196a4bcbe5c939dfd280107c776108d77b6b9e4fd479c127b7bb16ac3e7a05595b89965abc3f24f8c616ee5111bce9e1b0791aa2f37
+EBUILD lgogdownloader-9999.ebuild 802 BLAKE2B 7b58e8cdf6ed1e69e9b6d1dd05c23170c5d92d1a70f72b7d3034990cdb3531b106dbc35a71e98ad2da95b9f7fb6c53556d16caa204144c1f5048d887d919aa01 SHA512 239b12971fff5743930a2780327f43b8a9d6ff7396b331fec0001a5ab850d03909ac662c506cf6c49f351a265969a154100230afcb4d8f755eb915648805e723
MISC metadata.xml 1097 BLAKE2B 029a2a56a669431f4128f2e3c375f66a03c91e101b4d18555cbff0d7e0840025b5cace7c7eae5a98f5c2a79d2ace2c0caf8824b6d29ccccd67de98fee188e924 SHA512 2dbc9390d544b0c5c215dcf6788ced1bcbf0de677dafbafa500725d4968b0ab733df82c4799c62cbe30fb058ffdc7332cb7bd1459f872093e777ce9e108ce720
diff --git a/games-util/lgogdownloader/lgogdownloader-3.8.ebuild b/games-util/lgogdownloader/lgogdownloader-3.8.ebuild
new file mode 100644
index 000000000000..805b3a49d3c0
--- /dev/null
+++ b/games-util/lgogdownloader/lgogdownloader-3.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Unofficial GOG.com downloader for Linux"
+HOMEPAGE="https://sites.google.com/site/gogdownloader/"
+SRC_URI="https://sites.google.com/site/gogdownloader/${P}.tar.gz"
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gui"
+
+RDEPEND=">=app-crypt/rhash-1.3.3-r2:0=
+ dev-cpp/htmlcxx:0=
+ dev-libs/boost:0=[zlib]
+ >=dev-libs/jsoncpp-1.7:0=
+ dev-libs/tinyxml2:0=
+ >=net-misc/curl-7.32:0=[ssl]
+ gui? ( dev-qt/qtwebengine:5=[widgets] )"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="sys-apps/help2man
+ virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_QT_GUI=$(usex gui)
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ gunzip "${ED}"/usr/share/man/man1/${PN}.1.gz || die
+}
diff --git a/games-util/lgogdownloader/lgogdownloader-9999.ebuild b/games-util/lgogdownloader/lgogdownloader-9999.ebuild
index e1817aeca2ae..39a33d8fe4fd 100644
--- a/games-util/lgogdownloader/lgogdownloader-9999.ebuild
+++ b/games-util/lgogdownloader/lgogdownloader-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake git-r3