summaryrefslogtreecommitdiff
path: root/games-util/libstrangle
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /games-util/libstrangle
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'games-util/libstrangle')
-rw-r--r--games-util/libstrangle/Manifest3
-rw-r--r--games-util/libstrangle/libstrangle-0.1.1_p20220222.ebuild71
-rw-r--r--games-util/libstrangle/metadata.xml11
3 files changed, 85 insertions, 0 deletions
diff --git a/games-util/libstrangle/Manifest b/games-util/libstrangle/Manifest
new file mode 100644
index 000000000000..696f10552731
--- /dev/null
+++ b/games-util/libstrangle/Manifest
@@ -0,0 +1,3 @@
+DIST libstrangle-0.1.1_p20220222.tar.gz 947358 BLAKE2B 2222550e28d4af1dafc43691f3021fdac30445e3223673b74f69adfe681c9b1879925b3961dc9d086f2e5cadeeca7488e1a53bcdb6e302b2e4087a0f2a19a380 SHA512 5f6d7bc5acb95be4c0083a16134dfe7c6a95ab6a73cca69ec2d92cf75ebf5ecfaea08dda0d887e8e136fd410c988c0bd36289c2a17df3eb1698b453bb38c4011
+EBUILD libstrangle-0.1.1_p20220222.ebuild 1738 BLAKE2B 96016bfee57d1add6e500572d82bc6ca34cc84360ccca795b192e62659b82f728d1cdf121213c2d76d6c80807d82e9070c9cf2649a3bdc3be007f3889996a052 SHA512 9868640ab100395db2bf7dc3edf63464059dc739f351accd2557c48da8e3ba082ad83f6426226e3a0d18ae5b9d4f53f3a9b3d4cdc2d25c204c211633446a3306
+MISC metadata.xml 332 BLAKE2B e75edf673556ac4f9fa191394e3984305272379efc2ca67149029dd037a16ea8679081ccde536648e57e61d7fc4cdeab7dd946dfc4dfe2222f9ca777636ae2b8 SHA512 2cd2bdaef93867ff657b5b752e548e74a43663549b02fe71ce0cef61662ed3a69b6d49e90f912486080e266308391f1b93a910ccf18879dd39e563a3327eb095
diff --git a/games-util/libstrangle/libstrangle-0.1.1_p20220222.ebuild b/games-util/libstrangle/libstrangle-0.1.1_p20220222.ebuild
new file mode 100644
index 000000000000..1ecf01f317d3
--- /dev/null
+++ b/games-util/libstrangle/libstrangle-0.1.1_p20220222.ebuild
@@ -0,0 +1,71 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib multilib-minimal toolchain-funcs
+
+STRANGLE_COMMIT="0273e318e3b0cc759155db8729ad74266b74cb9b"
+
+DESCRIPTION="Frame rate limiter for OpenGL/Vulkan"
+HOMEPAGE="https://gitlab.com/torkel104/libstrangle/"
+SRC_URI="https://gitlab.com/torkel104/libstrangle/-/archive/${STRANGLE_COMMIT}/${P}.tar.gz"
+S="${WORKDIR}/${PN}-${STRANGLE_COMMIT}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Note: requires a glibc version with DT_HASH fix or split libdl.so.
+# For the latter, <glibc-2.34 is acceptable but skip so portage
+# doesn't suggest downgrading to stable users.
+# https://gitlab.com/torkel104/libstrangle/-/issues/59
+# (cleanup these after fixed glibc is stable for some time)
+RDEPEND="
+ sys-apps/grep[pcre]
+ elibc_glibc? (
+ || (
+ >=sys-libs/glibc-2.35-r4
+ (
+ >=sys-libs/glibc-2.34-r12
+ <sys-libs/glibc-2.35
+ )
+ )
+ )"
+DEPEND="
+ media-libs/libglvnd
+ dev-util/vulkan-headers"
+
+QA_SONAME="usr/lib.*/libstrangle.*" # intended for dlopen()
+
+src_prepare() {
+ default
+
+ sed -ri '/^C(XX)?FLAGS=/s|=|+=$(CPPFLAGS) |' makefile || die
+
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" LD{,XX}FLAGS="${LDFLAGS}" native
+}
+
+multilib_src_install() {
+ local emakeargs=(
+ DESTDIR="${D}"
+ prefix="${EPREFIX}"/usr
+ libdir="${EPREFIX}"/usr/$(get_libdir)
+ )
+
+ emake "${emakeargs[@]}" install-native
+}
+
+multilib_src_install_all() {
+ emake DESTDIR="${D}" prefix="${EPREFIX}"/usr install-common
+ einstalldocs
+}
+
+pkg_postinst() {
+ has_multilib_profile && use amd64 && use !abi_x86_32 &&
+ ewarn "Note that USE=abi_x86_32 is needed for 32bit games (common with steam / wine)"
+}
diff --git a/games-util/libstrangle/metadata.xml b/games-util/libstrangle/metadata.xml
new file mode 100644
index 000000000000..1af7db338edf
--- /dev/null
+++ b/games-util/libstrangle/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ionen@gentoo.org</email>
+ <name>Ionen Wolkens</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="gitlab">torkel104/libstrangle</remote-id>
+ </upstream>
+</pkgmetadata>