summaryrefslogtreecommitdiff
path: root/games-util/lutris/lutris-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-30 19:43:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-30 19:43:03 +0100
commit162945d2a91899b637bbb9e163b406350de12906 (patch)
tree49cc2cc66f724a7c6f033f93aaba4ae3be1f2259 /games-util/lutris/lutris-9999.ebuild
parentf660c6de84558324d784218831d8f0782ee41e2e (diff)
gentoo resync : 30.10.2021
Diffstat (limited to 'games-util/lutris/lutris-9999.ebuild')
-rw-r--r--games-util/lutris/lutris-9999.ebuild21
1 files changed, 6 insertions, 15 deletions
diff --git a/games-util/lutris/lutris-9999.ebuild b/games-util/lutris/lutris-9999.ebuild
index 4ca63a7a2a1f..fa2c19860a63 100644
--- a/games-util/lutris/lutris-9999.ebuild
+++ b/games-util/lutris/lutris-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="sqlite,threads(+)"
DISTUTILS_SINGLE_IMPL="1"
@@ -54,26 +54,17 @@ RDEPEND="
x11-libs/libnotify[introspection]
"
-distutils_enable_tests nose
+distutils_enable_tests pytest
-src_prepare() {
- default
-
- # Avoid test failure:
- # "ERROR: Failure: OSError (data_path can't be found at : /usr/share/lutris)"
- sed -i -e "s:sys.path\[0\]:\"${S}/share\":" lutris/util/datapath.py || die
-
- distutils-r1_src_prepare
-}
+DOCS=( AUTHORS README.rst docs/installers.rst docs/steam.rst )
python_test() {
- virtx nosetests -v
+ virtx epytest
}
python_install_all() {
- local DOCS=( AUTHORS README.rst docs/installers.rst )
distutils-r1_python_install_all
- python_fix_shebang "${ED}"/usr/share/lutris/bin/lutris-wrapper #740048
+ python_fix_shebang "${ED}/usr/share/lutris/bin/lutris-wrapper" #740048
}
pkg_postinst() {