summaryrefslogtreecommitdiff
path: root/games-util/pogo-manager-bin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-util/pogo-manager-bin
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-util/pogo-manager-bin')
-rw-r--r--games-util/pogo-manager-bin/Manifest6
-rw-r--r--games-util/pogo-manager-bin/files/pogo-manager17
-rw-r--r--games-util/pogo-manager-bin/metadata.xml14
-rw-r--r--games-util/pogo-manager-bin/pogo-manager-bin-0.1.6.ebuild34
-rw-r--r--games-util/pogo-manager-bin/pogo-manager-bin-0.1.7.ebuild34
5 files changed, 105 insertions, 0 deletions
diff --git a/games-util/pogo-manager-bin/Manifest b/games-util/pogo-manager-bin/Manifest
new file mode 100644
index 000000000000..d6b512db1be0
--- /dev/null
+++ b/games-util/pogo-manager-bin/Manifest
@@ -0,0 +1,6 @@
+AUX pogo-manager 485 BLAKE2B adfc003c723b021685f9d0f5d1dd8201a1bc433091992a651c9008e6249738df81f910229cafeb85199c4818336dff78d268a9a441541e3fb1a8aa9b7cd16043 SHA512 d95abdc10df5aefca0e84a4fc39d2da62a78d82cd076ad899c0b602f639f500a13ddd3f0c1477b6ef9cc8524859cd5d72aeb827d4f1cf0b805c6a247d45c8edf
+DIST pogo-manager-bin-0.1.6.zip 7703380 BLAKE2B f50c8a96a3b93a1c0036918a24ae8b7426659327648fb249db7460d83f053393c7e7d5723abb8553135bb46c4fdea2fcf07297aa77b870d0de9a4749596a71fe SHA512 d09e5f905fad659b5f380c25e8ccb7f9423430a1210ebb15e233f7f9436dff0307897ce372fdedf1b44ff48bd682b1f991a5fa3ac28a98af18d2a2bec72b08b0
+DIST pogo-manager-bin-0.1.7.zip 7978366 BLAKE2B a9e9b9460a50adb7964ba887a89c427b7344745c84d70711dbf372c942fb6829437eddb093fbef9b2c8b2231f3c06689d163c6ec0418d3ca9a7d8f105d35306b SHA512 6d43626d0b7edb756d0a36b8114782ea78bd87fe1f4bdcd78c8d724961ad1635042ab8e0e7f489c5c5cf8b09fa14788c701a14eb5bdce1cf21ed95c3e97fa90a
+EBUILD pogo-manager-bin-0.1.6.ebuild 813 BLAKE2B 77348ed0188581e2a4702bc22630376d97fe11feb42bb471d0c96d161830dca8072825bfcb0e063eaf76dd9d9966add92bfdf9c432e1d1ac6884c47a212de905 SHA512 02e77126376f2b4877c48dee79177b71df2b0f1a18b2d93aa2f88dc28dd2612a2ba40c0929a6ed8398668ba61b641ca4efc6486aa28c777f3dabade49658355d
+EBUILD pogo-manager-bin-0.1.7.ebuild 814 BLAKE2B 9d45605e1fbc2b3ad46362800f16a1615b2865169af60737450139017981b437c549dcfb06df5f93d6ab06680aeb530b2d78eadd9fb64351e32b53a5f9b5f3ef SHA512 2c530bc42be1263c008a71c980947ea3460f473525b1175f559b4c1e60140e94243913249edbe9a6722f6507bc7544406f252c89c5a692dc1dfb7806d371f88c
+MISC metadata.xml 490 BLAKE2B cd6b153e8bbdf8c7b75c67e7236a107044ec2d9bee6db08256262b45457673bf9d55671da6d4bdb707f0187860e812f871c1f7769708544fc32ff30d014876c3 SHA512 e2b41bf4dbebfa0f1f26f0856fe291dedf7553c059b9d2d2049dc97eb9a6e0655d631fe41efc52aa67dfad5d6338548ff4602f3c6695ffbc5eb0068ce5ed446c
diff --git a/games-util/pogo-manager-bin/files/pogo-manager b/games-util/pogo-manager-bin/files/pogo-manager
new file mode 100644
index 000000000000..9866fec91a84
--- /dev/null
+++ b/games-util/pogo-manager-bin/files/pogo-manager
@@ -0,0 +1,17 @@
+#!/bin/bash
+
+# Config files are written to current directory, so make a config dir and pushd there
+
+if [[ ! -z "${XDG_CONFIG_DIR}" ]] ; then
+ config_dir="${XDG_CONFIG_DIR}/pogo-manager"
+elif [[ ! -z "${HOME}" ]] ; then
+ config_dir="${HOME}/.config/pogo-manager"
+else
+ config_dir="$(mktemp -d)"
+fi
+
+echo "Using ${config_dir} for configuration files"
+mkdir -p "${config_dir}"
+pushd "${config_dir}" > /dev/null
+java -Dfile.encoding=UTF-8 -jar /opt/pogo-manager/pogo-manager.jar
+
diff --git a/games-util/pogo-manager-bin/metadata.xml b/games-util/pogo-manager-bin/metadata.xml
new file mode 100644
index 000000000000..591d99816ca6
--- /dev/null
+++ b/games-util/pogo-manager-bin/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>wizardedit@gentoo.org</email>
+ <name>Austin English</name>
+ </maintainer>
+ <longdescription>
+ Utility to manage Pokemon Go accounts. Not sanctioned by Niantic, use at your own risk.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">Wolfsblvt/BlossomsPokemonGoManager</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-util/pogo-manager-bin/pogo-manager-bin-0.1.6.ebuild b/games-util/pogo-manager-bin/pogo-manager-bin-0.1.6.ebuild
new file mode 100644
index 000000000000..a58f94b84142
--- /dev/null
+++ b/games-util/pogo-manager-bin/pogo-manager-bin-0.1.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/-bin}"
+
+DESCRIPTION="Pokemon Go manager"
+HOMEPAGE="https://github.com/Wolfsblvt/BlossomsPokemonGoManager"
+SRC_URI="https://github.com/Wolfsblvt/BlossomsPokemonGoManager/releases/download/v${PV}/BPGM_v${PV}.zip -> ${P}.zip"
+
+LICENSE="CC-BY-NC-SA-4.0"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+IUSE=""
+
+RDEPEND="|| ( dev-java/oracle-jdk-bin:1.8[javafx] dev-java/oracle-jre-bin:1.8[javafx] )"
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/BPGM_v${PV}"
+
+src_install()
+{
+ insinto /opt/${MY_PN}
+ newins BlossomsPogoManager.jar ${MY_PN}.jar
+
+ dobin "${FILESDIR}/pogo-manager"
+}
+
+pkg_postinst()
+{
+ ewarn "Use of this tool is not sanctioned by Niantic and could get you banned."
+ ewarn "You have been warned!"
+}
diff --git a/games-util/pogo-manager-bin/pogo-manager-bin-0.1.7.ebuild b/games-util/pogo-manager-bin/pogo-manager-bin-0.1.7.ebuild
new file mode 100644
index 000000000000..5d4eb27d04bc
--- /dev/null
+++ b/games-util/pogo-manager-bin/pogo-manager-bin-0.1.7.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/-bin}"
+
+DESCRIPTION="Pokemon Go manager"
+HOMEPAGE="https://github.com/Wolfsblvt/BlossomsPokemonGoManager"
+SRC_URI="https://github.com/Wolfsblvt/BlossomsPokemonGoManager/releases/download/v${PV}/BPGM_v${PV}.zip -> ${P}.zip"
+
+LICENSE="CC-BY-NC-SA-4.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="|| ( dev-java/oracle-jdk-bin:1.8[javafx] dev-java/oracle-jre-bin:1.8[javafx] )"
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/BPGM_v${PV}"
+
+src_install()
+{
+ insinto /opt/${MY_PN}
+ newins BlossomsPogoManager.jar ${MY_PN}.jar
+
+ dobin "${FILESDIR}/pogo-manager"
+}
+
+pkg_postinst()
+{
+ ewarn "Use of this tool is not sanctioned by Niantic and could get you banned."
+ ewarn "You have been warned!"
+}