summaryrefslogtreecommitdiff
path: root/games-util/umodpack
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-util/umodpack
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-util/umodpack')
-rw-r--r--games-util/umodpack/Manifest3
-rw-r--r--games-util/umodpack/metadata.xml8
-rw-r--r--games-util/umodpack/umodpack-0.5_beta16-r2.ebuild46
3 files changed, 57 insertions, 0 deletions
diff --git a/games-util/umodpack/Manifest b/games-util/umodpack/Manifest
new file mode 100644
index 000000000000..88f4fb7cc9ba
--- /dev/null
+++ b/games-util/umodpack/Manifest
@@ -0,0 +1,3 @@
+DIST umodpack-0.5b16-allinone.tar.gz 3605080 BLAKE2B 718208835f318c85305f266a23f9fa5c2966031924d4d4e3a5cdee649afaee64ed5ac753e630ef6783a49581b932a44d8b0dafa3e97603eb1706190f3c7e10d5 SHA512 3678507c7aec30043f50f5519935e2d5eb7471b5e0692ba8b27c506bdd7a067fdb055e6731a6bffb04bb3008020c889f3486624a1466a77e0eab3e5139003ff0
+EBUILD umodpack-0.5_beta16-r2.ebuild 968 BLAKE2B 23eaa1f37092fd58f7b01f8f3c9549f7b5e80ec20be6910cc91e803896fc8b7bfd95372c3c6da02473ae27df2c973f72c35879d7f2dfb88b34acfdddf8a5e1fa SHA512 e97de8824e672d0a6812868133cee06b3452a35f595b88a0f9fea06f2fd7a96b0d557a7081cda9d16283855d1cc76b33eb6607a6dabb664989b7817950943b41
+MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-util/umodpack/metadata.xml b/games-util/umodpack/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-util/umodpack/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-util/umodpack/umodpack-0.5_beta16-r2.ebuild b/games-util/umodpack/umodpack-0.5_beta16-r2.ebuild
new file mode 100644
index 000000000000..772fe6487292
--- /dev/null
+++ b/games-util/umodpack/umodpack-0.5_beta16-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit perl-module toolchain-funcs
+
+MY_P=${P/_beta/b}
+DESCRIPTION="portable and useful [un]packer for Unreal Tournament's Umod files"
+HOMEPAGE="http://www.oldunreal.com/wiki/index.php?title=UmodPack"
+SRC_URI="mirror://gentoo/${MY_P}-allinone.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="tk"
+
+DEPEND="virtual/perl-IO-Compress
+ dev-perl/Archive-Zip
+ dev-perl/Tie-IxHash
+ tk? ( dev-perl/Tk )"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${MY_P}
+SRC_TEST="do parallel"
+
+src_prepare() {
+ # remove the stupid perl modules since we already installed em
+ rm -rf {Archive-Zip,Compress-Zlib,Tie-IxHash,Tk}* || die
+}
+
+src_compile() {
+ perl-module_src_compile
+
+ cd umr-0.3 || die
+ emake DEBUG=0 CFLAGS="${CFLAGS}" CC="$(tc-getCC)"
+}
+
+src_install() {
+ mydoc="Changes"
+ perl-module_src_install
+ dobin umod umr-0.3/umr
+ if use tk ; then
+ dobin xumod
+ fi
+}