summaryrefslogtreecommitdiff
path: root/games-util/uz2unpack/uz2unpack-0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-util/uz2unpack/uz2unpack-0.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'games-util/uz2unpack/uz2unpack-0.1.ebuild')
-rw-r--r--games-util/uz2unpack/uz2unpack-0.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/games-util/uz2unpack/uz2unpack-0.1.ebuild b/games-util/uz2unpack/uz2unpack-0.1.ebuild
new file mode 100644
index 000000000000..c82230aa1692
--- /dev/null
+++ b/games-util/uz2unpack/uz2unpack-0.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="UZ2 Decompressor for UT2003/UT2004"
+HOMEPAGE="http://icculus.org/cgi-bin/ezmlm/ezmlm-cgi?42:mss:1013:200406:kikgppboefcimdbadcdo"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+DEPEND="sys-libs/zlib"
+RDEPEND=${DEPEND}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LDLIBS=-lz ${PN}
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc README
+}