summaryrefslogtreecommitdiff
path: root/games-util/vispatch/vispatch-1.4.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-util/vispatch/vispatch-1.4.6.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-util/vispatch/vispatch-1.4.6.ebuild')
-rw-r--r--games-util/vispatch/vispatch-1.4.6.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/games-util/vispatch/vispatch-1.4.6.ebuild b/games-util/vispatch/vispatch-1.4.6.ebuild
new file mode 100644
index 000000000000..1bb5067893ac
--- /dev/null
+++ b/games-util/vispatch/vispatch-1.4.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="WaterVIS utility for glquake"
+HOMEPAGE="http://vispatch.sourceforge.net/"
+SRC_URI="mirror://sourceforge/vispatch/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S=${WORKDIR}/${P}/source
+
+src_prepare() {
+ sed -i \
+ -e '/^CFLAGS/d' \
+ -e '/^LDFLAGS/d' \
+ makefile || die
+ tc-export CC
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc ${PN}.txt
+}