summaryrefslogtreecommitdiff
path: root/games-util/wxchtdecoder/wxchtdecoder-1.5a-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-util/wxchtdecoder/wxchtdecoder-1.5a-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'games-util/wxchtdecoder/wxchtdecoder-1.5a-r1.ebuild')
-rw-r--r--games-util/wxchtdecoder/wxchtdecoder-1.5a-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/games-util/wxchtdecoder/wxchtdecoder-1.5a-r1.ebuild b/games-util/wxchtdecoder/wxchtdecoder-1.5a-r1.ebuild
new file mode 100644
index 000000000000..adaa68ec3e1f
--- /dev/null
+++ b/games-util/wxchtdecoder/wxchtdecoder-1.5a-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+WX_GTK_VER="3.0"
+inherit eutils wxwidgets
+
+DESCRIPTION="A program to decode .CHT files in Snes9x and ZSNES to plain text"
+HOMEPAGE="http://games.technoplaza.net/chtdecoder/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="x11-libs/wxGTK:${WX_GTK_VER}[X]"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-wxgtk.patch
+}
+
+src_configure() {
+ econf --with-wx-config=${WX_CONFIG}
+}
+
+src_install() {
+ dobin source/wxchtdecoder
+ dodoc docs/wxchtdecoder.txt
+}