summaryrefslogtreecommitdiff
path: root/games-util/xgamer/xgamer-0.6.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-util/xgamer/xgamer-0.6.2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-util/xgamer/xgamer-0.6.2.ebuild')
-rw-r--r--games-util/xgamer/xgamer-0.6.2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/games-util/xgamer/xgamer-0.6.2.ebuild b/games-util/xgamer/xgamer-0.6.2.ebuild
new file mode 100644
index 000000000000..ab29f4ccbd52
--- /dev/null
+++ b/games-util/xgamer/xgamer-0.6.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit perl-module
+
+DESCRIPTION="A launcher for starting games in a second X session"
+HOMEPAGE="https://code.google.com/p/xgamer/"
+SRC_URI="https://xgamer.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/perl-5.10
+ >=x11-libs/gtk+-2.18:2
+ >=dev-perl/Gtk2-1.120
+ virtual/perl-File-Path
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ dev-perl/File-BaseDir
+ dev-perl/XML-Twig
+ dev-perl/glib-perl
+ x11-misc/numlockx
+ media-gfx/feh"
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build"
+
+S=${WORKDIR}/${PN}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-desktopfile.patch
+ "${FILESDIR}"/${P}-perl526.patch
+)
+
+pkg_postinst() {
+ elog "optional dependencies:"
+ elog " x11-wm/openbox (integrates well)"
+}