summaryrefslogtreecommitdiff
path: root/games-util/xqf/xqf-1.0.6.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-util/xqf/xqf-1.0.6.2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-util/xqf/xqf-1.0.6.2.ebuild')
-rw-r--r--games-util/xqf/xqf-1.0.6.2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/games-util/xqf/xqf-1.0.6.2.ebuild b/games-util/xqf/xqf-1.0.6.2.ebuild
new file mode 100644
index 000000000000..5ea89476375a
--- /dev/null
+++ b/games-util/xqf/xqf-1.0.6.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="A server browser for many FPS games (frontend for qstat)"
+HOMEPAGE="http://xqf.github.io/en/"
+SRC_URI="https://github.com/XQF/xqf/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="bzip2 geoip nls"
+
+RDEPEND="x11-libs/gtk+:2
+ >=games-util/qstat-2.11
+ nls? ( virtual/libintl )
+ geoip? ( dev-libs/geoip )
+ bzip2? ( app-arch/bzip2 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/${PN}-${P}
+
+# bug #288853
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-underlink.patch \
+ "${FILESDIR}"/${P}-zlib-1.2.5.1-compile-fix.patch
+ sed -i \
+ -e '/Icon/s/.png//' \
+ xqf.desktop.in || die
+
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable geoip) \
+ $(use_enable bzip2)
+}