summaryrefslogtreecommitdiff
path: root/gnome-base/dconf/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /gnome-base/dconf/files
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'gnome-base/dconf/files')
-rw-r--r--gnome-base/dconf/files/0.32.0-drop-vapigen-dep.patch2
-rw-r--r--gnome-base/dconf/files/0.32.0-meson-0.52-compat.patch35
2 files changed, 36 insertions, 1 deletions
diff --git a/gnome-base/dconf/files/0.32.0-drop-vapigen-dep.patch b/gnome-base/dconf/files/0.32.0-drop-vapigen-dep.patch
index 55959a7febf0..0dcb72358bde 100644
--- a/gnome-base/dconf/files/0.32.0-drop-vapigen-dep.patch
+++ b/gnome-base/dconf/files/0.32.0-drop-vapigen-dep.patch
@@ -34,7 +34,7 @@ index f3b7122..7dbca97 100644
+ define_variable: ['datadir', dconf_datadir]
)
+ else
-+ vapi_dir = dconf_datadir / 'vala' / 'vapi'
++ vapi_dir = join_paths(dconf_datadir, 'vala', 'vapi')
+ endif
install_data(
diff --git a/gnome-base/dconf/files/0.32.0-meson-0.52-compat.patch b/gnome-base/dconf/files/0.32.0-meson-0.52-compat.patch
new file mode 100644
index 000000000000..7b5d8c5aefc0
--- /dev/null
+++ b/gnome-base/dconf/files/0.32.0-meson-0.52-compat.patch
@@ -0,0 +1,35 @@
+From cc32667c5d7d9ff95e65cc21f59905d8f9218394 Mon Sep 17 00:00:00 2001
+From: Diego Escalante Urrelo <diegoe@gnome.org>
+Date: Thu, 31 Oct 2019 05:51:22 -0500
+Subject: [PATCH] build: Update use of link_whole for meson-0.52
+
+A regression in meson-0.52 caused uses of link_whole to expose scenarios
+where duplicate symbols issues could appear. In particular
+libdconf_client_dep was being link_whole'd to itself, which recursively
+already included libdconf_common which was also a link_whole.
+
+This change does not modify the available symbols in libdconf.so, and is
+compatible with meson-0.52 and 0.51.
+
+See: https://github.com/mesonbuild/meson/pull/6030
+Fixes: https://gitlab.gnome.org/GNOME/dconf/issues/59
+---
+ client/meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/client/meson.build b/client/meson.build
+index f3b7122..de6387e 100644
+--- a/client/meson.build
++++ b/client/meson.build
+@@ -28,7 +28,7 @@ libdconf_client = static_library(
+
+ libdconf_client_dep = declare_dependency(
+ dependencies: gio_dep,
+- link_whole: libdconf_client,
++ link_with: libdconf_client,
+ )
+
+ libdconf = shared_library(
+--
+2.20.1
+