summaryrefslogtreecommitdiff
path: root/gnome-base/libbonobo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /gnome-base/libbonobo
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'gnome-base/libbonobo')
-rw-r--r--gnome-base/libbonobo/Manifest3
-rw-r--r--gnome-base/libbonobo/libbonobo-2.24.3-r1.ebuild65
-rw-r--r--gnome-base/libbonobo/metadata.xml8
3 files changed, 76 insertions, 0 deletions
diff --git a/gnome-base/libbonobo/Manifest b/gnome-base/libbonobo/Manifest
new file mode 100644
index 000000000000..2a863df66969
--- /dev/null
+++ b/gnome-base/libbonobo/Manifest
@@ -0,0 +1,3 @@
+DIST libbonobo-2.24.3.tar.bz2 1354929 BLAKE2B 44f8d7bf4530363dd680fb277dbacabb85a3871fd3645ef7aa4a2a4dbd112a31329c8295637f73e37853035ac0e2cd7b918b2966f58fbcccd5abc943c02a2cc5 SHA512 c97224ba2d4afc07e520399aa04849487a4ec4dd1b80b56e0472b4c3ebbddd0ce0105ba63ca2f823590788754791127dbe86b49cb39239db0019f8104db25716
+EBUILD libbonobo-2.24.3-r1.ebuild 1536 BLAKE2B 64649733ace865324333a93aec10a789eb477c31bac61d3fc46965787c7608e700a4232336c4829189ce1cf86b2892a647b3d17f64669e815d6afd269e1440bd SHA512 c7d376ee9959e9b885ac8cbd53a3029062ecd7f7093f9fddc5075e328cd529e5a5caa298c378c79507f5fe31a305087165681ddced153adbef1161b66bdf53cc
+MISC metadata.xml 249 BLAKE2B e71e1b95fee768c696704acbf7e3cf0e599ed2bc8de92bae0141d1194ef9e842bdc292798904487a9b90ddfda9b0e84abd3b76b1518576c1d288240e4e46f110 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506
diff --git a/gnome-base/libbonobo/libbonobo-2.24.3-r1.ebuild b/gnome-base/libbonobo/libbonobo-2.24.3-r1.ebuild
new file mode 100644
index 000000000000..4be2587ea505
--- /dev/null
+++ b/gnome-base/libbonobo/libbonobo-2.24.3-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+GNOME_TARBALL_SUFFIX="bz2"
+
+inherit gnome2
+
+DESCRIPTION="GNOME CORBA framework"
+HOMEPAGE="https://developer.gnome.org/libbonobo/stable/"
+
+LICENSE="LGPL-2.1 GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE="debug examples test"
+
+RDEPEND="
+ >=dev-libs/glib-2.14:2
+ >=gnome-base/orbit-2.14.0
+ >=dev-libs/libxml2-2.4.20:2
+ >=sys-apps/dbus-1.0.0
+ >=dev-libs/dbus-glib-0.74
+ >=dev-libs/popt-1.5
+ !gnome-base/bonobo-activation
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ virtual/yacc
+ sys-devel/flex
+ x11-apps/xrdb
+ virtual/pkgconfig
+ >=dev-util/intltool-0.35
+"
+
+# Tests are broken in several ways as reported in bug #288689 and upstream
+# doesn't take care since libbonobo is deprecated.
+RESTRICT="test"
+
+src_prepare() {
+ # Fix intltoolize broken file, see upstream #577133
+ sed "s:'\^\$\$lang\$\$':\^\$\$lang\$\$:g" -i po/Makefile.in.in || die
+
+ if ! use test; then
+ # don't waste time building tests, bug #226223
+ sed 's/tests//' -i Makefile.am Makefile.in || die
+ fi
+
+ if ! use examples; then
+ sed 's/samples//' -i Makefile.am Makefile.in || die
+ fi
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure $(use_enable debug bonobo-activation-debug)
+}
+
+src_test() {
+ # Pass tests with FEATURES userpriv, see bug #288689
+ unset ORBIT_SOCKETDIR
+ emake check
+}
diff --git a/gnome-base/libbonobo/metadata.xml b/gnome-base/libbonobo/metadata.xml
new file mode 100644
index 000000000000..39980802b1da
--- /dev/null
+++ b/gnome-base/libbonobo/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+</maintainer>
+</pkgmetadata>