summaryrefslogtreecommitdiff
path: root/gnome-base/nautilus/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-01 01:09:37 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-01 01:09:37 +0100
commit290844d409ace33d948956aec3c542ea6f4a7b13 (patch)
treea1849e2730c9848c11d12aa322070e4e87edb729 /gnome-base/nautilus/files
parent31459e63971ac3b08706bba949851d93c45043c3 (diff)
gentoo auto-resync : 01:10:2022 - 01:09:37
Diffstat (limited to 'gnome-base/nautilus/files')
-rw-r--r--gnome-base/nautilus/files/43.0-docs-build.patch41
-rw-r--r--gnome-base/nautilus/files/43.0-optional-gstreamer.patch42
2 files changed, 83 insertions, 0 deletions
diff --git a/gnome-base/nautilus/files/43.0-docs-build.patch b/gnome-base/nautilus/files/43.0-docs-build.patch
new file mode 100644
index 000000000000..653970dc26ad
--- /dev/null
+++ b/gnome-base/nautilus/files/43.0-docs-build.patch
@@ -0,0 +1,41 @@
+From a62478c8e55bc6b1cd685f0c8c2094e1ed244c69 Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <leio@gentoo.org>
+Date: Mon, 11 Mar 2019 20:52:53 +0200
+Subject: [PATCH] build: Always install man page
+
+It's already generated and shouldn't be thrown in the same pot as
+full gtk-doc generation. It should be either a separate `man` option,
+or just always installed.
+---
+ docs/meson.build | 4 +++-
+ meson.build | 4 +---
+ 2 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/docs/meson.build b/docs/meson.build
+index b039cb631..2b1800be6 100644
+--- a/docs/meson.build
++++ b/docs/meson.build
+@@ -1,4 +1,5 @@
+ install_man('nautilus.1')
+ install_man('nautilus-autorun-software.1')
+-
+-subdir('reference')
++if get_option('docs')
++ subdir('reference')
++endif
+diff --git a/meson.build b/meson.build
+index 996360a62..50479f5f0 100644
+--- a/meson.build
++++ b/meson.build
+@@ -205,9 +205,8 @@ subdirs = [
+ # Conditional building #
+ ########################
+
+-if gi_docgen.found()
+- subdirs += 'docs'
+-endif
++subdirs += 'docs'
++
+ if get_option('tests') != 'none'
+ subdirs += 'test'
+ endif
diff --git a/gnome-base/nautilus/files/43.0-optional-gstreamer.patch b/gnome-base/nautilus/files/43.0-optional-gstreamer.patch
new file mode 100644
index 000000000000..de0e008fffb7
--- /dev/null
+++ b/gnome-base/nautilus/files/43.0-optional-gstreamer.patch
@@ -0,0 +1,42 @@
+diff --git a/extensions/meson.build b/extensions/meson.build
+index a10349c..5494275 100644
+--- a/extensions/meson.build
++++ b/extensions/meson.build
+@@ -1,2 +1,4 @@
+ subdir('image-properties')
+-subdir('audio-video-properties')
++if get_option('gstreamer')
++ subdir('audio-video-properties')
++endif
+diff --git a/meson.build b/meson.build
+index 00f01f6..bdbd33a 100644
+--- a/meson.build
++++ b/meson.build
+@@ -102,8 +102,10 @@ libm = cc.find_library('m')
+ if get_option('extensions')
+ gexiv = dependency('gexiv2', version: '>= 0.14.0')
+ gdkpixbuf = dependency('gdk-pixbuf-2.0', version: '>= 2.30.0')
++ if get_option('gstreamer')
+ gst_tag_dep = dependency('gstreamer-tag-1.0')
+ gst_pbutils_dep = dependency('gstreamer-pbutils-1.0')
++ endif
+ endif
+ gio = dependency('gio-2.0', version: glib_ver)
+ gio_unix = dependency('gio-unix-2.0', version: glib_ver)
+diff --git a/meson_options.txt b/meson_options.txt
+index fce5f16..1fa8f89 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -13,6 +13,12 @@ option(
+ value: true,
+ description: 'Build stock extensions',
+ )
++option(
++ 'gstreamer',
++ type: 'boolean',
++ value: true,
++ description: 'Build audio-video properties extension (requires "extensions")',
++)
+ option(
+ 'introspection',
+ type: 'boolean',