summaryrefslogtreecommitdiff
path: root/gnome-extra/chrome-gnome-shell
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /gnome-extra/chrome-gnome-shell
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'gnome-extra/chrome-gnome-shell')
-rw-r--r--gnome-extra/chrome-gnome-shell/Manifest2
-rw-r--r--gnome-extra/chrome-gnome-shell/chrome-gnome-shell-10-r5.ebuild (renamed from gnome-extra/chrome-gnome-shell/chrome-gnome-shell-10-r4.ebuild)19
2 files changed, 11 insertions, 10 deletions
diff --git a/gnome-extra/chrome-gnome-shell/Manifest b/gnome-extra/chrome-gnome-shell/Manifest
index c6536ed1d557..5f6b0fd3baee 100644
--- a/gnome-extra/chrome-gnome-shell/Manifest
+++ b/gnome-extra/chrome-gnome-shell/Manifest
@@ -1,3 +1,3 @@
DIST chrome-gnome-shell-10.tar.xz 158972 BLAKE2B fe4df942f885aee40d5c5e01dcd127a9deb46aeb57765336c91a7a9c56f7c953eb36d822ffa821300b99e3d765c1b162767fc5debc24e42a16bddb1404796c9c SHA512 cf0d108c3fb57deb4926a4cf043dd64d776eda4c01ec595a1472c6c45726b8460381b9bd7cb1b43d7a5bd8a585be0d1b648c720a2f0a7a377c133b8750e76cd6
-EBUILD chrome-gnome-shell-10-r4.ebuild 1408 BLAKE2B d39507fa77f3d8010ef3116a2b327ce511581f9169f75a6924f26dfe3d90a483c1497ce09b3dff56e19abfcfb0abf014a00d438f51a12744708868efca4de43f SHA512 1a4aeb07487594df9bccd58ba78bcd009ebf81357cb3c1dd1b9184ea35c882e634da3f0eb779381ed903863e92585eeee7856a11c3fbed29637e4e8dee3218bb
+EBUILD chrome-gnome-shell-10-r5.ebuild 1401 BLAKE2B 71e9615355e527e5e4569889647f8871d1ce1e54660a0a96d32affb05fdeef752836cd863b1793142f81704a2a385f813b99967d463b225bc010248f9837497d SHA512 91ec86e2b3a9958f1f2c2056a9bbabc6a83a31ac34654cd820dadf17680f6d932ee56fb1c11b71ef5c95948cf2b648cb15a0cfe0d032d087f7ea69486667d5d5
MISC metadata.xml 569 BLAKE2B 75ca01eca709bea5e7e2876676f2cead028f56f99ea921f6c8068191ab1497c2424f2b0b526a35b347bdf95a0ec851237b1091647294f122d208f7df4112e4e2 SHA512 93b2791f3bdcc9462030f0afcf5c9fe956f92ddb1fa26c024b9a689476cb0055dcefdfc4f62200d2648733e4b3a83e8592ec0c4bb79ce7400f7e5d3e5a8879b7
diff --git a/gnome-extra/chrome-gnome-shell/chrome-gnome-shell-10-r4.ebuild b/gnome-extra/chrome-gnome-shell/chrome-gnome-shell-10-r5.ebuild
index fdd0cb9ab06c..8198915b17bf 100644
--- a/gnome-extra/chrome-gnome-shell/chrome-gnome-shell-10-r4.ebuild
+++ b/gnome-extra/chrome-gnome-shell/chrome-gnome-shell-10-r5.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
-inherit cmake-utils python-single-r1
+inherit cmake python-single-r1
DESCRIPTION="GNOME Shell integration for Chrome/Chromium, Firefox, Vivaldi, Opera browsers"
HOMEPAGE="https://wiki.gnome.org/Projects/GnomeShellIntegrationForChrome"
@@ -18,10 +18,7 @@ IUSE=""
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-DEPEND="${PYTHON_DEPS}
- app-misc/jq
- sys-apps/coreutils
-"
+DEPEND="${PYTHON_DEPS}"
RDEPEND="${PYTHON_DEPS}
$(python_gen_cond_dep '
dev-python/pygobject:3[${PYTHON_USEDEP}]
@@ -29,14 +26,18 @@ RDEPEND="${PYTHON_DEPS}
')
gnome-base/gnome-shell
"
+BDEPEND="
+ app-misc/jq
+ sys-apps/coreutils
+"
src_configure() {
local mycmakeargs=( -DBUILD_EXTENSION=OFF )
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
if [[ $(get_libdir) != "lib" && "${SYMLINK_LIB}" != yes ]]; then
# Workaround www-client/firefox-bin manifests location