summaryrefslogtreecommitdiff
path: root/gnome-extra/chrome-gnome-shell
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /gnome-extra/chrome-gnome-shell
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'gnome-extra/chrome-gnome-shell')
-rw-r--r--gnome-extra/chrome-gnome-shell/Manifest3
-rw-r--r--gnome-extra/chrome-gnome-shell/chrome-gnome-shell-10-r1.ebuild51
-rw-r--r--gnome-extra/chrome-gnome-shell/chrome-gnome-shell-10.ebuild4
3 files changed, 55 insertions, 3 deletions
diff --git a/gnome-extra/chrome-gnome-shell/Manifest b/gnome-extra/chrome-gnome-shell/Manifest
index e12a98a4b511..56e4620505c3 100644
--- a/gnome-extra/chrome-gnome-shell/Manifest
+++ b/gnome-extra/chrome-gnome-shell/Manifest
@@ -1,3 +1,4 @@
DIST chrome-gnome-shell-10.tar.xz 158972 BLAKE2B fe4df942f885aee40d5c5e01dcd127a9deb46aeb57765336c91a7a9c56f7c953eb36d822ffa821300b99e3d765c1b162767fc5debc24e42a16bddb1404796c9c SHA512 cf0d108c3fb57deb4926a4cf043dd64d776eda4c01ec595a1472c6c45726b8460381b9bd7cb1b43d7a5bd8a585be0d1b648c720a2f0a7a377c133b8750e76cd6
-EBUILD chrome-gnome-shell-10.ebuild 1038 BLAKE2B 00dc41dc18f0d750f82656d0f48c039974ed7484a2d518f4eb5d523400a28de45f26d71fbd92a303e141b308e66e3ea1a3ee3b46230ec14506b97be11fe79162 SHA512 5087fe9300593d578d1c32f3af8558875bd08d3f07132827da0527b51ae1fcc624e46b925952c68973eac6d37408618457d78471a829a1e3741fca50bafcc323
+EBUILD chrome-gnome-shell-10-r1.ebuild 1399 BLAKE2B 052f9863288de6f60e2395161fbc91d2c3cf94e268411acd17b2050235d458df623b3e92bb6b23fae0762a71dfc3b2797c098e3ca8d607571776b62d7d7aa5db SHA512 79b5c2a483cbce7e450ecefd7d2b60b3b6fd7b987c94a35d59b667b308c8030243c56c7c1ee3da52255f545d444937aff0420ae0151860bfc7fc06fe9ba2c3b1
+EBUILD chrome-gnome-shell-10.ebuild 1036 BLAKE2B d65fb38160852887d20f5da9271a97245f48705d5591752f6f4cbd05b0bf50a086406dc748139e7a16c27188bfb4d60187f2f0e0a7b409785cbf83e25ae69bb3 SHA512 b1aef359f6fcc19729cdb4be162db62fe9eb8e16ea1eb0a19bedb295a64465de50b06c83f06041e831052c337fae6f7b053f21eb82cdca8948bd8a54f3fd0455
MISC metadata.xml 538 BLAKE2B 730cc561a29ab8e4506843dfaa1520af6a8ef1b3139856fbb4e7ba077eab90f28f0440c0b511e0c11167961971ebe0b1b7b53ce386d2f82d4d20b0e9f41664a9 SHA512 fed3f8fac456d95085878b4f3a5f9a0c139df07d4c3a515412727f4e4a805456736d5e36df6397e2a38dbf7043f4e83e2ffddf2615749fa7a43734a17b0ea3b2
diff --git a/gnome-extra/chrome-gnome-shell/chrome-gnome-shell-10-r1.ebuild b/gnome-extra/chrome-gnome-shell/chrome-gnome-shell-10-r1.ebuild
new file mode 100644
index 000000000000..5e66e29d6797
--- /dev/null
+++ b/gnome-extra/chrome-gnome-shell/chrome-gnome-shell-10-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+
+inherit cmake-utils python-single-r1
+
+DESCRIPTION="GNOME Shell integration for Chrome/Chromium, Firefox, Vivaldi, Opera browsers"
+HOMEPAGE="https://wiki.gnome.org/Projects/GnomeShellIntegrationForChrome"
+SRC_URI="mirror://gnome/sources/${PN}/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ app-misc/jq
+ sys-apps/coreutils
+"
+RDEPEND="${PYTHON_DEPS}
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ gnome-base/gnome-shell
+"
+
+src_configure() {
+ local mycmakeargs=( -DBUILD_EXTENSION=OFF )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if [[ $(get_libdir) != "lib" && "${SYMLINK_LIB}" != yes ]]; then
+ # Workaround www-client/firefox-bin manifests location
+ # Bug: https://bugs.gentoo.org/643522
+ insinto /usr/lib/mozilla/native-messaging-hosts
+ doins "${ED}"/usr/$(get_libdir)/mozilla/native-messaging-hosts/org.gnome.chrome_gnome_shell.json
+ fi
+}
+
+pkg_postinst() {
+ elog "Please note that this package provides native messaging connector only."
+ elog "You can install browser extension using link provided at"
+ elog "https://extensions.gnome.org website."
+}
diff --git a/gnome-extra/chrome-gnome-shell/chrome-gnome-shell-10.ebuild b/gnome-extra/chrome-gnome-shell/chrome-gnome-shell-10.ebuild
index 2389b912cc20..7ea1fb9f0045 100644
--- a/gnome-extra/chrome-gnome-shell/chrome-gnome-shell-10.ebuild
+++ b/gnome-extra/chrome-gnome-shell/chrome-gnome-shell-10.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
inherit cmake-utils python-single-r1