summaryrefslogtreecommitdiff
path: root/gnome-extra/cinnamon/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /gnome-extra/cinnamon/files
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'gnome-extra/cinnamon/files')
-rw-r--r--gnome-extra/cinnamon/files/cinnamon-4.8.6-build-fixes.patch28
-rw-r--r--gnome-extra/cinnamon/files/cinnamon-5.2.7-optional-eds.patch85
2 files changed, 85 insertions, 28 deletions
diff --git a/gnome-extra/cinnamon/files/cinnamon-4.8.6-build-fixes.patch b/gnome-extra/cinnamon/files/cinnamon-4.8.6-build-fixes.patch
deleted file mode 100644
index bc4476a5892e..000000000000
--- a/gnome-extra/cinnamon/files/cinnamon-4.8.6-build-fixes.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-diff --git a/meson.build b/meson.build
-index a4d49a16..eff937ac 100644
---- a/meson.build
-+++ b/meson.build
-@@ -36,8 +36,6 @@ gio_unix = dependency('gio-unix-2.0')
- gl = dependency('gl')
- glib_version = '2.52.0'
- glib = dependency('glib-2.0', version: '>= ' + glib_version)
--gstreamer = dependency('gstreamer-1.0')
--gstreamer_base = dependency('gstreamer-base-1.0')
- gtk = dependency('gtk+-3.0', version: '>= 3.12.0')
- muffin = dependency('libmuffin', version: '>= 4.0.3')
- muffinlibdir = muffin.get_pkgconfig_variable('typelibdir')
-@@ -53,6 +51,14 @@ if has_nm
- dependency('libnm')
- endif
-
-+if get_option('build_recorder')
-+ gstreamer = dependency('gstreamer-1.0')
-+ gstreamer_base = dependency('gstreamer-base-1.0')
-+else
-+ gstreamer = dependency('', required: false)
-+ gstreamer_base = dependency('', required: false)
-+endif
-+
- # on some systems we need to find the math lib to make sure it builds
- cc = meson.get_compiler('c')
- math = cc.find_library('m', required: false)
diff --git a/gnome-extra/cinnamon/files/cinnamon-5.2.7-optional-eds.patch b/gnome-extra/cinnamon/files/cinnamon-5.2.7-optional-eds.patch
new file mode 100644
index 000000000000..c0646359552b
--- /dev/null
+++ b/gnome-extra/cinnamon/files/cinnamon-5.2.7-optional-eds.patch
@@ -0,0 +1,85 @@
+diff --git a/files/usr/share/cinnamon/applets/calendar@cinnamon.org/eventView.js b/files/usr/share/cinnamon/applets/calendar@cinnamon.org/eventView.js
+index 1d1035c60..ebfd5a3a4 100644
+--- a/files/usr/share/cinnamon/applets/calendar@cinnamon.org/eventView.js
++++ b/files/usr/share/cinnamon/applets/calendar@cinnamon.org/eventView.js
+@@ -301,7 +301,7 @@ class EventsManager {
+ }
+
+ start_events() {
+- if (this._calendar_server == null) {
++ if (this._calendar_server == null && Cinnamon.CalendarServerProxy) {
+ Cinnamon.CalendarServerProxy.new_for_bus(
+ Gio.BusType.SESSION,
+ // Gio.DBusProxyFlags.NONE,
+diff --git a/meson.build b/meson.build
+index 2c1baf47d..aba5d5a30 100644
+--- a/meson.build
++++ b/meson.build
+@@ -179,6 +179,9 @@ install_subdir(
+ strip_directory: true,
+ )
+
+-subdir('calendar-server')
++
++if get_option('build_calendar_server')
++ subdir('calendar-server')
++endif
+ subdir('python3')
+ subdir('install-scripts')
+diff --git a/meson_options.txt b/meson_options.txt
+index 82422246b..752f7904e 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -13,6 +13,11 @@ option('build_recorder',
+ value: true,
+ description: 'Build the cinnamon recorder into source'
+ )
++option('build_calendar_server',
++ type: 'boolean',
++ value: true,
++ description: 'Build the cinnamon EDS calendar server'
++)
+ option('disable_networkmanager',
+ type: 'boolean',
+ value: false,
+diff --git a/src/meson.build b/src/meson.build
+index 7999c0a67..1b22aa279 100644
+--- a/src/meson.build
++++ b/src/meson.build
+@@ -3,12 +3,6 @@ subdir('hotplug-sniffer')
+
+ include_src = include_directories('.')
+
+-calendar_generated = gnome.gdbus_codegen('cinnamon-calendar',
+- sources: 'org.cinnamon.CalendarServer.xml',
+- interface_prefix: 'org.cinnamon.',
+- namespace: 'Cinnamon'
+-)
+-
+ cinnamon_headers = [
+ 'cinnamon-app.h',
+ 'cinnamon-app-system.h',
+@@ -59,10 +53,21 @@ cinnamon_sources = [
+ 'cinnamon-window-tracker.c',
+ 'cinnamon-wm.c',
+ 'cinnamon-xfixes-cursor.c',
+- cinnamon_headers,
+- calendar_generated
++ cinnamon_headers
+ ]
+
++if get_option('build_calendar_server')
++ calendar_generated = gnome.gdbus_codegen('cinnamon-calendar',
++ sources: 'org.cinnamon.CalendarServer.xml',
++ interface_prefix: 'org.cinnamon.',
++ namespace: 'Cinnamon'
++ )
++
++ cinnamon_sources += [
++ calendar_generated
++ ]
++endif
++
+ cinnamon_enum_types = gnome.mkenums_simple(
+ 'cinnamon-enum-types',
+ sources: cinnamon_headers,