summaryrefslogtreecommitdiff
path: root/gnome-extra/cjs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-03-11 01:49:36 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-03-11 01:49:36 +0000
commitcf7807d7aea23a99a144afceaba961cfed652b5f (patch)
treeffd2c781c27e0b7e72152a685a04938a2b7966f0 /gnome-extra/cjs
parent7c5ebaf83da4c538dd11b56fdd5dfdf39dcbc096 (diff)
gentoo auto-resync : 11:03:2025 - 01:49:36HEADmaster
Diffstat (limited to 'gnome-extra/cjs')
-rw-r--r--gnome-extra/cjs/Manifest2
-rw-r--r--gnome-extra/cjs/cjs-6.4.0.ebuild91
2 files changed, 93 insertions, 0 deletions
diff --git a/gnome-extra/cjs/Manifest b/gnome-extra/cjs/Manifest
index d27306b3c201..1fc4f35e20ce 100644
--- a/gnome-extra/cjs/Manifest
+++ b/gnome-extra/cjs/Manifest
@@ -1,4 +1,6 @@
AUX cjs-6.2.0-glib-closure.patch 4161 BLAKE2B 5c13ab48391a9f60d54de6d80a9dc9c0844e8957c5b3de623d440ceae29591b6af0cdae6abc65b0bf19b584098b6a774d53bfae77a31326c5b5f524263c30def SHA512 1ae50a1fa32db0b093682ae57f179abf173799f67ce4bba6d681d4e170b02395d7fbe4dcea2ada2b91a8f20525a4994f0d040462614a608f72cf857880810b7f
DIST cjs-6.2.0.tar.gz 874457 BLAKE2B 7b1afda55bc0b5da165a20afa7be58382b8f03f1421bde960f6a3f134d7bdb2bdd44320b0b613f4f710258379da6666383a20d92556a1172971ca8340ae6d348 SHA512 5f7ce7f1ba648db834d7703e909ef65cf369d47147ca02e90b8844c31b4360dcc0fb94bbd3265632c3de8ef2b026934dd799b94a2ff3895442a2f9fc469f53db
+DIST cjs-6.4.0.tar.gz 874506 BLAKE2B 7cedfa8c9c3b53b417cbe6cebc335cb9ca056c6d98cb6c0abc03db5da678f275ff73b867b4c85289797c4701fe1f4dc10aa257eaa55b97824d9e4bebe61eadeb SHA512 525f19f7a5fba642b9d98ca29406d6663ca029d0f92d177bb10ffb68f03843085b86dfc623ef49ceada01dacb64e03742f16e9d7e2fb86a3cc67c25b6de4a616
EBUILD cjs-6.2.0.ebuild 2367 BLAKE2B 1443f14a3f093c25be89ce4fc1ba7b9a34d6c29adaad632cdc3da081fe4b046bc6a87764b9b10bffc4628ba7102282817d6e470e3be39093e7295f21321e3f3c SHA512 babd5e44c148313452ccf06f50b34bea6084747edfc21f20742b68dacd2a62c917d3594f62cd950a60e83f9a636b0b87975142c9ae829a7fdfeeb70caa433f0e
+EBUILD cjs-6.4.0.ebuild 2310 BLAKE2B b09b4b4820cdb836b9c250a0d0984e0c1662abb5e90c8e07ded5f5118e71b06cb3d51ce79ae90d75e1e0839d84dd428021e1bc816b6c914f208a6458264fb6fe SHA512 a2708073cb75af2d9e976e968536ef1465284a21e61f92abcff8d83f3ebb43303f4f09f36f1d2c5b95f822b01a1104e7dfd56f33ffdae5c42410b5d8b398bfc0
MISC metadata.xml 608 BLAKE2B 7cc55145357fc7b4b46e1a77f19570b60f5dc6207c81efc3b92adf7d5fdb025296d4e6b8b927f193ed7bd0a929274e61c9bdddad2371ca78a497b94fdbe87737 SHA512 672923005e936fd3d08367a8db65318f63217841e6f841623d469c21ce354724f6c2cea853ecca928280b21011d6aa0e133a7830841c9fa44dd8c36402b28066
diff --git a/gnome-extra/cjs/cjs-6.4.0.ebuild b/gnome-extra/cjs/cjs-6.4.0.ebuild
new file mode 100644
index 000000000000..05415690462e
--- /dev/null
+++ b/gnome-extra/cjs/cjs-6.4.0.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit flag-o-matic meson pax-utils python-any-r1 virtualx
+
+DESCRIPTION="Linux Mint's fork of gjs for Cinnamon"
+HOMEPAGE="https://projects.linuxmint.com/cinnamon/ https://github.com/linuxmint/cjs"
+SRC_URI="https://github.com/linuxmint/cjs/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD CC0-1.0 MIT MPL-2.0 || ( MPL-1.1 GPL-2+ LGPL-2.1+ )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="+cairo examples readline sysprof test"
+
+RDEPEND="
+ dev-lang/spidermonkey:115
+ >=dev-libs/glib-2.66.0:2
+ >=dev-libs/gobject-introspection-1.71.0:=
+ >=dev-libs/libffi-3.3:0=
+
+ cairo? (
+ x11-libs/cairo[glib,svg(+),X]
+ x11-libs/libX11
+ )
+ readline? ( sys-libs/readline:0= )
+"
+DEPEND="
+ ${RDEPEND}
+ sysprof? ( >=dev-util/sysprof-capture-3.40.1:4 )
+ test? (
+ sys-apps/dbus
+ x11-libs/gtk+:3[introspection]
+ )
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ python_fix_shebang build
+}
+
+src_configure() {
+ append-cppflags -DG_DISABLE_CAST_CHECKS
+
+ # On musl, it's required that either gjs, pixman or gnome-shell to be built
+ # with a larger stack otherwise librsvg fails to render a particular SVG, as
+ # a result we fail to get gdm or gnome-shell running (greeted with a fail
+ # whale screen). The bug has been reported to librsvg. This is ideally just
+ # a temporary workaround until we understand what exactly needs a larger
+ # stack size, as it's not sufficient to do just librsvg.
+ #
+ # Please refer to:
+ # https://gitlab.gnome.org/GNOME/librsvg/-/issues/686
+ # https://gitlab.gnome.org/GNOME/librsvg/-/issues/874
+ #
+ # TODO: Find an actual fix instead of increasing the stack
+ use elibc_musl && append-ldflags -Wl,-z,stack-size=2097152
+
+ local emesonargs=(
+ $(meson_feature cairo)
+ $(meson_feature readline)
+ $(meson_feature sysprof profiler)
+ -Dinstalled_tests=false
+ $(meson_use !test skip_dbus_tests)
+ $(meson_use !test skip_gtk_tests)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+src_install() {
+ meson_src_install
+
+ if use examples; then
+ docinto examples
+ dodoc "${S}"/examples/*
+ fi
+
+ # Required for cjs-console to run correctly on PaX systems
+ pax-mark mr "${ED}/usr/bin/cjs-console"
+}