summaryrefslogtreecommitdiff
path: root/gnome-extra/gnome-integration-spotify/gnome-integration-spotify-20140907-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /gnome-extra/gnome-integration-spotify/gnome-integration-spotify-20140907-r2.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'gnome-extra/gnome-integration-spotify/gnome-integration-spotify-20140907-r2.ebuild')
-rw-r--r--gnome-extra/gnome-integration-spotify/gnome-integration-spotify-20140907-r2.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/gnome-extra/gnome-integration-spotify/gnome-integration-spotify-20140907-r2.ebuild b/gnome-extra/gnome-integration-spotify/gnome-integration-spotify-20140907-r2.ebuild
new file mode 100644
index 000000000000..049a2479a33b
--- /dev/null
+++ b/gnome-extra/gnome-integration-spotify/gnome-integration-spotify-20140907-r2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_7 python3_8 )
+
+inherit gnome2-utils python-r1
+
+DESCRIPTION="GNOME integration for Spotify"
+HOMEPAGE="https://github.com/mrpdaemon/gnome-integration-spotify"
+#SRC_URI="https://github.com/mrpdaemon/${PN}/tarball/${PV} -> ${PN}-git-${PV}.tgz"
+SRC_URI="https://github.com/mrpdaemon/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+#S="${WORKDIR}/mrpdaemon-${PN}-df9124d"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ media-gfx/imagemagick
+ x11-misc/wmctrl
+ x11-misc/xautomation
+ x11-misc/xdotool
+ x11-apps/xwininfo"
+
+PATCHES=(
+ "${FILESDIR}/gnome-integration-spotify-command-line-parsing.patch"
+ "${FILESDIR}/gnome-integration-spotify-correct-interface.patch"
+ "${FILESDIR}/gnome-integration-spotify-use-glib.patch"
+)
+
+src_install() {
+ dobin spotify-dbus.py
+ python_replicate_script "${ED}"/usr/bin/spotify-dbus.py
+ mkdir -p "${D}/etc/gconf/schemas"
+ cp spotify.schemas "${D}/etc/gconf/schemas"
+}
+
+pkg_preinst() {
+ gnome2_gconf_savelist
+}
+
+pkg_postinst() {
+ gnome2_gconf_install
+}
+
+pkg_prerm() {
+ gnome2_gconf_uninstall
+}