summaryrefslogtreecommitdiff
path: root/gnome-extra/gnome-shell-extension-applications-overview-tooltip
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
commite9d044d4b9b71200a96adfa280848858c0f468c9 (patch)
tree1bd8ef816043a8cd340f1d774e79553a1a7d31d8 /gnome-extra/gnome-shell-extension-applications-overview-tooltip
parentfc2f1018fc323ef2c6572734a9b130427cba76a6 (diff)
gentoo resync : 13.11.2021
Diffstat (limited to 'gnome-extra/gnome-shell-extension-applications-overview-tooltip')
-rw-r--r--gnome-extra/gnome-shell-extension-applications-overview-tooltip/Manifest2
-rw-r--r--gnome-extra/gnome-shell-extension-applications-overview-tooltip/gnome-shell-extension-applications-overview-tooltip-14.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extension-applications-overview-tooltip/Manifest b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/Manifest
index 94a4d5921bd4..2c6ea55c8c1f 100644
--- a/gnome-extra/gnome-shell-extension-applications-overview-tooltip/Manifest
+++ b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/Manifest
@@ -1,3 +1,5 @@
DIST gnome-shell-extension-applications-overview-tooltip-12.tar.gz 27394 BLAKE2B 169460c7063fda0f664688303984c4a5c7fcd8a6b32281c2eb630ebea8143b95e96038f130b09c939371474b5ef27656cf77eec942412fcf3908a5d9fb8ae202 SHA512 4c993256d1f6d7d3a2c72c88f6f88facf7ff8237d489950484f54a68f09741e526f0e0a7c2862251fc2579fd3cdd496c9136bb222374abfacbace1615e263239
+DIST gnome-shell-extension-applications-overview-tooltip-14.tar.gz 27058 BLAKE2B 442e1b144358c40c6132ab2a067bb29439e826ccd540583a6e95d35841bca3eda53ac9b6004285c8ab63006d9e71dbdb46f0fb77310366cf976381bb70b50223 SHA512 6e5805f720e262181e4519ec8a19cf57dae41e3dcff3da4a4a1bc4a132bcc23aae575cc15aa0a0f5f04fe1a25a9ff3e03d5bcacb326c7bbc8d0b28351e0ecbfe
EBUILD gnome-shell-extension-applications-overview-tooltip-12.ebuild 1226 BLAKE2B 2dc6ac1e429c81175dd32a188b2d4c6a8406f0c99c214c7b1e659e741b35cf66ac9e3200015ac39083c9bafe3d94ebcfbb00b09d1b2ec51ba615047ff3979695 SHA512 22d7d2de2eeea0dbb0135c2970fd37d5730408b197b39912543b1ab079c1eb0bcdee5a0eb132a46433e030953e07392d47d2506c962e97b8b505b56e4d03fb74
+EBUILD gnome-shell-extension-applications-overview-tooltip-14.ebuild 1150 BLAKE2B cac3c948ad67fbec39640d3b2e90a7092297296227a7b720318b796e43fd010d88356292f325c2d309a425b40c2fbf521f857231b2dd0d08e37a2ddf5752ad6b SHA512 a125f5316f23863c538ab75b44c7694ddd139c8ed67e04b5f11fe94d7b37b45acf59c9732bb250df54948110c1208fdcfb28d7671b60f5461c561f02acc388e3
MISC metadata.xml 241 BLAKE2B cb0374238d11e2a3f28f23b7049da09babd4310a99862738acfb7ba554f7758ac68cd09d1eb7a29068195c27010a846a540ed2c09b88fd043b37fb4f0762150f SHA512 b2c1d3e2cb6760ed4682da82af5370adcacd48afd558efa1abf84d955067b2ad32eda034af8cef95c71409622f97fa0113f2e07bee328f2d03512908ae931050
diff --git a/gnome-extra/gnome-shell-extension-applications-overview-tooltip/gnome-shell-extension-applications-overview-tooltip-14.ebuild b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/gnome-shell-extension-applications-overview-tooltip-14.ebuild
new file mode 100644
index 000000000000..e2390562055f
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/gnome-shell-extension-applications-overview-tooltip-14.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome2-utils
+
+DESCRIPTION="Show tooltip with full name and description"
+HOMEPAGE="https://github.com/RaphaelRochet/applications-overview-tooltip"
+SRC_URI="https://github.com/RaphaelRochet/applications-overview-tooltip/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+# https://github.com/RaphaelRochet/applications-overview-tooltip/issues/7
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ app-eselect/eselect-gnome-shell-extensions
+ >=gnome-base/gnome-shell-40
+"
+DEPEND=""
+BDEPEND=""
+
+S="${WORKDIR}/${P/gnome-shell-extension-}"
+extension_uuid="applications-overview-tooltip@RaphaelRochet"
+
+src_install() {
+ einstalldocs
+ insinto /usr/share/glib-2.0/schemas
+ doins schemas/*.xml
+ rm -rf README.md schemas || die
+ insinto /usr/share/gnome-shell/extensions/"${extension_uuid}"
+ doins -r *
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}