summaryrefslogtreecommitdiff
path: root/gnome-extra/gnome-shell-extensions-topicons-plus
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /gnome-extra/gnome-shell-extensions-topicons-plus
reinit the tree, so we can have metadata
Diffstat (limited to 'gnome-extra/gnome-shell-extensions-topicons-plus')
-rw-r--r--gnome-extra/gnome-shell-extensions-topicons-plus/Manifest5
-rw-r--r--gnome-extra/gnome-shell-extensions-topicons-plus/gnome-shell-extensions-topicons-plus-20.ebuild42
-rw-r--r--gnome-extra/gnome-shell-extensions-topicons-plus/gnome-shell-extensions-topicons-plus-21.ebuild44
-rw-r--r--gnome-extra/gnome-shell-extensions-topicons-plus/metadata.xml11
4 files changed, 102 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extensions-topicons-plus/Manifest b/gnome-extra/gnome-shell-extensions-topicons-plus/Manifest
new file mode 100644
index 000000000000..d86e3ff23830
--- /dev/null
+++ b/gnome-extra/gnome-shell-extensions-topicons-plus/Manifest
@@ -0,0 +1,5 @@
+DIST gnome-shell-extensions-topicons-plus-20.tar.gz 6173720 SHA256 02ffe087b390b277ce3245b3db675977dad0ed5b6503d719e6e868d8a3082825 SHA512 89feaf4a42f1785c7667ba451efddce2322599c5441bfe66c8bcc72fa3c07bbc2535e34db5383ab9c5b38a61f83ec6ef245473f2c269708e4042684f2d7a07bc WHIRLPOOL 0ccba7837700964e730ab07c8fdac5795b08aab884fa0feab56789e0a5b8166ed864836a383baa01be86c49969a409c4d3b92f2a6653eaeb0387114352e245ca
+DIST gnome-shell-extensions-topicons-plus-21.tar.gz 2756641 SHA256 92c0865dff0bba89b64fa8a7808a29294bf6904430336c7cb13f51b823f74a13 SHA512 f85db46f20c24f0b11ce2c79c0548b88262faf059d674073e328917dc8497de0e07ccd6f3613f45aa9e49109468d78293f3a8f0f4fea5a24a7c5254666cda5df WHIRLPOOL 56c9933775ba9d10ee6bb383cf60ca76430ee97a6b22f238ef4b64892aecb61a8e523cd3e65ac6857a7e5d32c54d28bfcb4f8da1a6eca1df23e65afe8233ef6f
+EBUILD gnome-shell-extensions-topicons-plus-20.ebuild 1165 SHA256 12ba8f5a6afca26273a14db4437048c5dba94affdb03b6a8ed6fc5feb84631ac SHA512 075f4a6f42c2fa12c4e24baa6465c157e137bfb1fa19e89b1525cdd0ac61b1dbf49fced35f241cc023f2fd5d60e0c22610ce0f07fb8d13eb958e4a71e149c15d WHIRLPOOL 1fedc7eddc37f6318b41e76479395927dfa8cc4d070f9f0be136418464379788c21490ff81140592c20511f20b9d0118ddd70003bbf58d21e86bd336bb92d90b
+EBUILD gnome-shell-extensions-topicons-plus-21.ebuild 1329 SHA256 216e300b843339168ad1a9150446f3903995264e7ad01b4f82dba98af978af47 SHA512 dba500a6685f3896218e3ecaf7f3fe374db2cc39264fe4f6ad5ea220a1f9064ecb263771ff3c529af6827d18eadbbf8aa4c6afe5a9cf0346d29288c32670bf78 WHIRLPOOL 63c42dc4d8515b3142ecfab97187d5083a0597627b9cc94c56cc75cc97b9d471f6386da613293adea7566f8e61d3b482361b653567ae6ebe9b0869e0213f624e
+MISC metadata.xml 339 SHA256 373926033d85917882bddce65c6c6e2482dc7693ac1b0d88b64b63b4d979dfae SHA512 6bd54fe410561f215eba59872c742b9a11016cede62ddaf0aa8f899bf2c2abffde29cb63c9b819486a750be66b3dadd72257f6e26dcd87798aece31e0a752b40 WHIRLPOOL 960bba128f68bdc1c834a59f4a4f45017b83e8a60611ef0974b134332e31667179010dbc6d917e5b42d28f70328f95bcb213d4f2b379fe75c30214c308d1f1a3
diff --git a/gnome-extra/gnome-shell-extensions-topicons-plus/gnome-shell-extensions-topicons-plus-20.ebuild b/gnome-extra/gnome-shell-extensions-topicons-plus/gnome-shell-extensions-topicons-plus-20.ebuild
new file mode 100644
index 000000000000..ce20730a5df2
--- /dev/null
+++ b/gnome-extra/gnome-shell-extensions-topicons-plus/gnome-shell-extensions-topicons-plus-20.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit vcs-snapshot
+
+DESCRIPTION="Moves legacy tray icons to top panel"
+HOMEPAGE="https://extensions.gnome.org/extension/1031/topicons/"
+SRC_URI="https://github.com/phocean/TopIcons-plus/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+# glib for glib-compile-schemas at build time, needed at runtime anyways
+COMMON_DEPEND="
+ dev-libs/glib:2
+"
+RDEPEND="${COMMON_DEPEND}
+ app-eselect/eselect-gnome-shell-extensions
+ >=gnome-base/gnome-shell-3.16
+"
+DEPEND="${COMMON_DEPEND}"
+
+#src_compile() {
+ # It redoes this with "make install" later due to a dumb Makefile, so don't bother
+ #make build
+#}
+
+src_install() {
+ # TODO: Figure out if we can get the schemas to standard location, in a way that works properly runtime too
+ make install INSTALL_PATH="${ED}usr/share/gnome-shell/extensions/"
+ rm "${ED}/usr/share/gnome-shell/extensions/TopIcons@phocean.net/README.md" || die
+ dodoc README.md
+}
+
+pkg_postinst() {
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}
diff --git a/gnome-extra/gnome-shell-extensions-topicons-plus/gnome-shell-extensions-topicons-plus-21.ebuild b/gnome-extra/gnome-shell-extensions-topicons-plus/gnome-shell-extensions-topicons-plus-21.ebuild
new file mode 100644
index 000000000000..7639cc3ca8ae
--- /dev/null
+++ b/gnome-extra/gnome-shell-extensions-topicons-plus/gnome-shell-extensions-topicons-plus-21.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit vcs-snapshot
+
+DESCRIPTION="Moves legacy tray icons to top panel"
+HOMEPAGE="https://extensions.gnome.org/extension/1031/topicons/"
+SRC_URI="https://github.com/phocean/TopIcons-plus/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# glib for glib-compile-schemas at build time, needed at runtime anyways
+COMMON_DEPEND="
+ dev-libs/glib:2
+"
+RDEPEND="${COMMON_DEPEND}
+ app-eselect/eselect-gnome-shell-extensions
+ >=gnome-base/gnome-shell-3.16
+"
+DEPEND="${COMMON_DEPEND}"
+
+#src_compile() {
+ # It redoes this with "make install" later due to a dumb Makefile, so don't bother
+ #make build
+#}
+
+src_install() {
+ # TODO: Figure out if we can get the schemas to standard location, in a way that works properly runtime too
+ make install INSTALL_PATH="${ED}usr/share/gnome-shell/extensions/"
+ rm "${ED}/usr/share/gnome-shell/extensions/TopIcons@phocean.net/README.md" || die
+ # Assuming it needs only compiled gettext catalogs at runtime
+ rm "${ED}/usr/share/gnome-shell/extensions/TopIcons@phocean.net/locale"/*/LC_MESSAGES/*.po || die
+ dodoc README.md
+}
+
+pkg_postinst() {
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}
diff --git a/gnome-extra/gnome-shell-extensions-topicons-plus/metadata.xml b/gnome-extra/gnome-shell-extensions-topicons-plus/metadata.xml
new file mode 100644
index 000000000000..725b4746cbef
--- /dev/null
+++ b/gnome-extra/gnome-shell-extensions-topicons-plus/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">phocean/TopIcons-plus</remote-id>
+ </upstream>
+</pkgmetadata>