summaryrefslogtreecommitdiff
path: root/gnome-extra/gnome-user-docs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-08 04:18:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-08 04:18:34 +0100
commitd84be18029b166ee26fe5416098974a8d05b2983 (patch)
tree0fbc3087c3911f2ac23f738e4f43fcc77cc40386 /gnome-extra/gnome-user-docs
parent4242446a1af7d38662da76b31d2e6254d64706ec (diff)
gentoo auto-resync : 08:07:2023 - 04:18:34
Diffstat (limited to 'gnome-extra/gnome-user-docs')
-rw-r--r--gnome-extra/gnome-user-docs/Manifest2
-rw-r--r--gnome-extra/gnome-user-docs/gnome-user-docs-44.3.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/gnome-extra/gnome-user-docs/Manifest b/gnome-extra/gnome-user-docs/Manifest
index 9162c9d70a1b..26f4026b8b75 100644
--- a/gnome-extra/gnome-user-docs/Manifest
+++ b/gnome-extra/gnome-user-docs/Manifest
@@ -1,3 +1,5 @@
DIST gnome-user-docs-44.1.tar.xz 13297308 BLAKE2B 4e6c15d7511157c677d578804c883b7af3e8961cb9edfc192a51ef5d79020f638759c54d1f4ea26799bd59a8c008cf88e5432e1393ceaa82dfd4e9aab45b8d43 SHA512 9f1351232d09249ec21c9574e4d691e77eabf3840eb41242afeb44243049ffdc3ee3a064ef36962eb5418c4445c23be27675fdd2c1d71c758a3564419a1fd950
+DIST gnome-user-docs-44.3.tar.xz 13364796 BLAKE2B 2a8d23154d08c18a699691451f5c37fd6729a6da8ed53b40478f929260fac2c77c01388edbb12edef7e142a322acb163466166aceaa35594143b214e87dabb4c SHA512 c61967958e3d0447d69cc89381896697489e144c3bc3090e1d62cc385a6a7d94501172a11536ba591912a1f8c37c2ef5f8cb299b105f3ac2eabd637fdaa38fdd
EBUILD gnome-user-docs-44.1.ebuild 942 BLAKE2B 369ec49cfa9d7bcbee882a6b01590c4308b8c249bf2ee8ced65e158a9836318e6ad0eb5936b8bc8fa16f75babf4c5c0623dbb10fb334e433264dd55f617f597a SHA512 4d1328f0524b65af50c5ba2f6b77be35ab886f0c22ee89f9b2c13c8e2ef3359728420cc37588c804fdcca1ec38dafa1c7d3a71c062d8abff7566c0cf4db17ae7
+EBUILD gnome-user-docs-44.3.ebuild 945 BLAKE2B 93a07cb74f5bff49d619d2480fdc9f7cfe1f37476e8549c1267372b6e8ca4e400652652745cbf22d7b8ab406fc4e90cc68c630de3142a3e12cb595c2132a48cf SHA512 a8ee1a963a1d50efe8221bf64506e39dda70859a464e20a86a75e9a08e64d36c8916132a8d07beb8c839de6ca48c301b5fddb0941a419a08ec76c463c4751184
MISC metadata.xml 356 BLAKE2B 72f06c2a1caa00e95e7af168e9f600c480b016bbfc964f4d1f6403ef0061e59766adadda0f259923817104dcd0fcd23a3ec6f34212598c195b8bcd16f22e3889 SHA512 2370c1e00eede00c31ebcdde981e76f9aa265c48da0333555f2412a90b23747068972e983511fdd4f328e38cc369f0bbc76bd967bdf115f2084fb22666bbbc67
diff --git a/gnome-extra/gnome-user-docs/gnome-user-docs-44.3.ebuild b/gnome-extra/gnome-user-docs/gnome-user-docs-44.3.ebuild
new file mode 100644
index 000000000000..f5c2e5bd8bf7
--- /dev/null
+++ b/gnome-extra/gnome-user-docs/gnome-user-docs-44.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome2
+
+DESCRIPTION="GNOME end user documentation"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-user-docs"
+
+LICENSE="CC-BY-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="test"
+
+BDEPEND="test? ( dev-libs/libxml2 )"
+# eautoreconf requires:
+# app-text/yelp-tools
+# rebuilding translations requires:
+# app-text/yelp-tools
+# dev-util/gettext
+
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip
+ !test? ( test )"
+
+src_configure() {
+ # itstool is only needed for rebuilding translations
+ # xmllint is only needed for tests
+ gnome2_src_configure \
+ $(usex test "" XMLLINT=$(type -P true)) \
+ ITSTOOL=$(type -P true)
+}
+
+src_compile() {
+ # Do not compile; "make all" with unset LINGUAS rebuilds all translations,
+ # which can take > 2 hours on a Core i7.
+ return
+}