summaryrefslogtreecommitdiff
path: root/gnome-extra/gnome-weather/gnome-weather-3.26.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
commit62f67115b5c46134c34f88f4b1cbdacc19384c0a (patch)
tree0a76b14de203a4c23040e5665e39df8de9867745 /gnome-extra/gnome-weather/gnome-weather-3.26.0.ebuild
parent265dbe5dbc14c199299496c6db8fce3f76647015 (diff)
gentoo resync : 30.09.2018
Diffstat (limited to 'gnome-extra/gnome-weather/gnome-weather-3.26.0.ebuild')
-rw-r--r--gnome-extra/gnome-weather/gnome-weather-3.26.0.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/gnome-extra/gnome-weather/gnome-weather-3.26.0.ebuild b/gnome-extra/gnome-weather/gnome-weather-3.26.0.ebuild
new file mode 100644
index 000000000000..bc55ef114850
--- /dev/null
+++ b/gnome-extra/gnome-weather/gnome-weather-3.26.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit gnome2 python-any-r1 virtualx
+
+DESCRIPTION="A weather application for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Design/Apps/Weather"
+
+LICENSE="GPL-2+ LGPL-2+ MIT CC-BY-3.0 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=app-misc/geoclue-2.3.1:2.0
+ >=dev-libs/gjs-1.50
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/gobject-introspection-1.35.9:=
+ >=dev-libs/libgweather-3.25.91:=
+ gnome-base/gsettings-desktop-schemas
+ >=x11-libs/gtk+-3.11.4:3
+"
+# libxml2 required for glib-compile-resources
+DEPEND="${RDEPEND}
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ >=dev-util/intltool-0.26
+ virtual/pkgconfig
+ test? (
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep 'dev-util/dogtail[${PYTHON_USEDEP}]') )
+"
+
+python_check_deps() {
+ use test && has_version "dev-util/dogtail[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ gnome2_src_configure $(use_enable test dogtail)
+}
+
+src_test() {
+ virtx emake check TESTS_ENVIRONMENT="dbus-run-session"
+}