summaryrefslogtreecommitdiff
path: root/gnome-extra/gucharmap/gucharmap-12.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /gnome-extra/gucharmap/gucharmap-12.0.1.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'gnome-extra/gucharmap/gucharmap-12.0.1.ebuild')
-rw-r--r--gnome-extra/gucharmap/gucharmap-12.0.1.ebuild67
1 files changed, 0 insertions, 67 deletions
diff --git a/gnome-extra/gucharmap/gucharmap-12.0.1.ebuild b/gnome-extra/gucharmap/gucharmap-12.0.1.ebuild
deleted file mode 100644
index 17ae326da87b..000000000000
--- a/gnome-extra/gucharmap/gucharmap-12.0.1.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-VALA_USE_DEPEND="vapigen"
-
-inherit eapi7-ver gnome2 vala
-
-DESCRIPTION="Unicode character map viewer and library"
-HOMEPAGE="https://wiki.gnome.org/Apps/Gucharmap"
-
-LICENSE="GPL-3+"
-SLOT="2.90"
-KEYWORDS="~alpha amd64 arm arm64 ~ia64 ppc ppc64 sparc x86"
-
-IUSE="debug +introspection test vala"
-RESTRICT="!test? ( test )"
-REQUIRED_USE="vala? ( introspection )"
-
-UNICODE_VERSION=$(ver_cut 1-2)
-
-COMMON_DEPEND="
- =app-i18n/unicode-data-${UNICODE_VERSION}*
- >=dev-libs/glib-2.32:2
- >=x11-libs/pango-1.2.1[introspection?]
- >=x11-libs/gtk+-3.16:3[introspection?]
- media-libs/freetype:2
- introspection? ( >=dev-libs/gobject-introspection-0.9.0:= )
-"
-RDEPEND="${COMMON_DEPEND}
- !<gnome-extra/gucharmap-3:0
-"
-DEPEND="${RDEPEND}
- dev-util/desktop-file-utils
- dev-util/glib-utils
- >=dev-util/gtk-doc-am-1
- >=dev-util/intltool-0.40
- dev-util/itstool
- sys-devel/gettext
- virtual/pkgconfig
- test? ( app-text/docbook-xml-dtd:4.1.2 )
- vala? ( $(vala_depend) )
-"
-
-src_prepare() {
- # prevent file collisions with slot 0
- sed -e "s:GETTEXT_PACKAGE=gucharmap$:GETTEXT_PACKAGE=gucharmap-${SLOT}:" \
- -i configure.ac configure || die "sed configure.ac configure failed"
-
- # avoid autoreconf
- sed -e 's/-Wall //g' -i configure || die "sed failed"
-
- use vala && vala_src_prepare
- gnome2_src_prepare
-}
-
-src_configure() {
- # unihan is not really conditional
- # https://bugzilla.gnome.org/show_bug.cgi?id=768210#c5
- # https://gitlab.gnome.org/GNOME/gucharmap/issues/13
- gnome2_src_configure \
- --disable-static \
- --with-unicode-data=/usr/share/unicode-data \
- $(usex debug --enable-debug=yes ' ') \
- $(use_enable introspection) \
- $(use_enable vala)
-}