summaryrefslogtreecommitdiff
path: root/gnome-extra
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-30 21:21:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-30 21:21:38 +0100
commit2f210c93c08515a806199783aabe37d12a0197cb (patch)
tree8b846898d136de0503e4ec3c2cf1f90660ee3336 /gnome-extra
parent1c19f0d8d940b35f723e28d8a6ebe388cfacd1d8 (diff)
gentoo auto-resync : 30:05:2023 - 21:21:38
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/Manifest.gzbin11240 -> 11240 bytes
-rw-r--r--gnome-extra/gnome-boxes/Manifest2
-rw-r--r--gnome-extra/gnome-boxes/gnome-boxes-44.2.ebuild120
-rw-r--r--gnome-extra/sushi/Manifest2
-rw-r--r--gnome-extra/sushi/sushi-44.2.ebuild56
5 files changed, 180 insertions, 0 deletions
diff --git a/gnome-extra/Manifest.gz b/gnome-extra/Manifest.gz
index 402c7611718d..b01d8d1d7cbb 100644
--- a/gnome-extra/Manifest.gz
+++ b/gnome-extra/Manifest.gz
Binary files differ
diff --git a/gnome-extra/gnome-boxes/Manifest b/gnome-extra/gnome-boxes/Manifest
index 6ffd223b4866..4c4b45b794f8 100644
--- a/gnome-extra/gnome-boxes/Manifest
+++ b/gnome-extra/gnome-boxes/Manifest
@@ -1,3 +1,5 @@
DIST gnome-boxes-44.1.tar.xz 1239656 BLAKE2B 86a414982b95840f198dc5adc0bbead117405339a8ab997248768583d6abc5cba635540ec24029e0fc5771926728f6696aa117eb79a9c6dca7dfbfc60dff654c SHA512 75464f0ce6ff72c9da4cf4966f566674f0e16b4c7a51ae472761e4bd9c8fc654b4833f9f8bdc4c3e3581d00e3548ed3d731c4d8d8a05e610126f350136d8f31f
+DIST gnome-boxes-44.2.tar.xz 1239344 BLAKE2B 69b2c387f3482f41450df89ed742d754c68f119c02b4aa7401b019a28e21494d07b6402fe2ae2e5fb59f4c292e7246ef8a5eb240bb586359368c3dbab93b83ca SHA512 08e40cd45a4bdc3ba82bfd0a5f4065e56685c43343d6e745f51a5a8043b402a1eb6b6396193600d89d30b2791cb4e8718194ca1b83b7be954b83b5d939eed948
EBUILD gnome-boxes-44.1.ebuild 3446 BLAKE2B af146f8f12b3ed9967f21f9e3e126cf5bf1703511c32e2305790fa752c8eb7b56e8a068bb095482d92f62d28280dcde827000c45d6b9ed8bc3cfc503ee652007 SHA512 c492e8d00b5b1d40c10dc67ac95019ae1c80d5f7bafe195e901cec0c9b372d3664450b954bdc9bd02f65d1eade8b13591116f40e7e46e73ae7227595a6f81557
+EBUILD gnome-boxes-44.2.ebuild 3467 BLAKE2B bd5fb7805750f4b9dea15530b23f6ad02c711b32ae8a3fb025e27c389680af18c9e9bf3bfcd963c2b300fb24b91e86e6d10b269cbb955471f08685ea3488d6e6 SHA512 51cc358f1929279c8a35b44909edfd26b710633ffd6af3d7a45a6c28728b2ba5e88e1ff63dad3616df34b3df4f874d7424f2e98a13de113a951db581eb97cf2a
MISC metadata.xml 352 BLAKE2B 285b6e588965df3d070f92552b36941c6346a9fde3dce831baa82d42c8ca23f62cc027e5984a27fc87bffca8181c2d13a52b064729349daef0aa815a566a885e SHA512 09baca6576a90ca57b6e0935879f1630550efc9d591b425d6944b28b1184612b34fcdbae6d835d98812c89ec7a47415af9a01678be16f35a52933bb7c374131f
diff --git a/gnome-extra/gnome-boxes/gnome-boxes-44.2.ebuild b/gnome-extra/gnome-boxes/gnome-boxes-44.2.ebuild
new file mode 100644
index 000000000000..49f09ffa0d85
--- /dev/null
+++ b/gnome-extra/gnome-boxes/gnome-boxes-44.2.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils linux-info meson readme.gentoo-r1 vala xdg
+
+DESCRIPTION="Simple GNOME application to access remote or virtual systems"
+HOMEPAGE="https://wiki.gnome.org/Apps/Boxes"
+
+LICENSE="LGPL-2+ CC-BY-2.0"
+SLOT="0"
+
+KEYWORDS="~amd64"
+
+# FIXME: qemu probably needs to depend on spice[smartcard] directly with USE=spice
+# FIXME: Check over libvirt USE=libvirtd,qemu and the smartcard/usbredir requirements
+# Technically vala itself still ships a libsoup vapi, but that may change, and
+# it should be better to use the .vapi from the same libsoup version
+DEPEND="
+ >=app-arch/libarchive-3.0.0:=
+ >=dev-libs/glib-2.52:2
+ >=x11-libs/gtk+-3.24.1:3
+ >=gui-libs/libhandy-1.5.0:1
+ >=sys-libs/libosinfo-1.10.0-r1
+ net-libs/libsoup:3.0
+ virtual/libusb:1
+ >=app-emulation/libvirt-glib-4.0.0
+ >=dev-libs/libxml2-2.7.8:2
+ >=net-misc/spice-gtk-0.32[gtk3(+),smartcard,usbredir]
+ >=net-libs/webkit-gtk-2.38.0:4.1
+
+ >=dev-libs/gobject-introspection-1.56:=
+ >=dev-libs/libgudev-165:=
+" # gobject-introspection needed for libovf subproject
+# These are called via exec():
+# - sys-fs/mtools mcopy for unattended file copying for files that libarchive doesn't support
+# - app-cdr/cdrtools mkisofs is needed for unattended installer secondary disk image creation
+# - app-emulation/libguestfs virt-sysprep is used for VM cloing, if not there, it logs debug and doesn't function
+# - sys-apps/policycoreutils restorecon is used for checking selinux context
+# - app-emulation/libvirt virsh used for various checks (and we need the library anyways)
+# - sys-auth/polkit used for making all libvirt system disks readable via "pkexec
+# chmod a+r" that aren't already readable to the user (libvirt system importer)
+# - app-emulation/qemu qemu-img used to convert image to QCOW2 format during copy
+RDEPEND="${DEPEND}
+ app-cdr/cdrtools
+ app-misc/tracker-miners:3[iso]
+ app-emulation/spice[smartcard]
+ >=app-emulation/libvirt-0.9.3[libvirtd,qemu]
+ >=app-emulation/qemu-1.3.1[spice,smartcard,usbredir]
+ sys-fs/mtools
+ sys-auth/polkit
+"
+# This is only needed for creating the .vapi file, but gnome-boxes needs it
+BDEPEND="
+ $(vala_depend)
+ sys-libs/libosinfo[vala]
+ app-crypt/libsecret[vala]
+ net-libs/libsoup:3.0[vala]
+ app-emulation/libvirt-glib[vala]
+ net-misc/spice-gtk[vala]
+ x11-libs/vte:2.91[vala]
+ dev-libs/appstream-glib
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="Before running gnome-boxes for local VMs, you will need to load the KVM modules.
+If you have an Intel Processor, run:
+# modprobe kvm-intel
+
+If you have an AMD Processor, run:
+# modprobe kvm-amd"
+
+pkg_pretend() {
+ linux-info_get_any_version
+
+ if linux_config_exists; then
+ if ! { linux_chkconfig_present KVM_AMD || \
+ linux_chkconfig_present KVM_INTEL; }; then
+ ewarn "You need KVM support in your kernel to use GNOME Boxes local VM support!"
+ fi
+ fi
+}
+
+src_prepare() {
+ default
+ vala_setup
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ -Ddistributor_name=Gentoo
+ -Ddistributor_version=${PVR}
+ -Dinstalled_tests=false
+ -Dflatpak=false
+ -Dprofile=default
+ -Duefi=true
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
diff --git a/gnome-extra/sushi/Manifest b/gnome-extra/sushi/Manifest
index 1eb9841703e5..3197a82ae8db 100644
--- a/gnome-extra/sushi/Manifest
+++ b/gnome-extra/sushi/Manifest
@@ -1,3 +1,5 @@
DIST sushi-43.0.tar.xz 81552 BLAKE2B 13ca7ec446aeaae454bb0a8c874a786914211a9b27d423189846aba9adb844b224a7f0cb6d95b2e6c4d71043a2b592d14ce9998a9732150517aa18b14b4f2c25 SHA512 0a909f685e49bbddb7fc2cf17338eba08723a796e1e42f09ed404487620437b36c2bdaede3efbb6bd49cd7efde0141e971ac9869f73c0c30bea9b6658978b19e
+DIST sushi-44.2.tar.xz 82236 BLAKE2B 144b2a068c0ed81e49236ed2f43125ec9df8eb853dac6d49e55c56d489f6dd41e1704b3e22996bd80bcbda07f0843a831bdbd8296606a9688376bf7fc6140406 SHA512 0e2cd6e619872e7ebd29b01bf6038b3db7f8202f20a77034451e69b722e46ee9f8e20378253f49ccb12b6060490c25555581f10823c778c42ab9edf41016a1da
EBUILD sushi-43.0.ebuild 1407 BLAKE2B 5d1f5993601f58de0db0b133cc79d1c37973cf2407b299a949727a7b7fc3741a3c02cf6c5d9e5b63de52f114f651252d76f5936b8474ce60fd0c7dfcc165e334 SHA512 02d967851c6a22fff9d13d4f0bb63ed84892da954b814ca292dc85b3ba3e815e348ff0cc2f637af5fcfe50f6fc9da4fd24e2f897d931ce9d3f1e3f9d1bb0502c
+EBUILD sushi-44.2.ebuild 1410 BLAKE2B 453f4e55f00c85f44fd9d116cf7e8f272151c3047ccb8333a9cf767294a1f7fe1b138661ce891f9fa73a25d75a697aa229ef479134a2c3de8acb9d38afdd9123 SHA512 61e0b23941861eb019f818602f2ce59c1a06ab3a0a00a85949bf693095737bc57264a9bbdc2a3ceadcada0b6ff2b24eb1ae224bbb182ee720b8825c8e0b46c98
MISC metadata.xml 346 BLAKE2B 6c6e45a4f1642d9a57f42d8ad9578ecf50e678289ea8323b0e77a374b4482fc00425e2e3e1c3238f5d6cb60d393cfa472b4b865a74bf0d048feab7e7c5bc85f0 SHA512 886866cd0386728871c2200495893c7844cbd46c2507c64a2d796888292f2a348724510b843617164ac616b9d0d793ad4e9f0ff1e66066209c12e12e50e031a5
diff --git a/gnome-extra/sushi/sushi-44.2.ebuild b/gnome-extra/sushi/sushi-44.2.ebuild
new file mode 100644
index 000000000000..1727de732e1c
--- /dev/null
+++ b/gnome-extra/sushi/sushi-44.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome.org meson optfeature xdg
+
+DESCRIPTION="A quick previewer for Nautilus, the GNOME file manager"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/sushi"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~sparc ~x86"
+IUSE="wayland +X"
+REQUIRED_USE="|| ( wayland X )"
+
+DEPEND="
+ media-libs/libepoxy
+ >=app-text/evince-3.0[introspection]
+ media-libs/freetype:2
+ >=x11-libs/gdk-pixbuf-2.23.0[introspection]
+ >=dev-libs/glib-2.29.14:2
+ media-libs/gstreamer:1.0[introspection]
+ media-libs/gst-plugins-base:1.0[introspection]
+ >=x11-libs/gtk+-3.13.2:3[introspection,wayland?,X?]
+ >=x11-libs/gtksourceview-4.0.3:4[introspection]
+ >=media-libs/harfbuzz-0.9.9:=
+ >=dev-libs/gobject-introspection-1.54:=
+ net-libs/webkit-gtk:4.1[introspection]
+ >=dev-libs/gjs-1.40
+"
+RDEPEND="${DEPEND}
+ >=gnome-base/nautilus-3.1.90
+ media-plugins/gst-plugins-gtk:1.0[wayland?,X?]
+"
+BDEPEND="
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature wayland)
+ $(meson_feature X X11)
+ )
+ meson_src_configure
+}
+
+src_compile() {
+ local -x GST_PLUGIN_SYSTEM_PATH_1_0=
+ meson_src_compile
+}
+
+pkg_postinst() {
+ optfeature "Support viewing file formats such as generated by LibreOffice" app-office/libreoffice app-office/libreoffice-bin
+}