summaryrefslogtreecommitdiff
path: root/gnustep-apps/simpleagenda/simpleagenda-0.44.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /gnustep-apps/simpleagenda/simpleagenda-0.44.ebuild
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'gnustep-apps/simpleagenda/simpleagenda-0.44.ebuild')
-rw-r--r--gnustep-apps/simpleagenda/simpleagenda-0.44.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnustep-apps/simpleagenda/simpleagenda-0.44.ebuild b/gnustep-apps/simpleagenda/simpleagenda-0.44.ebuild
new file mode 100644
index 000000000000..2b1fd484cd39
--- /dev/null
+++ b/gnustep-apps/simpleagenda/simpleagenda-0.44.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnustep-2
+
+DESCRIPTION="a simple calendar and agenda application"
+HOMEPAGE="https://github.com/poroussel/simpleagenda"
+SRC_URI="https://github.com/poroussel/simpleagenda/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="dbus"
+
+DEPEND=">=dev-libs/libical-0.27
+ >=virtual/gnustep-back-0.20.0
+ dbus? ( gnustep-libs/dbuskit )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ egnustep_env
+ econf $(use_enable dbus dbuskit)
+}