summaryrefslogtreecommitdiff
path: root/gnustep-base/libobjc2/libobjc2-2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /gnustep-base/libobjc2/libobjc2-2.1.ebuild
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'gnustep-base/libobjc2/libobjc2-2.1.ebuild')
-rw-r--r--gnustep-base/libobjc2/libobjc2-2.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnustep-base/libobjc2/libobjc2-2.1.ebuild b/gnustep-base/libobjc2/libobjc2-2.1.ebuild
new file mode 100644
index 000000000000..98b36a4a4fa1
--- /dev/null
+++ b/gnustep-base/libobjc2/libobjc2-2.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit cmake
+
+DESCRIPTION="GNUstep Objective-C runtime"
+HOMEPAGE="http://www.gnustep.org"
+SRC_URI="https://github.com/gnustep/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/Tessil/robin-map/archive/757de82.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="boehm-gc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="boehm-gc? ( dev-libs/boehm-gc )"
+BDEPEND="${RDEPEND}
+ sys-devel/clang"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-eh_trampoline.patch
+ "${FILESDIR}"/${P}-pthread_link.patch
+)
+
+src_prepare() {
+ cmake_src_prepare
+ cp -a "${WORKDIR}"/robin-map-757de829927489bee55ab02147484850c687b620/* \
+ "${S}"/third_party/robin-map || die
+}
+
+src_configure() {
+ export CC="clang"
+ export CXX="clang++"
+ local mycmakeargs=(
+ -DGNUSTEP_CONFIG=GNUSTEP_CONFIG-NOTFOUND
+ -DBOEHM_GC="$(usex boehm-gc)"
+ -DTESTS="$(usex test)"
+ )
+ cmake_src_configure
+}