summaryrefslogtreecommitdiff
path: root/gnustep-base/mknfonts/mknfonts-0.5-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /gnustep-base/mknfonts/mknfonts-0.5-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'gnustep-base/mknfonts/mknfonts-0.5-r2.ebuild')
-rw-r--r--gnustep-base/mknfonts/mknfonts-0.5-r2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnustep-base/mknfonts/mknfonts-0.5-r2.ebuild b/gnustep-base/mknfonts/mknfonts-0.5-r2.ebuild
new file mode 100644
index 000000000000..b4e3d0b21090
--- /dev/null
+++ b/gnustep-base/mknfonts/mknfonts-0.5-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnustep-base
+
+DESCRIPTION="A tool to create .nfont packages for use with gnustep-back-art"
+HOMEPAGE="https://packages.debian.org/mknfonts.tool"
+SRC_URI="mirror://debian/pool/main/m/${PN}.tool/${PN}.tool_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ppc sparc x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE=""
+
+DEPEND="gnustep-base/gnustep-gui
+ >=media-libs/freetype-2.1"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-rename.patch )
+
+src_prepare() {
+ # Correct link command for --as-needed
+ sed -i -e "s/ADDITIONAL_LDFLAGS/ADDITIONAL_TOOL_LIBS/" GNUmakefile || die "sed failed"
+
+ default
+}