summaryrefslogtreecommitdiff
path: root/gui-apps/grim/grim-1.4.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /gui-apps/grim/grim-1.4.0-r1.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'gui-apps/grim/grim-1.4.0-r1.ebuild')
-rw-r--r--gui-apps/grim/grim-1.4.0-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/gui-apps/grim/grim-1.4.0-r1.ebuild b/gui-apps/grim/grim-1.4.0-r1.ebuild
new file mode 100644
index 000000000000..0883e35c818a
--- /dev/null
+++ b/gui-apps/grim/grim-1.4.0-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 meson
+
+DESCRIPTION="Grab images from a Wayland compositor"
+HOMEPAGE="https://github.com/emersion/grim"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/emersion/${PN}.git"
+else
+ SRC_URI="https://github.com/emersion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+man jpeg"
+
+DEPEND="
+ >=dev-libs/wayland-protocols-1.14
+ dev-libs/wayland
+ media-libs/libpng
+ x11-libs/pixman
+ jpeg? ( virtual/jpeg )"
+
+RDEPEND="${DEPEND}"
+BDEPEND="man? ( app-text/scdoc )"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature jpeg)
+ $(meson_feature man man-pages)
+ "-Dbash-completions=false"
+ "-Dfish-completions=false"
+ "-Dwerror=false"
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ newbashcomp contrib/completions/bash/grim.bash grim
+ insinto /usr/share/fish/vendor_completions.d/
+ doins contrib/completions/fish/grim.fish
+}