summaryrefslogtreecommitdiff
path: root/gui-apps/mako
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-27 00:07:23 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-27 00:07:23 +0100
commit3c1648a0749c1d66b300d857e6b417c1162890da (patch)
tree2b13f04c2c10d472e5bb7cc40fe6048bf8bc549d /gui-apps/mako
parent994fe442814c4d169bb0f1ee9745604928006b39 (diff)
gentoo auto-resync : 27:05:2024 - 00:07:23
Diffstat (limited to 'gui-apps/mako')
-rw-r--r--gui-apps/mako/Manifest4
-rw-r--r--gui-apps/mako/mako-1.9.0.ebuild70
-rw-r--r--gui-apps/mako/mako-9999.ebuild7
3 files changed, 76 insertions, 5 deletions
diff --git a/gui-apps/mako/Manifest b/gui-apps/mako/Manifest
index 9060a5c72d28..1100fa8a6663 100644
--- a/gui-apps/mako/Manifest
+++ b/gui-apps/mako/Manifest
@@ -1,4 +1,6 @@
DIST mako-1.8.0.tar.gz 63143 BLAKE2B da39c1d2a1748649432d2760831cee7c9b135114b8e36c48a87900d9a3610fc5103c15f2ed511344d84a3142aa76ddd3680177318d0e096ad0574952632dc0b7 SHA512 d187c00296f3c3d4fb2c5964a95e1ac6ab74deb7dc27633d8e8301d60d90e4dc92b0ee66953670c42a3c08160536a4126ee747214c4ea05a30a80fd5e2004ad0
+DIST mako-1.9.0.tar.gz 63415 BLAKE2B 932f045cede44f79e4039a40118cdd4283413f86524d74703e84a3bf999af58d9ee605054480d369a33f81c7fcaed60415cb203fd32a22333adc1e88876f6a33 SHA512 da9c89dc698e44100960c9911c9da59e6f3dd5e95c8c0fbc489c9597dd614bb46074170b9621eba6ff692eff140f7be11ecc9da1a285b8e5c0975b7b53daabee
EBUILD mako-1.8.0.ebuild 1352 BLAKE2B 4e7dcddcc153aca3cd5048830e0a3f5401e93e3409c4f67bf7e6be9893a01cb7222a8e77ff09e74fb1bb359b081dd8f238e16e2564833187ab583c2a8182c5ce SHA512 3a68407808e9022ebf0b5a97c5119d8eaa3e6cbf8f04cf8de88eb675f7976dd14afe1696508475980195bf59f8cac3f9e393d9498c539cbcf999b940299d44ef
-EBUILD mako-9999.ebuild 1348 BLAKE2B bd07cade08d52298c358b124589a080d49d1bfa7f4b88457ad1e84b4508178a66f77f65e94da410a3d8b00a90ef550f98be56634d4c3187c564c27f47934f0cb SHA512 45d5c24425dc28f52d40b3b6c6358bdbb2307ad27eeaefd3278d063a9b80b83b2f2d554342a9209c43e2bbcacc036f74eb8a43cc47e39d7b81e162a314a30d5b
+EBUILD mako-1.9.0.ebuild 1337 BLAKE2B 5333337da388c056d1186ea703c4385b49abb01cb01cb1056e5d9b9e69fb4fe3eb09de2cf508b2a0ecc7961328b4ad2b5827f011d710093a328c52ffb96d4955 SHA512 243217c4df859958ee2a4732c02bd491f66c22ccb4f942c974fac49dbe6f05c4678b814b2d9ee8931b7392d5e9826da08d389cad25adf656d37c9b6054839615
+EBUILD mako-9999.ebuild 1337 BLAKE2B 5333337da388c056d1186ea703c4385b49abb01cb01cb1056e5d9b9e69fb4fe3eb09de2cf508b2a0ecc7961328b4ad2b5827f011d710093a328c52ffb96d4955 SHA512 243217c4df859958ee2a4732c02bd491f66c22ccb4f942c974fac49dbe6f05c4678b814b2d9ee8931b7392d5e9826da08d389cad25adf656d37c9b6054839615
MISC metadata.xml 529 BLAKE2B 4f2efb156f415c6ac8c411f200ef91235304bb2b4cc794ccab638e401164964d8e0268f3ecba0f5dc59bd80c38d0af6fe90b8b8498c317fed041615e4d965ee3 SHA512 f7186a5e6122993c032d502103485093db262193834f568b19a3c19b3b5187e7cfc658c11a53fd47ebb57e091db8734e6f83c4cf99b740fd6f99478bc4275405
diff --git a/gui-apps/mako/mako-1.9.0.ebuild b/gui-apps/mako/mako-1.9.0.ebuild
new file mode 100644
index 000000000000..29e50118f3ba
--- /dev/null
+++ b/gui-apps/mako/mako-1.9.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson systemd
+
+DESCRIPTION="A lightweight notification daemon for Wayland. Works on Sway"
+HOMEPAGE="https://github.com/emersion/mako"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/emersion/${PN}.git"
+else
+ SRC_URI="https://github.com/emersion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="elogind +icons systemd"
+
+RDEPEND="
+ dev-libs/wayland
+ x11-libs/pango
+ x11-libs/cairo
+ || (
+ systemd? ( sys-apps/systemd )
+ elogind? ( sys-auth/elogind )
+ sys-libs/basu
+ )
+ sys-apps/dbus
+ icons? (
+ x11-libs/gdk-pixbuf
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ >=dev-libs/wayland-protocols-1.32
+"
+BDEPEND="
+ app-text/scdoc
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dicons=$(usex icons enabled disabled)
+ -Dzsh-completions=true
+ -Dfish-completions=true
+ -Dbash-completions=true
+ )
+
+ if use systemd ; then
+ emesonargs+=( -Dsd-bus-provider=libsystemd )
+ elif use elogind ; then
+ emesonargs+=( -Dsd-bus-provider=libelogind )
+ else
+ emesonargs+=( -Dsd-bus-provider=basu )
+ fi
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ systemd_douserunit contrib/systemd/mako.service
+}
diff --git a/gui-apps/mako/mako-9999.ebuild b/gui-apps/mako/mako-9999.ebuild
index 13a9eb711c00..29e50118f3ba 100644
--- a/gui-apps/mako/mako-9999.ebuild
+++ b/gui-apps/mako/mako-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -13,7 +13,7 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/emersion/${PN}.git"
else
SRC_URI="https://github.com/emersion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm64 ~x86"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
fi
LICENSE="MIT"
@@ -31,13 +31,12 @@ RDEPEND="
)
sys-apps/dbus
icons? (
- x11-libs/gtk+:3
x11-libs/gdk-pixbuf
)
"
DEPEND="
${RDEPEND}
- >=dev-libs/wayland-protocols-1.21
+ >=dev-libs/wayland-protocols-1.32
"
BDEPEND="
app-text/scdoc