summaryrefslogtreecommitdiff
path: root/gui-apps
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-07 06:41:06 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-07 06:41:06 +0000
commitd69399c7befdd98cda62d6a1788ae2aa7f104c5e (patch)
treeeac7184f4cfe7d67580c1d0a0d9942a91e6cb4ee /gui-apps
parente4d9d6796d5018e338f0b27a3bc97716195bf0b8 (diff)
gentoo auto-resync : 07:01:2025 - 06:41:06
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/Manifest.gzbin5065 -> 5065 bytes
-rw-r--r--gui-apps/qt6ct/Manifest2
-rw-r--r--gui-apps/qt6ct/qt6ct-0.9-r1.ebuild62
-rw-r--r--gui-apps/qt6ct/qt6ct-0.9.ebuild40
-rw-r--r--gui-apps/waybar/Manifest2
-rw-r--r--gui-apps/waybar/metadata.xml3
6 files changed, 66 insertions, 43 deletions
diff --git a/gui-apps/Manifest.gz b/gui-apps/Manifest.gz
index 872eb33e849f..52d9269478d1 100644
--- a/gui-apps/Manifest.gz
+++ b/gui-apps/Manifest.gz
Binary files differ
diff --git a/gui-apps/qt6ct/Manifest b/gui-apps/qt6ct/Manifest
index f799bbdf06c5..eb04d1db5fff 100644
--- a/gui-apps/qt6ct/Manifest
+++ b/gui-apps/qt6ct/Manifest
@@ -1,3 +1,3 @@
DIST qt6ct-0.9.tar.xz 75868 BLAKE2B 32c3cb641edcedc5a3c675e9f9541c1d8269f9b40ed3dff7da14ce6b2686302f3812ec365fc746bd872cba1a12bcee1a644e3bad5885ba7a27d3fe1de0693f01 SHA512 ea5242cc10d9d210e190dd442c72c9f75c6a13e50191ec164fc9772de0475ca39453f22b061cfe24e1face4d660159d491627b65f2637b5d611cfe5fb0ac228f
-EBUILD qt6ct-0.9.ebuild 1187 BLAKE2B c40025673daf88100a6a37c1c4f28142ab5ea0a9c6b16cabbf12456c0d4bf6235c73c2b00c395ed83b3009fa26c371db573b8b4cf122c42db50925b9df6a2bba SHA512 4d5ded09b425c35693391bd05099adaf36948cfc4e61e2a22fe5b08a1d3c828f99777a7ad466d90f1438b9ecbc01f7a27685f096afcb47a83cc19d95ebf4e083
+EBUILD qt6ct-0.9-r1.ebuild 1659 BLAKE2B 06780c60560827a7adf0065cd74745419e3786733b2492cceaa36822dda75c9d94593dcd1c5d41781cd750199f81f1ca62d795a352bf64dcb2fb581b37b9effd SHA512 41fb05c53e8b043a42cf2264d347ad857a92df627f1799602c0508473e688ee8b9202056a7f6e7092f988f418b8480478f1a820232cb4b622af2d5972c9f2957
MISC metadata.xml 328 BLAKE2B 0e3436b743292d8aaceb7474ba3a2ad22a5b0d81e18d2a2ec050a76d773da3736a1be17681d694bcbdbc2c6825639f35836db0ba75be526457af5ad2be29fa3d SHA512 8dd8edc8b55d76fcb5d6f3181783778a6b06fd22bafe0fafba033ef7981981620e9e29d0019ed39fd9b45bb202fddaf6d7f25b5150b81a1fc0054e79784249cc
diff --git a/gui-apps/qt6ct/qt6ct-0.9-r1.ebuild b/gui-apps/qt6ct/qt6ct-0.9-r1.ebuild
new file mode 100644
index 000000000000..2f798cf51885
--- /dev/null
+++ b/gui-apps/qt6ct/qt6ct-0.9-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 2023-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Qt6 Configuration Tool (for DE/WM without Qt integration)"
+HOMEPAGE="https://github.com/trialuser02/qt6ct/"
+SRC_URI="https://github.com/trialuser02/qt6ct/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64"
+
+# uses Qt private APIs wrt :=
+# dlopen: qtsvg
+DEPEND="
+ dev-qt/qtbase:6=[gui,widgets]
+"
+RDEPEND="
+ ${DEPEND}
+ dev-qt/qtsvg:6
+"
+BDEPEND="
+ dev-qt/qtbase:6
+ dev-qt/qttools:6[linguist]
+"
+
+src_install() {
+ cmake_src_install
+
+ # can replace after qt5ct is gone
+# newenvd - 98${PN} <<<'QT_QPA_PLATFORMTHEME=qt6ct'
+ newenvd - 98${PN} <<-EOF
+ # 'qt5ct' is recognized by both qt5ct and qt6ct to allow simultaneous usage
+ QT_QPA_PLATFORMTHEME=qt5ct
+ EOF
+}
+
+pkg_postinst() {
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog
+ elog "QT_QPA_PLATFORMTHEME has been set to enable ${PN} usage by"
+ elog "default. This will only come into effect after re-login into"
+ elog "the current desktop session(s)."
+ elog
+ elog "Note that ${PN} should not be used with DEs that do their own"
+ elog "integration (e.g. Plasma/KDE). Qt also has special handling"
+ elog "for Gnome which may or may not be better."
+ fi
+
+ # not a very important warning (at most could surprise users that had it
+ # installed but weren't really using it), can likely cleanup next version
+ if [[ ${REPLACING_VERSIONS##* } ]] &&
+ ver_test ${REPLACING_VERSIONS##* } -lt 0.9-r1
+ then
+ ewarn
+ ewarn "Note that ${PF} newly sets QT_QPA_PLATFORMTHEME globally"
+ ewarn "by default to use ${PN} (or qt5ct if it is installed)."
+ fi
+}
diff --git a/gui-apps/qt6ct/qt6ct-0.9.ebuild b/gui-apps/qt6ct/qt6ct-0.9.ebuild
deleted file mode 100644
index bb92d244d751..000000000000
--- a/gui-apps/qt6ct/qt6ct-0.9.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="Qt6 Configuration Tool (for DE/WM without Qt integration)"
-HOMEPAGE="https://github.com/trialuser02/qt6ct/"
-SRC_URI="https://github.com/trialuser02/qt6ct/releases/download/${PV}/${P}.tar.xz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="amd64"
-
-# uses Qt private APIs wrt :=
-DEPEND="dev-qt/qtbase:6=[gui,widgets]"
-RDEPEND="
- ${DEPEND}
- dev-qt/qtsvg:6
-"
-BDEPEND="
- dev-qt/qtbase:6
- dev-qt/qttools:6[linguist]
-"
-
-pkg_postinst() {
- if [[ ! ${REPLACING_VERSIONS} ]]; then
- elog "Note need to export QT_QPA_PLATFORMTHEME=qt6ct in the used environment"
- elog "for theming to take effect (not done automatically, may want to set in"
- elog "the HOME's shell initialization scripts, or use /etc/env.d followed by"
- elog "running env-update then re-login)."
- elog
- elog "If also using x11-misc/qt5ct, =qt5ct is alternatively recognized so it"
- elog "can be activated for both Qt5 and Qt6 at once."
- elog
- elog "Try disabling if experience startup crashes for some applications,"
- elog "may still be unstable (especially with newly released Qt versions)."
- fi
-}
diff --git a/gui-apps/waybar/Manifest b/gui-apps/waybar/Manifest
index 46d6d0fff892..e9f960fd0e6a 100644
--- a/gui-apps/waybar/Manifest
+++ b/gui-apps/waybar/Manifest
@@ -5,4 +5,4 @@ EBUILD waybar-0.10.4-r1.ebuild 2430 BLAKE2B 183403d7ae5cff41f7a91d7cd3803b2b10b3
EBUILD waybar-0.11.0-r1.ebuild 2479 BLAKE2B 65fe26b9879541785ec05042f147ba9cc2d134d3c36767c1df3303f08aef43a15d935094320358a386db850dceaa6b6c5b49561af12ab58624861457e914fb68 SHA512 c4d4398689ca014bb71e17c9ec5f817004b43365a3f5f9d5cb5c9a8da2b1d268fe106d2a5d6326d225b62918b879922e9116aa6740d45b674965c95891a110e9
EBUILD waybar-0.11.0.ebuild 2431 BLAKE2B 56d9efff56f8d23d1098c24a936d95e42f5fb31fe8ae2dbda6587af8984573fa0f4393fa8c231fd748978eb09852b7ce83d1ac38f81bad11d88e7de54740ab93 SHA512 682076b52d6451d731d8836333110ae9eadb75d64d4f93557a913e6edae5481e2bfef484ace50b028fb2d9d78a61d3563a1f4cc569268c4ed3509fcf8cd51cc5
EBUILD waybar-9999.ebuild 2439 BLAKE2B 211a5b24e74efcbf2a9b1b7859ee8aca051db4e82f4cfbd6e2f0af09e39403f6271304d7ee39b405c9ee5e4810cc3aa683158787993713deed66cd2f9248df53 SHA512 92a7c7451841e516601bc2b3b25cfdabfea439ad5739f81bf7be0ad419c5a3d529b8d7e8487232b5bb56f5e0a7f87d95b3032d81ae1d46e2db457b95d5d080cd
-MISC metadata.xml 1606 BLAKE2B a364eeb9464f58fcb379a290f774cbd067883134ecf3fc7cf978455cd3d8412c65bc9070ba856c183624e89c15b15f6fb5acaa64a15c3d94e39b047acfac3512 SHA512 5aae9c0808b8fc2be2693852894668aaa4f93939b2f88a3a8f0fe788650579974de860b4af5fb692d775e558876d1521882462ea670b84490811af52029c0056
+MISC metadata.xml 1658 BLAKE2B d38ec05f76e0b48d83ba44a207673a7a729894f48fbf5d02dd79b437d7945ad90e559617b8aaa8f892beaf0c7573e0d1f8c6a88451632d029e5fe8cf7f6d0f9a SHA512 8049542e1e120ce83ae75d10785747dbb615a6b38f180f2f54e9f43c97266bd88eeaccbafcfcc23f17a7367cc35deb64afae9b2fb109c4f0bc95a234b21a7121
diff --git a/gui-apps/waybar/metadata.xml b/gui-apps/waybar/metadata.xml
index b672f3d72644..f5aa99ba21fe 100644
--- a/gui-apps/waybar/metadata.xml
+++ b/gui-apps/waybar/metadata.xml
@@ -28,8 +28,9 @@
<flag name="wifi">Enable support for wifi/rfkill</flag>
</use>
<upstream>
- <remote-id type="github">Alexays/Waybar</remote-id>
<bugs-to>https://github.com/Alexays/Waybar/issues</bugs-to>
<changelog>https://github.com/Alexays/Waybar/releases</changelog>
+ <doc>https://github.com/Alexays/Waybar/wiki</doc>
+ <remote-id type="github">Alexays/Waybar</remote-id>
</upstream>
</pkgmetadata>