summaryrefslogtreecommitdiff
path: root/gui-libs/egl-wayland/egl-wayland-1.1.13.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-18 21:57:33 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-18 21:57:33 +0100
commit99c41a033e7745ed8aa9ffbf0f9e1e414e80da4a (patch)
treed7dd421828aea0525f9e8fad6380cdf6daf1ec04 /gui-libs/egl-wayland/egl-wayland-1.1.13.ebuild
parente903f5ad5c87da9f55a9c9fa0d0e5c531d25af3f (diff)
gentoo auto-resync : 18:10:2023 - 21:57:33
Diffstat (limited to 'gui-libs/egl-wayland/egl-wayland-1.1.13.ebuild')
-rw-r--r--gui-libs/egl-wayland/egl-wayland-1.1.13.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/gui-libs/egl-wayland/egl-wayland-1.1.13.ebuild b/gui-libs/egl-wayland/egl-wayland-1.1.13.ebuild
new file mode 100644
index 000000000000..3e137c76f3a3
--- /dev/null
+++ b/gui-libs/egl-wayland/egl-wayland-1.1.13.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="EGLStream-based Wayland external platform"
+HOMEPAGE="https://github.com/NVIDIA/egl-wayland/"
+SRC_URI="
+ https://github.com/NVIDIA/egl-wayland/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ dev-libs/wayland
+ x11-libs/libdrm
+ !<x11-drivers/nvidia-drivers-470.57.02[wayland(-)]
+"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/wayland-protocols
+ gui-libs/eglexternalplatform
+ media-libs/libglvnd
+"
+BDEPEND="dev-util/wayland-scanner"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.6-remove-werror.patch
+)
+
+src_install() {
+ meson_src_install
+
+ insinto /usr/share/egl/egl_external_platform.d
+ doins "${FILESDIR}"/10_nvidia_wayland.json
+}